Changing httpd.conf from port 80 to 8080

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Changing httpd.conf from port 80 to 8080

Postby ThomasW » 21. March 2009 22:25

I am running Windows Vista in 64-bit mode. I installed the XAMPP control panel and then edited the httpd.conf -- lines Listen 80 and ServerName localhost:80 to both be 8080. Saved the changes and restarted the XAMPP control panel.

The control panel still indicates that Apache is running on port 80 instead of the 8080 value I changed in the httpd.conf file. When I try to load http://localhost:8080/ or http://localhost/ in my IE web browser, the XAMPP welcome screen webpage does not load.

Have I installed XAMPP and Apache properly? How do I make Apache recognize and use the port 8080 based on the changes that I made to the httpd.conf file?

Thanks!
ThomasW
 
Posts: 3
Joined: 21. March 2009 22:13
Location: Los Angeles, CA

Re: Changing httpd.conf from port 80 to 8080

Postby Izzy » 21. March 2009 22:37

Ignore the message in the XAMPP Control Panel as it is hard coded with port 80.

What can you see if you go to http://127.0.0.1:8080

BTW after changing the Listen directive in the httpd.conf file you will always have to add :8080 at then end of any address for the server in your browser, so http://localhost will not work.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: Changing httpd.conf from port 80 to 8080

Postby ThomasW » 21. March 2009 23:13

Browsing to http://127.0.0.1:8080/ still returns an error that IE cannot display the webpage. As does the http://localhost/ and http://localhost:8080/

I've tried it both ways with using port 80 and port 8080.

I have also shut down and restarted Windows Vista between each change that I made to the httpd.conf file before I restarted the XAMPP control panel.
ThomasW
 
Posts: 3
Joined: 21. March 2009 22:13
Location: Los Angeles, CA

Re: Changing httpd.conf from port 80 to 8080

Postby Izzy » 21. March 2009 23:17

In the XAMPP Control Panel (XCP) is Apache and MySQL showing a green running indication?

If so, then clear your browser's cache as you may be receiving a cached page.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: Changing httpd.conf from port 80 to 8080

Postby ThomasW » 22. March 2009 00:44

Yes. Under "Modules" both the Apache and MySql are marked with a green "Running" indication.

On Vista, I am running Windows Firewall. I checked the Exemptions settings on Firewall for allowing what programs can run during Firewall and Apache HTTP Server is in the list and has a checkmark in the box indicating that it is being allowed to run.

Are there any other Windows options or settings that I should be changing so that the XAMPP welcome screen can open and run?

Thanks!
ThomasW
 
Posts: 3
Joined: 21. March 2009 22:13
Location: Los Angeles, CA

Re: Changing httpd.conf from port 80 to 8080

Postby Izzy » 22. March 2009 00:55

Make sure in your firewall that all the ports that XAMPP uses are allowed through.
xampp-portcheck.exe will give you the ports and make sure they are only occupied by the XAMPP components that are running - if you try this portcheck with the Apache and MySql stopped then they should all show free.

What do you see if you go to http://localhost:8080/xampp/index.php or http://127.0.0.1:8080/xampp/index.php after you changed the Listen directive.

If you can I would revert your httpd.conf file back to the defaults that you had when you installed XAMPP then we can dispense with the 8080 bit and then, after we get it up and running, you can change the Listen directive if you need to, it makes it easier to troubleshoot.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 92 guests