(OS 10048)Only one usage of each socket...

Problems with the Windows version of XAMPP, questions, comments, and anything related.

(OS 10048)Only one usage of each socket...

Postby TheFinalBob » 18. March 2009 21:19

Error when I run apache_start.bat

Code: Select all
Apache 2 is starting ...
(OS 10048)Only one usage of each socket address (protocol/network address/port)
is normally permitted.  : make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs

Apache konnte nicht gestartet werden
Apache could not be started
Press any key to continue . . .


Please help if you know what's going on
TheFinalBob
 
Posts: 3
Joined: 18. March 2009 21:17

Re: (OS 10048)Only one usage of each socket...

Postby Nobbie » 18. March 2009 22:02

There is already running a webserver, usually its Microsoft IIS. Stop it and try again.
Nobbie
 
Posts: 6502
Joined: 09. March 2008 13:04

Re: (OS 10048)Only one usage of each socket...

Postby TheFinalBob » 18. March 2009 23:54

I have disabled everything that I thought could be interfering and I still get the error. Is there any way I can check to see which process or what is not allowing me to start apache?
TheFinalBob
 
Posts: 3
Joined: 18. March 2009 21:17

Re: (OS 10048)Only one usage of each socket...

Postby Izzy » 19. March 2009 00:28

Skype may be the other reason as it uses port 80 and port 443.

Run xampp-portcheck.exe found in the xampp folder and see what is using the ports and if it says SYSTEM is using the ports then check out this post:
viewtopic.php?p=135356#p135356
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: (OS 10048)Only one usage of each socket...

Postby TheFinalBob » 19. March 2009 00:42

Izzy wrote:Skype may be the other reason as it uses port 80 and port 443.

Run xampp-portcheck.exe found in the xampp folder and see what is using the ports and if it says SYSTEM is using the ports then check out this post:
viewtopic.php?p=135356#p135356


Ah, it was Skype! Thanks a billion, works perfectly now.
TheFinalBob
 
Posts: 3
Joined: 18. March 2009 21:17

Re: (OS 10048)Only one usage of each socket...

Postby Izzy » 19. March 2009 00:49

TheFinalBob wrote:Ah, it was Skype! Thanks a billion, works perfectly now.
You can have Skype use other ports so you can have both XAMPP and Skype running at the same time.

Run Skype and go to:
Tools\Options\Connection

Untick
Use port 80 and 443 as alternative for incoming connections

You will have to decide a different port to use for incoming connections before Skype lets you save your changes.

Use a port number between 49152 through 65535.

Good luck and thanks for posting back with your solution.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: (OS 10048)Only one usage of each socket...

Postby acker » 25. July 2013 13:45

NI Application Web Server service under Windows 7 can cause the same problem. As soon as you stop the service Apache starts up smoothly.
acker
 
Posts: 1
Joined: 25. July 2013 13:41
XAMPP Version: 5.6.3
Operating System: Windows 7


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 35 guests