Mysql Security

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Re: Mysql Security

Postby Abycats312 » 31. March 2009 04:18

Adding the http:// makes no difference, except when I include the :80, it disappears when I hit enter. Otherwise, still a request error.

Thank you for all your help; I've gotta get some sleep so I can homeschool 7 kids tomorrow. I'll try any fixes you post between teaching addition tables and multiplication tables.

Here's the Hosts file:

# Copyright (c) 1993-2006 Microsoft Corp.
#
# This is a sample HOSTS file used by Microsoft TCP/IP for Windows.
#
# This file contains the mappings of IP addresses to host names. Each
# entry should be kept on an individual line. The IP address should
# be placed in the first column followed by the corresponding host name.
# The IP address and the host name should be separated by at least one
# space.
#
# Additionally, comments (such as these) may be inserted on individual
# lines or following the machine name denoted by a '#' symbol.
#
# For example:
#
# 102.54.94.97 rhino.acme.com # source server
# 38.25.63.10 x.acme.com # x client host

127.0.0.1 localhost
#::1 localhost
Abycats312
 
Posts: 15
Joined: 28. March 2009 16:44

Re: Mysql Security

Postby Izzy » 31. March 2009 04:30

OK, it's early afternoon here so I will see what I can find in the mean time as I have not encountered this issue before.

Can you put a space after the hash and save the file and try again but I don't think it will make any difference.

#[space here]::1 localhost

To eliminate it being browser related do you have another browser to test it with - Firefox for example, or Opera perhaps?


Can you ping 127.0.0.1

Go to start>Run...
type
cmd
click OK

A console window opens

type
cd C:\Windows\system32
hit enter
next type
ping 127.0.0.1
hit enter

Should look something like this
Code: Select all
C:\WINDOWS\system32>ping 127.0.0.1

Pinging 127.0.0.1 with 32 bytes of data:

Reply from 127.0.0.1: bytes=32 time<1ms TTL=128
Reply from 127.0.0.1: bytes=32 time<1ms TTL=128
Reply from 127.0.0.1: bytes=32 time<1ms TTL=128
Reply from 127.0.0.1: bytes=32 time<1ms TTL=128

Ping statistics for 127.0.0.1:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 0ms, Maximum = 0ms, Average = 0ms

C:\WINDOWS\system32>
To copy and paste what you see click on the tiny c:\ icon top left of the console window.
A menu will show.
Click on the Edit item and you will see Mark.
Select it then go to the window and drag you mouse over what you want to copy.
Back to the menu and select Copy.
Now back to the forum reply box, right click in the box and select Paste from the context menu.
Job done.


Just spent several hours trying to find what may be the issue here but nothing came up that related directly except the following link that was referenced from someone who had similar issues that recommended to reinstall TCP/IP:
http://www.zimbio.com/Windows+Vista/art ... ol+Windows

You may also look at disabling IPv6 (Google it) and see if that helps because normally with IPv6 uncommented in the Hosts file you can access 127.0.0.1 but not localhost - XAMPP uses IPv4.

Sorry I can't be much help as I have exhausted every avenue to resolve this issue - IMHO and if it helps it is definitely PC related now not an XAMPP issue.

There is a new version of XAMPP 1.7.1 due to be release after the beta testing which is at stage 4 of usually 6 stages and this new release may or may not improve the situation.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: Mysql Security

Postby Abycats312 » 31. March 2009 19:51

Microsoft Windows [Version 6.0.6000]
Copyright (c) 2006 Microsoft Corporation. All rights reserved.

C:\Users\John>cd C:\Windows\system32

C:\Windows\System32>ping 127.0.0.1

Pinging 127.0.0.1 with 32 bytes of data:

Reply from 127.0.0.1: bytes=32 time<1ms TTL=128
Reply from 127.0.0.1: bytes=32 time<1ms TTL=128
Reply from 127.0.0.1: bytes=32 time<1ms TTL=128
Reply from 127.0.0.1: bytes=32 time<1ms TTL=128

Ping statistics for 127.0.0.1:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 0ms, Maximum = 0ms, Average = 0ms

C:\Windows\System32>

You're right, adding the space in the Hosts file made no difference.

I've downloaded Firefox. Part of the problem is solved. I no longer get the request error. However, I still can't get into the security console. I just get the Security check table, like when I've typed in localhost.

Since the problem has been with security (who knows what else, since I haven't gotten any farther), I went on the Joomla! forum to check if XAMPPlite would work ok since there is no security there. The only answer I've gotten so far suggested WAMP for windows. I may try that, but of course if it's a pc issue....

I went ahead and uninstalled XAMPP and thought I might reinstall now that I have Firefox working. I'm waiting to hear back on the Joomla! forum and also if you had any other insights.

I did the ping after uninstalling, so it might not be accurate. I wasn't sure. If you'd like, I could do the reinstall and ping again. Since my screen looked like your sample, I thought perhaps it worked right.

Thank you, thank you! I owe you about a thousand batches of chocolate chip cookies! The edible kind, not the spyware kind.

Cynthia
Abycats312
 
Posts: 15
Joined: 28. March 2009 16:44

Re: Mysql Security

Postby Izzy » 01. April 2009 09:10

Cynthia, please try this and tell me what happens.

Go to http://localhost/security

When you get to the screen with the tables and the menu in the left frame click on the Security menu item - these pages can take some time to load so be patient.

Also make sure you have JavaScript enabled in your browsers.

I have been able to replicate this in 1.7.0 by doing the above, I get to the table page then have to select Security to see the rest of the page.

This does not occur in my 1.6.8 version but does need you to click on the Security menu item in the 1.7.0 and the 1.7.1 beta version so the developers may have modified the security pages in these later versions.

Good luck. :)
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: Mysql Security

Postby Abycats312 » 02. April 2009 17:57

I tried clicking the Security tab repeatedly (waiting for it to load before each subsequent click--yes, it takes a long time to load). Every time, I've only gotten the security check table, no security console. And yes, I have Javascript enabled.

I wish it worked, especially after all the time we have both put into this. What I've done now is install WAMP and Joomla!. So far, it is working smoothly, but I haven't had a whole lot of time to really play with Joomla!, so time will tell.

For whatever reason, XAMPP doesn't seem to like my pc! But of course, computers are only as good as those who are using them. Wonder what that says about me???

You have been an amazing help and troubleshooter. Keep it up with all us needy newbies!

Cynthia
Abycats312
 
Posts: 15
Joined: 28. March 2009 16:44

Re: Mysql Security

Postby Izzy » 03. April 2009 00:16

Try going direct to the Security console using:
http://localhost/security/xamppsecurity.php

The rest of the page that won't seem to load for you looks like this:
Code: Select all
 The green marked points are secure; the red marked points are definitively unsecure and the yellow marked points couldn't be checked (for example because the sofware to check isn't running).

To fix the problems for mysql, phpmyadmin and the xampp directory simply use

=> http://localhost/security/xamppsecurity.php <=   [allowed only for localhost]
 
 
Some other important notes:

    * All these test are made ONLY for host "localhost" (127.0.0.1).
    * For FileZilla FTP und Mercury Mail, you must fix all security problems by yourself! Sorry.
    * If your computer is not online or blocked by a firewall, your servers are SECURE against outside attacks.
    * If servers are not running, these servers are although SECURE!

Please consider this: With more XAMPP security some examples will NOT execute error free. If you use PHP in "safe mode" for example some functions of this security frontend will not working anymore. Often even more security means less functionality at the same time.
 

The XAMPP default ports:

ftp         21/tcp         # File Transfer [Control] (XAMPP: FTP Default Port)
smtp         25/tcp         mail # Simple Mail Transfer (XAMPP: SMTP Default Port)
http         80/tcp         # World Wide Web HTTP (XAMPP: Apache Default Port)
pop3         110/tcp         # Post Office Protocol - Version 3 (XAMPP: POP3 Default Port)
imap         143/tcp         # Internet Message Access Protocol (XAMPP: IMAP Default Port)
https         443/tcp         # http protocol over TLS/SSL (XAMPP: Apache SSL Port)
mysql         3306/tcp         # MySQL (XAMPP: MySQL Default Port)
AJP/1.3         8009         # AJP/1.3 (XAMPP: Tomcat AJP/1.3 Port)
http-alt         8080/tcp         # HTTP Alternate (see port 80) (XAMPP: Tomcat Default Port)

 
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Previous

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 62 guests