Intranet setup problems

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Intranet setup problems

Postby stephenbh » 17. March 2009 06:16

Hi guys :)

I am a volunteer for an ADRA community centre in a suburb of Brisbane, Qeensland, Australia.

We have about 20 computers we use for free computer education for the community.

I would like to install dokeos on one of our computers to show the centre manager the advantages of self paced computer training.

So I have a windows xp home edition computer with service pack 3
Its a p4 3ghz
1gb ram
tons of hard drive space

also runs avg anti virus uses port 80 for updates
realvnc remote desktop software with works on ports 5800 and 5900

I have installed xampp 1.7 with no problems
I unpacked dokeos 1.8.5 into c:\xampp\htdocs\dokeos

and then ran the dokeos web based installer with no problems

If I load http://localhost in ie or firefox on the computer running apache, I get the xampp conf page and everything works great

If I load http://localhost/dokeos on the computer running apache, I get the dokeos web appllication and everything works great

If I try to access from another computer with the ip address of the computer running apache, for example http://10.1.1.8 the xampp interface loads correctly and all links work correctly, except for a few which say i dont have permission

The xampp interface links that denny access from another computer on the lan are
security - which reports
---------------------------
Access forbidden!
You don't have permission to access the requested object. It is either read-protected or not readable by the server.

If you think this is a server error, please contact the webmaster.

Error 403
10.1.1.8
03/17/09 14:57:20
Apache/2.2.11 (Win32) DAV/2 mod_ssl/2.2.11 OpenSSL/0.9.8i mod_autoindex_color PHP/5.2.8
---------------------------

CD Collections - which reports
---------------------------
FORBIDDEN FOR CLIENT 10.1.1.15
---------------------------

Phone book - which reports
---------------------------
FORBIDDEN FOR CLIENT 10.1.1.15
---------------------------

ADOdb - which reports
---------------------------
FORBIDDEN FOR CLIENT 10.1.1.15
---------------------------

Mercury Mail - which reports (Yes its running in the control panel)
---------------------------
FORBIDDEN FOR CLIENT 10.1.1.15
---------------------------

The main Problem I am experiencing is that if I try to access dokeos from another computer with http://10.1.1.8/dokeos > Pictures and style Sheets are not displayed! < I did find a reference to this in the FAQ's but found that the suggestion did not help

I have made the following changes to the httpd.conf file and will document the results.
This is how I found the relevent settings by default, both settings were uncommented
---------------------------
EnableSendfile off
EnableMMAP off
---------------------------
changing them to the suggested
---------------------------
EnableSendfile offstage
EnableMMAP offstage
---------------------------
caused the apache server to fail to restart giving an error that these must be set to off or on
So I tryed
---------------------------
EnableSendfile off
EnableMMAP off
---------------------------
and
---------------------------
EnableSendfile on
EnableMMAP on
---------------------------
and
---------------------------
# EnableSendfile on
# EnableMMAP on
---------------------------

And the problem is still unresolved.
The faq references a program called netlimiter, this is not present in services or add / remove programs

Any suggestions would be greatly appreciated as this is my first go at apache.
stephenbh
 
Posts: 1
Joined: 17. March 2009 05:14

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 48 guests