Multiple apache processes running

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Multiple apache processes running

Postby coaster » 17. March 2009 04:01

Hi - I just upgraded to the newest release of xampp Apache for Windows and I just noticed that I have two instances of the apache process in my Task Manager process list, each with its own process ID, both using about the same amount of memory resources. Apache is run as an application, not as a service. Before the upgrade I only remember seeing one. I'm only running MySQL, and it's run as an app and not as a service as well. I did do a complete uninstall of the previous version, including deleting the xampp folder. The new version was installed using the executable Windows installer.

Is this normal? Or do I have a problem? It seems to be serving localhost just fine, though of course, if it's using twice the memory resources it should.

Thanks.....
coaster
 
Posts: 3
Joined: 10. May 2008 03:40

Re: Multiple apache processes running

Postby Izzy » 17. March 2009 04:13

coaster wrote:Is this normal?
This is perfectly normal behavior.

There is always two apache.exe processes running, one of them being just a thin wrapper around the other.

Apache uses two processes as a failsafe and optimization mechanism, a parent process with a child process that handles the client requests.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: Multiple apache processes running

Postby coaster » 17. March 2009 05:40

OK, I guess I don't remember seeing the second one previously. When you say one is a wrapper around the other, what you mean is that the memory usage of the child process is included in the memory usage of the parent process? i.e. if process #311 is apache.exe using 28,000K and process #3303 is apache.exe using 25,000K then the actual total memory usage of both is 28,000K because #3303 is included in #311? (process ID's and memory usage fictional). Hmmmm.....learned something new about how Task Manager reports memory usage. :)

Thanks....
coaster
 
Posts: 3
Joined: 10. May 2008 03:40

Re: Multiple apache processes running

Postby Izzy » 17. March 2009 06:08

Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: Multiple apache processes running

Postby coaster » 17. March 2009 13:46

Izzy, thanks for the link. ;)
coaster
 
Posts: 3
Joined: 10. May 2008 03:40

Re: Multiple apache processes running

Postby Izzy » 17. March 2009 23:06

coaster wrote:Izzy, thanks for the link. ;)
Your welcome. :)
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 46 guests