Problems with the Port 80

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Problems with the Port 80

Postby chetos » 15. March 2009 23:10

Hi, this is my problem: When i finish instal Xampp and it is searching for the ports for Mysql and Apache this appears:
errorxamp.png
How can ia fix this? or how i can change the port that use Apache? (in this case the port 80). By the Way i hava a Router ADSL2 Dlink dsl 2640t
I Have the same Problem when i install the xampp 1.7
Last edited by chetos on 15. March 2009 23:19, edited 2 times in total.
chetos
 
Posts: 4
Joined: 15. March 2009 23:02

Re: Problems with the Port 80

Postby Izzy » 15. March 2009 23:26

You have some other server on port 80 and port 443.

Run xampp-portcheck.exe found in the xampp folder and see what is using those ports and then disable them so XAMPP can work.

Usually Skype or IIS are at fault.

Change the ports Skype uses in Skype's configuration.
Disable IIS from the Windows Control Panel.
(IIS is inetserv or Windows Internet Information Server)


BTW your image is too big - kindly reduce the size so there is no need to horizontal scroll as it is a pain for the reader.
Thanks
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: Problems with the Port 80

Postby chetos » 16. March 2009 00:50

It seems okay but i push the start button on the apache service in the Xampp control panel and nothing happen, appear "Apache service started" but it isnt.
portchek.png

(Mod: Please use the URL button for such big pictures)
chetos
 
Posts: 4
Joined: 15. March 2009 23:02

Re: Problems with the Port 80

Postby Izzy » 16. March 2009 01:11

Remove the tick in the Svc box in the XCP then try and Start Apache.

Also try xampp\start_apache.bat file to see if you get an error message why apache fails to start.

BTW what version of Windows?

Where did you install XAMPP? - exact path please.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: Problems with the Port 80

Postby chetos » 16. March 2009 03:19

When i remove the tick its runs for 1or 2 seconds and get off, the image of the star_apache is here:
http://img25.imageshack.us/img25/1575/ecoul.png
Version of Windows : XP Professional SP2
Ubication of the Xamp: C:\Documents and Settings\user\Escritorio\Jorge\Investigaciòn\xamp\xampp
chetos
 
Posts: 4
Joined: 15. March 2009 23:02

Re: Problems with the Port 80

Postby Izzy » 16. March 2009 03:37

It is best to install XAMPP to the root of your drive like C:\ then the install will go in C:\xampp which is the default.

Did you run setup_xampp.bat file in the xampp folder after installing XAMPP so the paths will be set as outlined in the xampp\readme_en.txt file?

If not then run it now by double clicking on the setup_xampp.bat file then try and start Apache again.

The error message from the apache_start.bat file is telling me that the path to the ServerRoot on line 42 of the httpd.conf file is not correct which should be corrected by running the setup_xampp.bat file.

Let me know if that fixes your issue of Apache not starting.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: Problems with the Port 80

Postby chetos » 20. March 2009 02:53

THANKS SO MUCH I FIXED IT , THANK YOU!
chetos
 
Posts: 4
Joined: 15. March 2009 23:02

Re: Problems with the Port 80

Postby Izzy » 20. March 2009 02:57

Your welcome and thanks for posting back that it is now fixed.

Good luck and please enjoy your XAMPP experience.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 46 guests