Lost all my privileges

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Lost all my privileges

Postby potain » 14. March 2009 07:50

Hi

After installing version 1.7, I had a "Incorrect key file for table 'pma_history'" error and fixed it by emptying the pma_history table but I have also lost all the table privileges.

Any idea of how I can can get them back?

Thanks
potain
 
Posts: 9
Joined: 14. April 2006 04:50
Location: Brisbane Australia

Re: Lost all my privileges

Postby Izzy » 14. March 2009 08:56

Can you still go to http://localhost/phpmyadmin

If you can, when you click on the Privileges tab down at the bottom of the page do you see this message:
Note: phpMyAdmin gets the users' privileges directly from MySQL's privilege tables. The content of these tables may differ from the privileges the server uses, if they have been changed manually. In this case, you should reload the privileges before you continue.
The reload the privileges has a link attached if you click on it.

The link in my page is:
http://localhost/phpmyadmin/server_privileges.php?&flush_privileges=1

Don't know if that helps but let me know if it does.

Also the privileges are stored in the mysql database in the left column in the tables_priv


If that all fails then because you have upgraded to 1.7.0 did you run the mysql_upgrade.exe file to upgrade all your databases -
a poster wrote:The original update instructions from XAMPP are not correct.

The only thing you must do is (we assume that MySQL is running) from a command prompt in the mysql\bin folder type:

mysql_upgrade.exe --force -u root -p -t "%TEMP%"

Use this exact command and if your "root" does not have a password, just hit "return" for the password question.

Now restart MySQL.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 37 guests