Page 1 of 1

FEDERATED storage engine

PostPosted: 13. March 2009 15:21
by lnoll
I'm trying to use the FEDERATED storage engine with xampp mysql version 5.1.30-community. The documentation says FEDERATED is available starting with version 5.0.3, but as of 5.0.64 it is not enabled by default. I tried adding the --federated switch to the command line in the service properties (HKLM\SYSTEM\CurrentControlSet\Services\mysql\ImagePath) but that results in the MySql service not being able to start. How can I enable FEDERATED?


Re: FEDERATED storage engine

PostPosted: 13. March 2009 16:15
by Wiedmann
IMHO there is an option in "my.cnf" (but never used this myself)

Re: FEDERATED storage engine

PostPosted: 13. March 2009 22:22
by lnoll
After some search-engine help and a lot of floundering around here is what I found. Maybe not all steps are necessary. Maybe they are.

In My.cnf (add and commented out):


Reinstall xampp.


This got FEDERATED installed. However, the first times I tried to create a FEDERATED table from phpAdmin, all of the tables in my local database disappeared. Fortunately, they did not disappear in Toad for MySql. I deleted the newly created FEDERATED table and tried again.
The first (unsuccessful times) I used the connection string format: CONNECTION='mysql://fed_user@remote_host:9306/federated/test_table'; per the example in the MySql documentation ( ... ction.html).

My successful connection string format was: CONNECTION='mysql://fed_user:password@remote_host:3306/federated/test_table';

NOTE: When I later changed the structure of the remote table, all of the tables in the local phpAdmin display again disappeared until I deleted the FEDERATED table pointing to the changed remote table (using Toad for MySql). This didn't always happen but it was startling at first and is still annoying. More than likely there is a logical explanation.

Hope this helps someone.