[SOLVED] XAMPP on USB => localhost & php pages don't display

Problems with the Windows version of XAMPP, questions, comments, and anything related.

[SOLVED] XAMPP on USB => localhost & php pages don't display

Postby miguipda » 11. March 2009 11:38

Hi,

can somebody tell me how to get XAMPP working on a USB key.
I download the last 1.7 version on my USB. I unpacked it in the folder xampp on the root of my USB key.

I run xampp_start.exe (due to the fact I don't want to install it on each computer).
I checked the status where mysql is well running. Apache status stay at 0. If I click on start it runs it and the green running text disappeared. Status stay apache to 0 and mysql to 1.

How can I solve it ?

Have a nice day,

Miguipda ;-)
Last edited by miguipda on 12. March 2009 14:43, edited 1 time in total.
miguipda
 
Posts: 6
Joined: 12. April 2007 10:12

Re: XAMPP on USB => localhost and php pages don't display

Postby Wiedmann » 11. March 2009 11:47

Apache status stay at 0. If I click on start it runs it and the green running text disappeared.

Use "apache_start.bat" and read the error message.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: XAMPP on USB => localhost and php pages don't display

Postby miguipda » 11. March 2009 12:54

Hi,

please find here below the received error. Sincerely thanks for your help.

Microsoft Windows XP [Version 5.1.2600]
(C) Copyright 1985-2001 Microsoft Corp.

U:\>f:

F:\>cd xampp

F:\xampp>apache_start.bat
Diese Eingabeforderung nicht waehrend des Running beenden
Bitte erst bei einem gewollten Shutdown schliessen
Please close this command only for Shutdown
Apache 2 is starting ...
(OS 10048)Only one usage of each socket address (protocol/network address/port)
is normally permitted. : make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs

Apache konnte nicht gestartet werden
Apache could not be started
Press any key to continue . . .
miguipda
 
Posts: 6
Joined: 12. April 2007 10:12

Re: XAMPP on USB => localhost and php pages don't display

Postby Wiedmann » 11. March 2009 12:56

(OS 10048)Only one usage of each socket address (protocol/network address/port)
is normally permitted. : make_sock: could not bind to address 0.0.0.0:80

There is already a server running. Stop this, and you can start XAMPP/Apache.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: XAMPP on USB => localhost and php pages don't display

Postby miguipda » 11. March 2009 13:25

I though that there was already a running apache.
That's why I executed tha apache_stop.exe and exit apache_control.exe.

I just reboot. I executed apache_start.exe. = same situation : mysql running, apache nothing. I checked the status. Idem : apache 0 and mysql 1
I reused apache_stop. and start. no changes
I tried restart : no changes.

Then why one apache instance stay active even if I stop xampp or stop apachae with the .bat file. Even if I reboot.
When I use the apache_stop.bat I receive this error :

F:\xampp>apache_stop.bat
pv: No matching processes found

Thx.
miguipda
 
Posts: 6
Joined: 12. April 2007 10:12

Re: XAMPP on USB => localhost and php pages don't display

Postby Wiedmann » 11. March 2009 14:20

I though that there was already a running apache.

No: There is an other server running. This must not be an Apache.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: XAMPP on USB => localhost and php pages don't display

Postby miguipda » 11. March 2009 14:36

Then I presume there are no solution ...

Otherwise how can I do. It is on a local computer without any server... I don't understand which web server can run and how to remove it.

Have a nice day.
miguipda
 
Posts: 6
Joined: 12. April 2007 10:12

Re: XAMPP on USB => localhost and php pages don't display

Postby Wiedmann » 11. March 2009 15:04

Then I presume there are no solution ...

Sure. Find the other server with xampp-portcheck or tcpview or netstat, stop it, and start XAMPP/Apache.

(BTW: It's your pc. You should really know what happens on you box.)
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: XAMPP on USB => localhost and php pages don't display

Postby miguipda » 11. March 2009 15:11

Hi,

here is the result of my xampp-portcheck (in fact it seems apache is running for inet) :

***************************************************************
* XAMPP PortCheck v1.2 *
* *
* (c) 2005 Carsten Wiedmann <info@wiedmann-online.de> *
* *
* This script uses openport.exe: *
* (c) 2003 DiamondCS <http://www.diamondcs.com.au/openports/> *
***************************************************************

Please wait a moment...


RESULT
------

Service Port Status
==============================================================================
Apache (HTTP) 80 C:\WINDOWS\system32\inetsrv\inetinfo.exe
Apache (WebDAV) 81 free
Apache (HTTPS) 443 C:\WINDOWS\system32\inetsrv\inetinfo.exe

MySQL 3306 free

FileZilla (FTP) 21 free
FileZilla (Admin) 14147 free

Mercury (SMTP) 25 C:\WINDOWS\system32\inetsrv\inetinfo.exe
Mercury (POP3) 110 free
Mercury (IMAP) 143 free

Press <Return> to continue.


And tcpview doesn't work :
Microsoft Windows XP [Version 5.1.2600]
(C) Copyright 1985-2001 Microsoft Corp.

U:\>tcpview
'tcpview' is not recognized as an internal or external command,
operable program or batch file.

Thx.
miguipda
 
Posts: 6
Joined: 12. April 2007 10:12

Re: XAMPP on USB => localhost and php pages don't display

Postby Wiedmann » 11. March 2009 16:09

(in fact it seems apache is running for inet) :

No. The software "inetinfo.exe" is using the Apache port 80.

"inetinfo.exe" = Internet Information Service from Windows.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

[SOLVED] XAMPP on USB => localhost & php pages don't display

Postby miguipda » 12. March 2009 14:45

How to kill inetpub use =
Right click on my computer => Manage => services => right click on IIS admin => stop

Have a nice day,

Miguipda ;-)
miguipda
 
Posts: 6
Joined: 12. April 2007 10:12


Return to XAMPP for Windows

Who is online

Users browsing this forum: Bonniem and 60 guests