Resolving a domain?

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Resolving a domain?

Postby abandonwareguru » 10. March 2009 02:17

I'm completely new to this and can't seem to find any information on how to get this working.

Here's my situation:

-ISP has port 80 blocked
-I have a domain name under DynDNS
-Port TCP 8080 is forwarded correctly

I want people to type in my domain name, onions.selfip.net, and have it resolve to my IP address at port 8080 because the ISP blocks port 80.

I have added the line "Listen 8080" to httpd.conf, and Apache is now listening to ports 80 and 8080 according to netstat -ao.

My index page shows up fine when I go to http://localhost/, but other people can't access my server externally. I hear I might have to set up a virtual host, but I don't know the first thing about how that works. What exactly do I need to do for people to access my page over the internet?
abandonwareguru
 
Posts: 5
Joined: 10. March 2009 01:58

Re: Resolving a domain?

Postby Izzy » 10. March 2009 02:37

In httpd.conf file change Listen 8080 to Listen *:8080 which has been known to help and also make sure in your router that you have forwarded port 8080 and check with DynDNS that your address is to port 8080.

Don't forget to save the file after editing and use a text editor and also restart Apache after saving the file.

When I try you address I get a Timed out error and is your IP 72.73.90.205
Last edited by Izzy on 12. March 2009 08:06, edited 1 time in total.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: Resolving a domain?

Postby abandonwareguru » 10. March 2009 03:33

I've edited httpd.conf as you suggested. TCP 8080 is forwarded correctly. My IP is currently 72.73.90.205 as you said, but it's subject to change any time my ISP feels like it, hence the need for a service like DynDNS.

It's my understanding that a DNS service doesn't deal with ports at all, however. In fact, when I use ZSNES for netplay, I have people connect to onions.selfip.net:27015 and it works fine.

Since HTTP traffic goes through port 80 by default, do I need the Listen 80 line as well? I currently have these two lines in httpd.conf:

Listen *:80
Listen *:8080

Since my ISP blocks port 80, I haven't forwarded that, but 8080 IS forwarded correctly. However, while looking things over, 8080 seems to be blocked by my ISP as well. I get a "connection timed out" response from canyouseeme.org, but if I have Apache listen on port 16800 when forwarded I get a successful result. So instead I now have

Listen *:80
Listen *:16800

Which seems to work correctly now. Do I need to do anything with a virtual host for people to access my site? For instance:

NameVirtualHost 192.168.1.47
<VirtualHost 192.168.1.47>
DocumentRoot /html
Servername onions.selfip.net
</VirtualHost>

The information I found prior to this was very vague. Should NameVirtualHost should be set to my LAN IP, correct? Or is using a virtualhost completely unnecessary?
abandonwareguru
 
Posts: 5
Joined: 10. March 2009 01:58

Re: Resolving a domain?

Postby Izzy » 10. March 2009 04:07

abandonwareguru wrote:So instead I now have

Listen *:80
Listen *:16800
You only need Listen *:16800 and it would seem that your ISP also blocks port 8080.

Return this to Listen *:80 only if using the vhosts file.

abandonwareguru wrote:Which seems to work correctly now. Do I need to do anything with a virtual host for people to access my site?
No need if your web site is located within the xampp\htdocs folder...
...but when I try your site with the new port I get access forbidden because your web site files may not be stored within the htdocs folder.

No big deal, so if you want to use a virtualhost then try the following in the apache\conf\extra\httpd-vhosts.conf file but change your paths to suit your own XAMPP paths - I have used the defaults and guessed at your web site path based on your post and return the httpd.conf file to the installed defaults as we will override them in the vhosts config file:
Code: Select all
NameVirtualHost *:80
<VirtualHost *:80>
ServerName localhost
DocumentRoot "C:/xampp/htdocs"
</VirtualHost>


Listen *:16800
NameVirtualHost *:16800

<VirtualHost *:16800>
DocumentRoot "C:\html"
Servername onions.selfip.net
<Directory "C:\html" >
Options Indexes FollowSymLinks Includes ExecCGI
AllowOverride All
Order allow,deny
Allow from all
</VirtualHost>
You will notice we have moved the Listen directive from the httpd.conf file to the httpd-vhosts.conf file.
Save the file and restart apache and do this always when editing conf or ini files in XAMPP.

Also a good idea to always clear your browser's cache.


You should now be able to go to:
http://localhost
and see the XAMPP welcome page.

http://onions.selfip.net:16800/
and see your web site.

Let me know if that all works for you.

------------------------------------------
Edit.
I see this now when I go to http://onions.selfip.net:16800/
onions website wrote:Current PSOBB server IP: 72.73.90.205 Server status: Down Page under construction.
If anyone sees this message, it works. Let me know.
Last edited by Izzy on 12. March 2009 08:08, edited 1 time in total.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: Resolving a domain?

Postby abandonwareguru » 11. March 2009 05:08

Okay, I've used the setup you gave me in the last post, and people can see my site if they use http://onions.selfip.net:16800/ Thanks a lot for the help, this is great progress. I've got one more question though.

How would I set it up so that people can access it via just http://onions.selfip.net/ ? Is this impossible due to my ISP blocking port 80? If port 80 is forwarded even though traffic is blocked on that port by the ISP, can't Apache still listen on that port and redirect http://onions.selfip.net/ to http://onions.selfip.net:16800/ without having the remote user manually type it in?
abandonwareguru
 
Posts: 5
Joined: 10. March 2009 01:58

Re: Resolving a domain?

Postby Izzy » 11. March 2009 05:21

The traffic from the Internet on port 80 and as far as I can tell port 8080 is not getting past your ISP's filters and into your PC for Apache to even see it, so again as far as I know your router and Apache will never be able to see that incoming traffic on those ports to be able to do anything about it. - I'm afraid it looks like you will be stuck with the http://onions.selfip.net:16800/ address at this point in time.

Of course you could always make a request to your ISP to have them remove the restrictions on port 80/8080 and quite often, given reasonable reasons why they should, the ISP grants your request, but if not then it may well be time to hunt down a new ISP that does not have these blocking filters and give this one the flick.
Last edited by Izzy on 12. March 2009 08:10, edited 1 time in total.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: Resolving a domain?

Postby abandonwareguru » 11. March 2009 07:00

I would do that, but the problem with my ISP is that I'm on a basic home broadband connection. The only way to get a static IP or port 80 unblocked would be to pay a lot more each month for a business class connection, which I'm frankly not willing to do right now. Everything seems to be working exactly how I want now on my end, so thanks a million for the help, Izzy!
abandonwareguru
 
Posts: 5
Joined: 10. March 2009 01:58


Return to XAMPP for Windows

Who is online

Users browsing this forum: Bonniem and 64 guests