"localhost" is not setup to establish a connection on port..

Problems with the Windows version of XAMPP, questions, comments, and anything related.

"localhost" is not setup to establish a connection on port..

Postby Sully725 » 09. March 2009 20:32

Hello everyone,

I have been using XAMPP for about a year now to develop a Joomla site. I have not had any problems, until today. It has been great. However, today, when I try to go to localhost using my browser, I get the following error:

"localhost" is not set up to establish a connection on port "World Wide Web service (HTTP)" with this computer.


This is a windows Vista machine. I am using XAMPP version 2.5. Nothing has changed (to my knowledge) on this computer since the last time I used localhost a couple of days ago.

Can anyone give me some detailed advice on what could be the problem and how to fix it?

Thanks, in advance, for your help,
Sully
Sully725
 
Posts: 3
Joined: 09. March 2009 20:20

Re: "localhost" is not setup to establish a connection on port..

Postby Izzy » 10. March 2009 00:11

It would appear that you may have a Trojan creep into your system.

The Trojan may have added additional 127.0.0.1 entries to your C:\Windows\system32\drivers\etc\Hosts file that need to be removed so only
127.0.0.1 localhost
is the first entry in this file.

You can edit this file by dragging the file into your open text editor.

After editing save the file and try again to access localhost.

But this fix will not remove the Trojan so that is a priority and must be done before editing the Hosts file or the Trojan will simply do it's dirty deed once again.


There is a solution here if that is so:
Experts Exchange

The above fix from these Google search results for your error message plus there may be more solutions if you do not have a Trojan.
Last edited by Izzy on 12. March 2009 08:06, edited 1 time in total.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: "localhost" is not setup to establish a connection on port..

Postby Sully725 » 10. March 2009 06:38

Hi Izzy,

Thanks for the help, but I'm having trouble with this. I tried to edit the hosts file but I can only open it as read only so I can't save the changes. Can't seem to open it any other way. I opened it with MS Word. Any thoughts about how I can get around this?

Thanks again,
Sully
Sully725
 
Posts: 3
Joined: 09. March 2009 20:20

Re: "localhost" is not setup to establish a connection on port..

Postby Izzy » 10. March 2009 07:00

Make sure UAC is disabled and you are logged in as an administrator in Vista.

Or run Notepad as Administrator.

Find the shortcut for Notepad in your Programs list, right-click on it and choose "run as Administrator".

Now do File>Open to get the Hosts file. Make your changes and you should be able to save it.


BTW never use MS Word to edit files in XAMPP always use a text editor like Notepad and always save as text not with any other encoding like utf-8 for example.
Last edited by Izzy on 12. March 2009 08:08, edited 1 time in total.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: "localhost" is not setup to establish a connection on port..

Postby Sully725 » 10. March 2009 23:14

Hi Izzy,

Great. That worked perfectly. Thanks for all your help.

Sully
Sully725
 
Posts: 3
Joined: 09. March 2009 20:20

Re: "localhost" is not setup to establish a connection on port..

Postby varmt » 21. August 2009 07:55

Hi Izzy & everyone,

i am experiencing same problem and i have tried ur advised solution but still same error. I have removed this line 127.0.0.1 localhost infact.
there is other line
::1 localhost
should this stay or what. i am confused. please advise.

Regards,
Varmt
varmt
 
Posts: 1
Joined: 21. August 2009 07:49


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 48 guests