Apache wont start - busy port

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Apache wont start - busy port

Postby mickeymouse » 08. March 2009 06:19

Message is:
Apache started [port 80]
Busy
and Apache wont start.
What do I need to do?
Thanks,
Mickey
mickeymouse
 
Posts: 36
Joined: 08. March 2009 06:10
Location: France & Canada
XAMPP Version: 5.6.3
Operating System: Win 7 Family Prem Ed (64 bit?)

Re: Apache wont start - busy port

Postby Izzy » 08. March 2009 10:44

Run xampp\apache_start.bat file and see what message it tells you why Apache can't start.
Last edited by Izzy on 12. March 2009 07:30, edited 1 time in total.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: Apache wont start - busy port

Postby mickeymouse » 08. March 2009 17:21

bat file results:
OS 10048 Make_sock: could not bind to address 0.0.0.0:43
no listening sockets available.
shutting down
unable to open logs
Apache could not be started

To the best of my knowledge, there are no other sessions running on this computer.
There are only 2 available. I'm using one and I made sure the other one was closed.

Mickey
mickeymouse
 
Posts: 36
Joined: 08. March 2009 06:10
Location: France & Canada
XAMPP Version: 5.6.3
Operating System: Win 7 Family Prem Ed (64 bit?)

Re: Apache wont start - busy port

Postby az_critter » 08. March 2009 19:55

I had the same problem with my Apache after installation. I checked all the resources and couldn't find the answer, but after checking the readme in the control panel, I found an uninstall for the Apache. I tried it, and it worked.

Here's what you do;

1. Go to your Apache folder in your xampp folder. Mine is located at C:\Program Files\xampp\apache.

2. Once inside your apache folder, open the file named "apache_uninstallservice.bat".
This file will uninstall apache service.

3. Then in the same apache folder, open the file named "apache_installservice.bat".
This file will restart your apache.

Now it should work, as this is how I fixed mine. :)

Maybe someone will add this fix to the questions and answers page of the site. ;)
az_critter
 
Posts: 3
Joined: 08. March 2009 19:44

Re: Apache wont start - busy port

Postby Izzy » 08. March 2009 23:58

mickeymouse wrote:OS 10048 Make_sock: could not bind to address 0.0.0.0:43
I am sure the message read address 0.0.0.0:443 which is used by both Internet Information Services (Windows web server) and or Skype.

IIS can be disabled from the Windows Control Panel and Skype can be made to use other ports from the Skype configuration settings.

If you want to get up and running then go to xampp\apache\conf\ folder and load httpd.conf file in your text editor and find near the bottom of the file these lines:
# Secure (SSL/TLS) connections
Include conf/extra/httpd-ssl.conf


change to this by adding the comment character:
# Secure (SSL/TLS) connections
# Include conf/extra/httpd-ssl.conf


Save the file and try and start Apache again.

Often a reboot at this stage helps also.


az_critter wrote:3. Then in the same apache folder, open the file named "apache_installservice.bat".
This file will restart your apache.
This will install Apache as a service again and may not actually start Apache which may need to be started from the XAMPP Control Panel (XCP) or by running the apache_start.bat file - all these controls are contained within the XCP also and remember that some may not require Apache to run as a service.

BTW this fix would not need to be added to the Q&A because it is usually the result of those users who do not read and follow the simple install and uninstall instruction supplied - especially those who uninstall and reinstall many times without first making sure they have stopped and uninstalled any XAMPP components first and before deleting the xampp folder as is contained in the readme_en.txt file - this and many more fixes are easily found by searching this forum.
Last edited by Izzy on 12. March 2009 07:26, edited 1 time in total.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: Apache wont start - busy port

Postby az_critter » 09. March 2009 01:02

Izzy wrote:
az_critter wrote:3. Then in the same apache folder, open the file named "apache_installservice.bat".
This file will restart your apache.
This will install Apache as a service again and may not actually start Apache which may need to be started from the XAMPP Control Panel (XCP) or by running the apache_start.bat file - all these controls are contained within the XCP also and remember that some may not require Apache to run as a service.

BTW this fix would not need to be added to the Q&A because it is usually the result of those users who do not read and follow the simple install and uninstall instruction supplied - especially those who uninstall and reinstall many times without first making sure they have stopped and uninstalled any XAMPP components first and before deleting the xampp folder as is contained in the readme_en.txt file - this and many more fixes are easily found by searching this forum.


Yes, I meant to say that it would reinstall apache. It also does automatically start up Apache as well in the XCP.
As for all of these controls being contained within the XCP, I did not see the uninstall or install for Apache in there. As I'm new to this xampp, I could have missed it, but not likely as I searched intensely for several hours to find a way to fix the "busy" problem.

Seeing how as I am someone who follows directions, searches, and intensely researches any problems I have, I don't think I fall into your profiling of "those who uninstall and reinstall, etc.". Nor do I start installing and uninstalling or anything else of my programs and/or files, before I understand the consequences of doing so, and nor did I before trying my fix. I searched the forums and the site and several readme files contained within XAMPP folders and else where. All I found was a bunch of registry edits and other "fixes" which did not apply to the "busy" problem in any way whatso ever, and which are also very complicated and confusing to the new user.

Therefor, had my fix been in the Q&A, it could have saved me hours of trying to figure out how to fix my problem, and as it helped me so easily, I'm sure it could help others just the same.
az_critter
 
Posts: 3
Joined: 08. March 2009 19:44

Re: Apache wont start - busy port

Postby Izzy » 09. March 2009 01:42

Had you read and understood the second post of the OP you would have seen that your fix was unrelated and so off-topic, the OP's issue was a busy SSL https port 443 and not a sticking installed Apache service related issue - and in light of this fact alone it would appear my profile comments to be very much related to you.

I have also posted many times the reasons and fixes for this XP SP* services related issue with much success, that can be found by a patient and diligent search of this XAMPP for Windows forum, some btw quite recently.


I won't be commenting again about your posts in here as it would be off-topic of which there has been enough already.
Last edited by Izzy on 12. March 2009 07:24, edited 1 time in total.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: Apache wont start - busy port

Postby mickeymouse » 09. March 2009 19:22

If you want to get up and running then go to xampp\apache\conf\ folder and load httpd.conf file in your text editor and find near the bottom of the file these lines:
# Secure (SSL/TLS) connections
Include conf/extra/httpd-ssl.conf


change to this by adding the comment character:
# Secure (SSL/TLS) connections
# Include conf/extra/httpd-ssl.conf


Save the file and try and start Apache again.

Often a reboot at this stage helps also.


THIS WORKED WONDERFULLY! Didn't even have to reboot.
You obviously know what you're talking about!
1000 thanks.
Mickey
mickeymouse
 
Posts: 36
Joined: 08. March 2009 06:10
Location: France & Canada
XAMPP Version: 5.6.3
Operating System: Win 7 Family Prem Ed (64 bit?)


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 28 guests