Problem with Apache

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Problem with Apache

Postby human » 07. March 2009 16:03

Hello,

I have the following problem with Apache.When I'm Installing XAMPP I check Apache and Mysql to install as Service, but only install Mysql and Apache does not.
Then I try to run Apache as service but it does not go.
Settings of Skype is set to use port 80.
I went to install Apache as Service from apache_serviceinstall.bat but it gives this error:
Installing Apache2.2 as an Service
Now we Start Apache2.2 :)
The service name is invalid.

More help is available by typing NET HELPMSG 2185.

Press any key to continue . . .

I hope someone has an idea why it happens and how to fix it.

Thanks:)
human
 
Posts: 5
Joined: 07. March 2009 15:59

Re: Problem with Apache

Postby Izzy » 07. March 2009 21:17

Run xampp\apache_start.bat file and see what the message is.
Last edited by Izzy on 12. March 2009 08:30, edited 1 time in total.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: Problem with Apache

Postby human » 08. March 2009 09:37

When I start it it dissapear very fast.
The last line I can read is:
Apache2 is starting...
human
 
Posts: 5
Joined: 07. March 2009 15:59

Re: Problem with Apache

Postby Izzy » 08. March 2009 10:39

Settings of Skype is set to use port 80.
You must either disable Skype or change the ports that Skype uses in the Skype configuration or you will not be able to start Apache as it uses port 80 and 443.
Last edited by Izzy on 12. March 2009 08:32, edited 1 time in total.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: Problem with Apache

Postby human » 08. March 2009 10:50

Oops.
Mistake.
I wanted to say that is not set.
human
 
Posts: 5
Joined: 07. March 2009 15:59

Re: Problem with Apache

Postby Izzy » 08. March 2009 11:02

Run xampp-portcheck.exe - all ports should be free.
Last edited by Izzy on 12. March 2009 08:35, edited 1 time in total.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: Problem with Apache

Postby human » 08. March 2009 12:00

Image
human
 
Posts: 5
Joined: 07. March 2009 15:59

Re: Problem with Apache

Postby Izzy » 08. March 2009 12:08

Run xampp\xampp-control.exe the XAMPP Control Panel (XCP) and click on Start Apache and make sure it shows the green running then Click on Start MySQL and make sure the green running shows - but do not click on any of the Admin... buttons or you will get more issues.

Untick any Svc boxes then answer the questions.

Then go to http://localhost and select your language then test all the demos including the CD Collection as it will verify that MySQL is working.

Why do you want to run Apache as a service?

Do you know what running an app as a service means?
Last edited by Izzy on 12. March 2009 08:36, edited 1 time in total.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: Problem with Apache

Postby human » 08. March 2009 12:18

The first thing I tried was to start it from the xampp control panel but I can't.
Down in the box xampp wrotes:
[quote]
Busy
Apache started [Port 80][/qoute]

Before month my Xampp start to gave errors.Before that there were no problems with Xampp.
human
 
Posts: 5
Joined: 07. March 2009 15:59


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 47 guests