DBI object version 1.607 does not match $DBI::VERSION 1.604

Problems with the Windows version of XAMPP, questions, comments, and anything related.

DBI object version 1.607 does not match $DBI::VERSION 1.604

Postby redline » 05. March 2009 12:42

Good day, guys!
I have a serious trouble..
Code: Select all
DBI object version 1.607 does not match $DBI::VERSION 1.604 at C:/WebServers/perl/lib/DynaLoader.pm line 226.
BEGIN failed--compilation aborted at C:/WebServers/perl/lib/DBI.pm line 263.
Compilation failed in require at modules/DBH.pm line 6.
BEGIN failed--compilation aborted at modules/DBH.pm line 6.
Compilation failed in require at modules/conf.pm line 21.
BEGIN failed--compilation aborted at modules/conf.pm line 21.
Compilation failed in require at C:/WebServers/public/http://rusfx.net/search/cgi-bin/admin.cgi line 6.
BEGIN failed--compilation aborted at C:/WebServers/public/http://rusfx.net/search/cgi-bin/admin.cgi line 6.


I got xampp 1.7, latest perl addon (5.10) under win2003
Please help, what can i do to execute this script?
Last edited by redline on 22. July 2009 21:55, edited 1 time in total.
redline
 
Posts: 3
Joined: 05. March 2009 12:38

Re: DBI object version 1.607 does not match $DBI::VERSION 1.604

Postby Izzy » 05. March 2009 13:07

Disable mod_perl when you run setup_xampp.bat and see if that helps.
Last edited by Izzy on 12. March 2009 09:20, edited 1 time in total.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: DBI object version 1.607 does not match $DBI::VERSION 1.604

Postby redline » 05. March 2009 13:33

Izzy wrote:Disable mod_perl when you run setup_xampp.bat and see if that helps.

Nothing.. :(
redline
 
Posts: 3
Joined: 05. March 2009 12:38

Re: DBI object version 1.607 does not match $DBI::VERSION 1.604

Postby redline » 06. March 2009 01:26

Soution:
1. Install Visual Studion .Net 2003 with all components wich are needed in /xampp/perl/lib/cpan.pm
2. Change paths in /xampp/perl/lib/cpan.pm
3. /xampp/perl/bin/perl.exe -MCPAN -e shell
4. upgrade DBI

Time spent finding solution: 14 hours
Sugection to developers: plz, update CPAN, DBD, DBI modules beacuase that is the most important modules for users who uses perl!
redline
 
Posts: 3
Joined: 05. March 2009 12:38

Re: DBI object version 1.607 does not match $DBI::VERSION 1.604

Postby patil » 25. March 2009 01:53

Great, I'm also facing this problem. Isn't there an alternative way instead of having to install Visual Studio?

Look here:

http://blog.cachemiss.com/articles/Deal ... odules.pod

This guy has a solution, but it's for linux. Any way to get this working on windoes?


Your help is much appreciated!
patil
 
Posts: 1
Joined: 25. March 2009 01:49

Re: DBI object version 1.607 does not match $DBI::VERSION 1.604

Postby perlwacko » 17. April 2009 18:14

I have same problem.
Have the Apache friends not updated the modules for the install?
perlwacko
 
Posts: 1
Joined: 17. April 2009 18:01

Re: DBI object version 1.607 does not match $DBI::VERSION 1.604

Postby kbean » 24. April 2009 09:42

I tried the all three installation methods in the hopes that one of them might be working, but no luck.

I know how to update CPAN modules on Linux, but no experience on Windows. Does anyone have simple instructions on how I can get this cleared up without downloading Visual Studion .Net 2003 as suggested above?

Or does anyone know if Apachefriends (thank you very much for your work!) are planning on fixing this soon. I am not in a big hurry, but want to know if I should waste time trying to figure it out myself, or just wait a few days and download again.
kbean
 
Posts: 3
Joined: 24. April 2009 04:35

Re: DBI object version 1.607 does not match $DBI::VERSION 1.604

Postby kbean » 24. April 2009 11:33

First I want to clarify that I tried all *two* (not three) installation methods - the zip files and .exe files. Also I downloaded and installed ApacheFriends XAMPP (basic package) version 1.6.5 and Add-on Perl 5.8.8 Apache 2.2.8 which were what I was using before I had to reinstall my system. I didn't get the error about different DBI versions before, but I still get it now even with the older versions of Xampp and Perl.

Any help or direction would be appreciated. Xampp is a god-send and i really want to get it up and running again!
kbean
 
Posts: 3
Joined: 24. April 2009 04:35

Re: DBI object version 1.607 does not match $DBI::VERSION 1.604

Postby kbean » 24. April 2009 13:51

OK, just because I hate it when people solve something and don't update their forum question... If anyone is still having problems with DBI and xampp:

I finally managed to get xampp and perl and DBI up and running. I had to downgrade back to

xampp-win32-1.6.5.zip
xampp-win32-perl-addon-5.8.8-2.2.8.zip

All downloadable on sourceforge of course。
http://sourceforge.net/project/showfile ... e_id=89552
http://sourceforge.net/project/showfile ... _id=113693

Also, I had to completely delete any existing xampp instalation and restart the computer (I had several versions as I was trying to get this thing sorted out, but just killing the process didn't seem to do the trick even though I re-ran the set-up.bat file many times.) I used the .zip versions, though I am guessing that the .exe will work as well.

I am sure that there is a reason xampp and the perl addon have been updated, and I don't mean to recommend the older version, but the older version worked fine for me until now, and the newer versions dont, so until I know it is safe to upgrade...

Hope this helps anyone.
kbean
 
Posts: 3
Joined: 24. April 2009 04:35


Return to XAMPP for Windows

Who is online

Users browsing this forum: milaz357 and 54 guests