Cannot get appache to run under Windows Server 2003

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Cannot get appache to run under Windows Server 2003

Postby dalton565 » 05. March 2009 11:13

Hey guys

i am trying to get xampp to run on a windows 2003 box that also runs iis. this is what i have done so far

1. Installed Xampp
2. Edited httpd.conf to change port to 8080 have tried others also
3. Restarted Xamp, restarted pc

Still it is trying to listen on port 80 even though i have changed this. i have tried reinstalling twice so far to no avail. If i restart the pc when the machine restarts it defaults to port 80 which blocks my iis causing me problems.

Also when i click status in xamp apache is set to port 80 even though it says 8080 in the text file. i edited both lines

looks like this
# Listen: Allows you to bind Apache to specific IP addresses and/or
# ports, instead of the default. See also the <VirtualHost>
# directive.
#
# Change this to Listen on specific IP addresses as shown below to
# prevent Apache from glomming onto all bound IP addresses (0.0.0.0)
#
#Listen 12.34.56.78:8080
Listen 8080


i had this working on my local pc fine, just cant figure out why the port wont change when i edit the httpd.conf file in the appache folder.

Any ideas anyone ?
dalton565
 
Posts: 3
Joined: 05. March 2009 11:07

Re: Cannot get appache to run under Windows Server 2003

Postby Izzy » 05. March 2009 11:25

A bit further down in the httpd.conf file you may have this line:
ServerName localhost:80

Change it to
ServerName localhost:8080

Save and restart Apache.

See if that helps and ignore the port 80 in the XAMPP Control Panel (XCP) as it is hard coded and makes no difference what port Apache listens on.

BTW this topic may be moved to XAMPP for Windows in the Apache Friends in English forum.
Last edited by Izzy on 12. March 2009 09:21, edited 1 time in total.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: Cannot get appache to run under Windows Server 2003

Postby dalton565 » 05. March 2009 11:55

Installing Apache2.2 as an Service
Installing the Apache2.2 service
Hey thanks for the reply

tried what you said, but still no joy a further error message is get shown below mgiht give you a better idea. That comes up when i try to start appache from the appache_start.bat file

The Apache2.2 service is successfully installed.
Testing httpd.conf....
Errors reported here must be corrected before the service can be started.
(OS 10048)Only one usage of each socket address (protocol/network address/port)
is normally permitted. : make_sock: could not bind to address 0.0.0.0:443
no listening sockets available, shutting down
Unable to open logs
Now we Start Apache2.2 :)
The Apache2.2 service is starting.
The Apache2.2 service could not be started.

A service specific error occurred: 1.

More help is available by typing NET HELPMSG 3547.

Press any key to continue . . .
dalton565
 
Posts: 3
Joined: 05. March 2009 11:07

Re: Cannot get appache to run under Windows Server 2003

Postby Izzy » 05. March 2009 12:09

You also need to change the https (ssl) port that Apache uses as IIS is using port 443.

2 ways to do that.

1. If you don't want to use https (ssl) in XAMPP then disable the reference to it in the httpd.conf file down near the bottom:
# Secure (SSL/TLS) connections
Include conf/extra/httpd-ssl.conf


to:
# Secure (SSL/TLS) connections
# Include conf/extra/httpd-ssl.conf



2. If you do want to use https then go to xampp\apache\conf\extra\httpd-ssl.conf and change the port from 443 to 4433 for example.

Save the conf files and restart Apache then try again.
Last edited by Izzy on 12. March 2009 09:24, edited 1 time in total.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: Cannot get appache to run under Windows Server 2003

Postby dalton565 » 05. March 2009 12:25

Superb mate

thanks awful that has sorted my problem cheers
dalton565
 
Posts: 3
Joined: 05. March 2009 11:07

SOLVED- Cannot get appache to run under Windows Server 2003

Postby brergo » 12. July 2009 15:38

UPDATED- I was able to successfully change the port once I found the correct httpd.conf file. Thanks to all in this thread!

Brian


Izzy wrote:A bit further down in the httpd.conf file you may have this line:
ServerName localhost:80

Change it to
ServerName localhost:8080

Save and restart Apache.

See if that helps and ignore the port 80 in the XAMPP Control Panel (XCP) as it is hard coded and makes no difference what port Apache listens on.

BTW this topic may be moved to XAMPP for Windows in the Apache Friends in English forum.


I am running XAMMP Lite on a Windows Home Server (Server 2003 under the hood) and when I try your suggestions, I can't get the Apache service started. I get the same errors that the original poster was getting, ref to "...could not bind to address 0.0.0.0:80" even after I change the port to 8080 in httpd.conf. Is there more than 1 copy of that .conf file? If so, where is the one I should be changing? Thanks in advance.

Brian
brergo
 
Posts: 8
Joined: 07. March 2009 02:36
Operating System: Windows XP


Return to XAMPP for Windows

Who is online

Users browsing this forum: ben.mansuk and 59 guests