Getting started?

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Getting started?

Postby Sphinxy » 04. March 2009 21:41

Hello,

First off, im using no-ip for my ipaddress, so lets say my ip was: music.no-ip.org, when i type it into the browser bar, like : "http://music.no-ip.org" it works, but when i do "http://www.music.no-ip.org" it doesn't work, is their a reason for this? and how could I make it work?

Secondly, I want to run a phpbb forum from my windows vps. so i put the forum in htdocs in a forum directory, then go to : mysite/phpmyadmin how do i create a database with a database user and pass.

Also, when i access /phpmyadmin/ it says this:

Image

how do i stop that and make a password?

Thanks
Sphinxy
 
Posts: 4
Joined: 04. March 2009 21:32

Re: Getting started?

Postby Izzy » 04. March 2009 22:09

Sphinxy wrote:"http://music.no-ip.org" it works, but when i do "http://www.music.no-ip.org" it doesn't work, is their a reason for this? and how could I make it work?
You would configure this at no-ip - ask them how to do it - btw, the addresses above both work for me including the www which both redirect to a Portugal address.

Sphinxy wrote:Secondly, I want to run a phpbb forum from my windows vps. so i put the forum in htdocs in a forum directory, then go to : mysite/phpmyadmin how do i create a database with a database user and pass.
I did a small tutorial on how to create a database in phpMyAdmin for WordPress which will help you do this for your forum.

Just change the names to suit your forum as the instruction are for creating a database for any type of script like a forum or a blog etc..
viewtopic.php?p=112258#p112258

Sphinxy wrote:Also, when i access /phpmyadmin/ it says this...how do i stop that and make a password?
You would first read the readme_en.txt file in the xampp folder and look for this section:
A matter of security (A MUST READ!)
Last edited by Izzy on 12. March 2009 08:41, edited 1 time in total.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: Getting started?

Postby Sphinxy » 05. March 2009 08:36

Thanks,

but when i go too: http://localhost/security, I get:

Code: Select all
Access forbidden!

You don't have permission to access the requested object. It is either read-protected or not readable by the server.

If you think this is a server error, please contact the webmaster.


How can i bypass this?

Thanks
Sphinxy
 
Posts: 4
Joined: 04. March 2009 21:32

Re: Getting started?

Postby Izzy » 05. March 2009 08:48

Drag xampp\apache\conf\extra\httpd-xampp.conf file in to your open text editor and look for 2 instances of Allow from localhost and change them to Allow from 127.0.0.1

Save the file and restart Apache.

Then try again but first empty your browser's cache or you may be served a cached page and not a fresh page from the server.
Last edited by Izzy on 12. March 2009 08:44, edited 1 time in total.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: Getting started?

Postby Sphinxy » 05. March 2009 10:20

this? i changed it around, but still doesn't let me:

Code: Select all
    Alias /security "C:/xampp/security/htdocs/"
    <Directory "C:/xampp/security/htdocs">
      <IfModule php5_module>
         <Files "xamppsecurity.php">
            php_admin_flag safe_mode off
         </Files>
      </IfModule>
        Order Allow,allow
        Allow from all
        Allow from 127.0.0.1
    </Directory>
Sphinxy
 
Posts: 4
Joined: 04. March 2009 21:32

Re: Getting started?

Postby Izzy » 05. March 2009 10:33

Sphinxy wrote:this? i changed it around, but still doesn't let me:

Alias /security "C:/xampp/security/htdocs/"
<Directory "C:/xampp/security/htdocs">
<IfModule php5_module>
<Files "xamppsecurity.php">
php_admin_flag safe_mode off
</Files>
</IfModule>
Order Allow,allow
Allow from all

Allow from 127.0.0.1
</Directory>
That is wrong and I did not say change anything else other than the line Allow from localhost to Allow from 127.0.0.1 in 2 places - see below.



This is how it should look:
Code: Select all
    Alias /security "C:/xampp2/security/htdocs/"
    <Directory "C:/xampp2/security/htdocs">
      <IfModule php5_module>
         <Files "xamppsecurity.php">
            php_admin_flag safe_mode off
         </Files>
      </IfModule>
        Order deny,allow
        Deny from all
        Allow from 127.0.0.1
    </Directory>


The other place you change is here:
Code: Select all
      Alias /contrib "C:/xampp2/contrib/"
    <Directory "C:/xampp2/contrib">
      <IfModule php5_module>
         <Files "webalizer.php">
            php_admin_flag safe_mode off
         </Files>
      </IfModule>

        Order deny,allow
        Deny from all
        Allow from 127.0.0.1
    </Directory>
</IfModule>


All you change is the line Allow from localhost to Allow from 127.0.0.1 as I pointed out in my other post - don't change anything else and remember to save and restart Apache.
Last edited by Izzy on 12. March 2009 08:45, edited 1 time in total.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: Getting started?

Postby Sphinxy » 06. March 2009 17:56

strange, i still cant get into /security/ do you have msn?
Sphinxy
 
Posts: 4
Joined: 04. March 2009 21:32


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 61 guests