apache error(piwik)

Problems with the Windows version of XAMPP, questions, comments, and anything related.

apache error(piwik)

Postby 023yangbo » 04. March 2009 13:47

I installed piwik,but when finished,enter the piwik url ,the apache show error,
Image
this is the error log
Code: Select all
[Wed Mar 04 20:41:37 2009] [notice] Parent: child process exited with status 3221225477 -- Restarting.
[Wed Mar 04 20:41:37 2009] [notice] Digest: generating secret for digest authentication ...
[Wed Mar 04 20:41:37 2009] [notice] Digest: done
[Wed Mar 04 20:41:38 2009] [notice] Apache/2.2.11 (Win32) DAV/2 mod_ssl/2.2.11 OpenSSL/0.9.8i mod_autoindex_color PHP/5.2.8 mod_jk/1.2.27 configured -- resuming normal operations
[Wed Mar 04 20:41:38 2009] [notice] Server built: Dec 10 2008 00:10:06
[Wed Mar 04 20:41:38 2009] [notice] Parent: Created child process 5048
[Wed Mar 04 20:41:39 2009] [notice] Digest: generating secret for digest authentication ...
[Wed Mar 04 20:41:39 2009] [notice] Digest: done
[Wed Mar 04 20:41:39 2009] [notice] Child 5048: Child process is running
[Wed Mar 04 20:41:39 2009] [notice] Child 5048: Acquired the start mutex.
[Wed Mar 04 20:41:39 2009] [notice] Child 5048: Starting 250 worker threads.
[Wed Mar 04 20:41:39 2009] [notice] Child 5048: Starting thread to listen on port 443.
[Wed Mar 04 20:41:39 2009] [notice] Child 5048: Starting thread to listen on port 80.
023yangbo
 
Posts: 2
Joined: 04. March 2009 13:35

Re: apache error(piwik)

Postby 023yangbo » 04. March 2009 16:36

I find the problem,the PHP MySQL library(libmysql.dll in apache\bin directory) cause this problem,the default library is 5.1.30,
Image
stop apache service and change libmysql_5.0.51a.dll to libmysql.dll(make a backup first),and log your phpmyadmin,it will show this tip
Image
and is will be ok

but this will cause other porblem,so becareful
023yangbo
 
Posts: 2
Joined: 04. March 2009 13:35

Re: apache error(piwik)

Postby make-fun » 29. April 2009 04:28

An update to XAMPP 1.7.1 will solve the issue!
Just run the update from http://www.apachefriends.org/download.php?xampp-win32-upgrade-1.7.0-1.7.1-installer.exe and piwik is running fine now

Cheers
make-fun
 
Posts: 31
Joined: 11. March 2009 04:21


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 56 guests