Component MySql status deactivated [MySql Running]

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Component MySql status deactivated [MySql Running]

Postby jef » 03. March 2009 10:58

Hello-Bonjour, Purpose = I want to...
install XAMPP for a local use [http://localhost/ ...] on my Windows XP desktop for preparing later flows online.
In other words, at this early stage, I do not want to operate on a distant HostingOperator via a router or AdslBox.

Today, at this point intime, the context is as follows :

C1 : I believe the parameters in --- C:/windows/my.ini --- are correct

C2 : I believe the parameters in --- C:/windows/my.ini.old --- do not disturb

C3 : I have a traffic light icon in my sytem tray : green light

C4 : "Xampp Control Panel App" shows the following
Code: Select all
Svc[Ticked]  Apache ... Running
Svc[Ticked]  MySql ..... Running


C5 : I have created -- with command line mysql.exe -- my first database called wordpress
This first database is empty (no table)

C6 : I believe (?) my antivirus (Kaspersky) is not blocking the "call"

C7 : I believe (?) MicrosoftWindowsSecurity is not blocking the Apache_httpServer

The installation is not completed:

When I launch the daemon Apache with http://localhost
Code: Select all
      Statut [in French]     
                 MySql        desactive [in English "deactivated" I suppose]




For this purpose, in this context
Three questions :
Q1 : Is the context sufficiently described, specified ? Do you want more on C1 ? .. C7 ?

Q2 : Are they URLs explaining all (or part) of C1 to C7, plus, possibly, unknown C8, C9 ?

Q3 (main question) : How can one activate the first created database (here called wordpress) ?


- - - - - - - - - - - - - - -- - - - - - - - - - - - - - - - - - - - - - - - - -
[Nota: I have searched elsewhere during a week, and, yesterday+today, here on apachefriends.org on a best effort basis,
even helping one visitor charlieahern calling on 01. March 2009 02:32 ]

You are MY LAST HOPE
jef
 
Posts: 7
Joined: 03. March 2009 08:17

Re: Component MySql status deactivated [MySql Running]

Postby Izzy » 03. March 2009 11:59

First you have clicked on the Admin... button next to MySQL in the XAMPP Control Panel (XCP) hence the traffic lights - Do Not do this again or you will have the same bad issues all over again, MySQLAdmin will be no more in the next XAMPP release.

Right click on the traffic light icon and select Win NT> then, if available, Stop the Service.

Then click on Shut down this tool.

Now go to your Windows folder and delete the my.ini file if it exists.

Next go to your XCP and un-tick both Svc boxes after first stopping both MySQL and Apache.

Next go to Services in the XCP and remove any ticks you find in the boxes.

Now go to Task Manager (right click on the Task Bar select Task Manager from the context menu) and open the Processes tab and look for any instances of apache (2) and mysql and select each in turn and click on End Process if any found.

Next go to SCM in your XCP and look for any apache or mysql entries.

If you find any go to xampp\apache\ folder and run apache_uninstallservice.bat file.

Then go to xampp\mysql\ folder and run mysql_unstallservice.bat file.

Next go to SCM again in your XCP and look again for any apache or mysql entries.

If you find any go to Start>Run... and then type sc delete mysql if you find mysql.

Type sc delete apache2.2 (or apache2) if you find apache.

Now close your XCP.

Next check in your Windows startup folder that there is no shortcut for WinMySQLAdmin and if you find one delete it.

Next go to xampp\mysql\bin folder and look for 3 WinMySQLAdmin files and delete all 3 as they are deprecated and of no more use, this will prevent you accidentally clicking on the MySQL Admin... button in the XCP and having WinMySQLAdmin run again and undo all the good work you have just gone through.

Next reboot your PC and make sure after startup is complete that no Apache or MySQL services have started by looking in the Task Manager Processes tab again.

Next go to XCP and click on Start Apache and Start MySQL - both should start and show the green running and do not tick the Svc boxes at this stage and do not click on any Admin buttons.

Now go to http://localhost and see if you get to the XAMPP Welcome page and if so check that all the demos work including the CD Collection demo.

All this is to get you a clean start after using the Install version of XAMPP.
Here is a topic that does a similar job with MySQL and FileZilla for a member who had similar issues:
viewtopic.php?f=16&t=33157




If you feel all that is a waste of time then at least you should make sure that all XAMPP components are stopped and any services properly uninstalled then delete the xampp folder.

Download and run the EXE (7zip) version and extract the files to the C:\ drive then run the setup-xampp.bat file to set the paths.

You should now have a fully working XAMPP installations without the hassles that the installer version may have caused.




I did a bit of a tutorial on installing WordPress and how to created the needed database using phpMyAdmin which is the GUI for MySQL.
viewtopic.php?p=112258#p112258
Last edited by Izzy on 12. March 2009 09:31, edited 1 time in total.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: Component MySql status deactivated [MySql Running]

Postby jef » 03. March 2009 22:51

Ooooooooooooooooooooooohh !
~~~~~~~~~~~~~~~~~~ ah !
Dear Izzi - Bravo !
"La Vie" (l' Dolce Vita) you know how to flow it "EASY" !
... Have a fine and very nice day and week and quarter !
All your instructions have been followed, step by step.
The Apache side appears OK as well as a percentage of the context for accessing the first empty SQLDatabase.
- - - - - - - - - - - - - - - - - - - - - - - - - -
The XAMPP Control Panel is now as follows:
Code: Select all
Modules
Svc[Unticked] Apache Running
Svc[Unticked] MySql Running

- - - - - - - - - - - - - - - - - - - - - - - - - -

Jef's PROGRESS REPORT as of Tuesday 22:40
Access to the first empty SQLDatabase

- - - - - Section A - - - - - - - - - - - - - - - - - - - -
In the navigator, typing : http://localhost/wordpress/index.php

You get :
Warning: Cannot modify header information - headers already sent by
(output started at C:\xampp\htdocs\wordpress\wp-config.php:1) in
C:\xampp\htdocs\wordpress\wp-includes\pluggable.php on line 850



Then you move to pluggable.php on line 850 ... and you find
Code: Select all
function wp_redirect($location, $status = 302)  {
   global $is_IIS;

   $location = apply_filters('wp_redirect', $location, $status);
   $status = apply_filters('wp_redirect_status', $status, $location);

   if ( !$location ) // allows the wp_redirect filter to cancel a redirect
      return false;

   $location = wp_sanitize_redirect($location);

   if ( $is_IIS ) {
      header("Refresh: 0;url=$location");
   } else {
      if ( php_sapi_name() != 'cgi-fcgi' )
         status_header($status); // This causes problems on IIS and some FastCGI setups
850      header("Location: $location");}}



- - - - - Section B - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
You may want to know what happens if you introduce http://localhost/phpmyadmin/
You get a left column . . .

- - - - - Section B1 - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
... with 4 icons [house - SQL - ? - SQL]

- - - - - Section B2 - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
...and 7 (seven) databases
cdcol (1) - information_schema (28) - mysql (23) - phpmyadmin (8) - test - webauth (1) - wordpress

- - - - - Section B3 - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
And, on the right, the main frame "Serveur:localhost"
with 10 (ten) functions
Bases-de-donnees - SQL - Etat - Variables - Jeux-de-caracteres - Moteurs (7) - Privileges - Processus - Exporter - Importer


- - - - - Section C - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
I have read
viewtopic.php?p=112258#p112258
by Izzy on 15. December 2007 02:57
Thus, I have checked wp-config.php

- - - - - Section D - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
The internaut is reminded Izzi's message :
We now have a database on localhost called wordpress with a user wp who has a password of pw with all privileges to use that database only.

To Check All Is Correct
Click on the database wordpress (0) in the left frame.
Click on the Privileges button in the top menu [the 7th button]
Check that you have the following in the Users having access to "wordpress" table.
Code: Select all

Code: Select all
User       Host              Type          Privileges         Grant
wp    localhost    database-specific    ALL PRIVILEGES    Yes



- - - - - Section E - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
In reference to above wp-config.php the following columns appear :
Code: Select all
User               Host     Type     Privileges     Grant         Action
root    127.0.0.1    global     ALL PRIVILEGES     Oui    icon 1 guy
root    localhost   global     ALL PRIVILEGES     Oui    icon 1 guy



- - - - - - - - - -
Question
Is it necessary to know the difference between "database-specific" and "global" ?

- - - - - Section F - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
The problem of Section A remains
The path htdocs/wordpress/ offers 3 (three) directories
wp-admin - wp-content - wp-includes
The path htdocs/wordpress/ offers 24 files [ 1 *.txt | 22 *.php | 1 *.html ]
- licence.txt
- index.php - wp-app.php - wp-atom.php - wp-blog-header.php - wp-comments-post.php - wp-commentsrss2.php - - wp-config.php - wp-config-sample.php - wp-cron.php - wp-feed.php - wp-links-opml.php - wp-load.php - - wp-login.php - wp-mail.php - wp-pass.php - wp-rdf.php - wp-register.php - wp-rss2.php - wp-settings.php - wp-trackback.php - xmlrpc.php
- readme.html

- - - - - Section G - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

What should be performed to control that any "blogSample" (group of scripts) is properly functioning

Q : Do you have an idea ?


- - - - - Section H - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

What happens if one introduces
http://localhost/wordpress/wp-admin/install.php ?

XAMPP answers:
" ERROR FOR ESTABLISHING THE CONNECTION WITH THE DATABASE "
It means that the identifier (user) and/or the password stipulated in the file wp-config.php are wrong, or
that the MySQL_Server at address localhost cannot be accessed"



... ... [ inadequate parameters ? unrelated script ? poor relation between components ? a deactivated service ? ... obstacle ? ...]

Thank you very much
jef
 
Posts: 7
Joined: 03. March 2009 08:17

Re: Component MySql status deactivated [MySql Running]

Postby Izzy » 03. March 2009 23:15

Question
Is it necessary to know the difference between "database-specific" and "global" ?

Global privileges should only be available for root user as this super user has privileges for all databases and in the wrong hands can wreak havoc in all databases.

Database-specific are the privileges you give to the user of a specific database and that user has no privileges globally and is the preferred when creating databases like WordPress and forums etc.



As this is an XAMPP forum your Wordpress issues should really be directed at WordPress support or their forums.



My advise would be to remove Wordpress and delete the database from phpMyAdmin that you created.

Then start afresh with a new download of Wordpress and then proceed to create the database in phpMyAdmin as I outlined in my tut, then armed with the database details you created, install Wordpress again as it is one of the easiest of scripts to follow when installing.
Last edited by Izzy on 12. March 2009 09:32, edited 1 time in total.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

MySql Running & Wordpress warning header unpluggable

Postby jef » 04. March 2009 08:53

@Izzy
Thank you very much
for your diligence, understanding, assistance, advice

- - - - - - - - - - - Jef's REPORT Wdnd 04 March @ 07:00 08:30 - - - - - - - - - - - - - - -
I have just followed and performed all your last instructions-directions :
# Delete, with phpMyAdmin, the empty database wordpress that I created
# Remove, with MS_fileSystem, the directory wordpress [I deleted the 24 files and 3 sub-directories]
# Start afresh with a new download of Wordpress [I reinstalled wordpress-2.7-fr_FR.zip]
# Proceed to create the database in phpMyAdmin as I outlined in your tutorial
# then, armed with the database details already created before, install Wordpress again

We are back to the same "ERROR MESSAGE" quoted in Section A [Above by jef on 03. March 2009 22:51]
Code: Select all
 Warning: Cannot modify header information - headers already sent by (output started at C:\xampp\htdocs\wordpress\wp-config.php:1) in C:\xampp\htdocs\wordpress\wp-includes\pluggable.php on line 850



As you said,
a question for http://www.wordpress.org/support/forum/2 and/or http://www.wordpress-fr.net/support/
- - - - - - - - - - - - - -
Subject: Installing wordpress with http://localhost/wordpress
Problem /wp-includes/pluggable.php ... function wp_redirect($location,...

[cf. www.apachefriends.org Component MySql status deactivated [MySql Running] by jef on 03. March 2009 22:51
Above viewtopic.php?f=16&t=33816&p=137364#p137435

[line 15 : Section A You get "Warning: Cannot modify header information - ... pluggable.php ...]
jef
 
Posts: 7
Joined: 03. March 2009 08:17

Re: Component MySql status deactivated [MySql Running]

Postby Izzy » 04. March 2009 09:30

Warning: Cannot modify header information - headers already sent by (output started at C:\xampp\htdocs\wordpress\wp-config.php:1) in C:\xampp\htdocs\wordpress\wp-includes\pluggable.php on line 850
Make sure that there is no white space at the top and bottom of the files in the error message.

<?php should be on line 1 with nothing above it.

Also when saving the files save as pure text not with any other encoding like utf-8 for example or you may have some invisible code or BOM (Byte Order Mark) added to the top of the files which PHP chucks a wobbly over.

Here is a Google in English that may help you understand the error - there is even a Wordpress item in the results.
Last edited by Izzy on 12. March 2009 09:36, edited 1 time in total.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

MySql running & Wordpress warning header unpluggable

Postby jef » 04. March 2009 10:19

@Izzy
You are a very kind person, entirely helping. Sure you are recognized and honoured by your community
For a later work, I record your remark [ <?php should be on line 1 with nothing above it ... and care utf8 encoding ]

At this stage, there is no file of my own (from myself)
I am merely on the very initial task installing XAMPP and Wordpress together [ref. the 5 minutes process]
Having MySql running, on the first hand, ... and, htpp://localhost/wordpress providing any blogSample (wordpress.org) on the other hand.

That's all, at this stage
Thank you again

- - - - - - - - - - - - - - - - -
A few apachefriends'visitors may want to know the coming solution.
Follow-up: http://www.wordpress.org/support/topic/249562?replies=0
Apparently, there is already someone called Jef on http://www.wordpress.org/support/
Thus my username here (Jef) is replaced by LeClownBlanc
jef
 
Posts: 7
Joined: 03. March 2009 08:17

Re: MySql running & Wordpress warning header unpluggable

Postby Izzy » 04. March 2009 10:33

jef wrote:A few apachefriends'visitors may want to know the coming solution.
Follow-up: http://www.wordpress.org/support/topic/249562?replies=0

Jef, the link above gives a Topic not found error

Tip - always go to your links after posting to make sure they work and adjust if required.
Last edited by Izzy on 12. March 2009 09:38, edited 1 time in total.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

encoding utf8 (basic, ie SANS SIGNATURE) notepad2

Postby jef » 04. March 2009 12:29

Required WordpressTask : Modifying wp-config-sample.php and saving it wp-config.php


@Izzy
You are a champion !
First, your idea ... search Google, was a good one
http://wordpress.org/support/topic/157174?replies=27

After searching more, I arrived on a "pinned post" on wordpress-fr ("épinglé")
http://www.wordpress-fr.net/support/suj ... ify-header

The conclusion for this task by a francophone :

# Let aside notepad.exe (called Bloc-notes in the French menu)
# Download notepad2.exe from Internet - I did it from Framasoft : http://www.framasoft.net/article2917.html
# Modify the file (wp-config.php) with "encoding...utf8" (not "encoding...utf8_avec_signature)
# Save and http://localhost/wordpress ... works !

Oooooooooooooffffffff !! .........
Thank you Izzy !
You'r a great person
I standup and offer you a nice-nice "Merci_hand" ... my commensalTable (near Paris)
Jef=Auguste+LeClownBlanc
jef
 
Posts: 7
Joined: 03. March 2009 08:17

Re: Component MySql status deactivated [MySql Running]

Postby Izzy » 04. March 2009 12:47

Well done Jef, you did all the work and deserve the applause Image
Last edited by Izzy on 12. March 2009 09:41, edited 1 time in total.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

entraide ...running

Postby jef » 04. March 2009 14:22

ImageImage
Izzy & Jef
jef
 
Posts: 7
Joined: 03. March 2009 08:17


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 63 guests