I made a mistake uninstalling

Problems with the Windows version of XAMPP, questions, comments, and anything related.

I made a mistake uninstalling

Postby karma_mechanic » 02. March 2009 15:06

I was having a problem installing Joomla so I decided to uninstall XAMPP and start again. However, I forgot to read the uninstall instructions and instead used Windows Vista control panel to uninstall XAMPP. Now I cannot delete the C:\XAMPP folder or its Apache and PHP subfolders - I "need permission to perform this action". What should I do to remove XAMPP entirely so I can re-install? Thank you.
karma_mechanic
 
Posts: 2
Joined: 02. March 2009 15:02

Re: I made a mistake uninstalling

Postby Izzy » 02. March 2009 23:01

You must be logged in as an Administrator and disable UAC (User Account Control) which is a must if you want to do anything worth while with XAMPP as a web server admin.

Here is a link that explains how to disable UAC.
viewtopic.php?p=134260#p134260

Then reboot, login as an administrator and then try and delete XAMPP again.
Last edited by Izzy on 12. March 2009 09:34, edited 1 time in total.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: I made a mistake uninstalling

Postby karma_mechanic » 03. March 2009 17:03

My UAC already is disabled. Perhaps I have to do something with the .bat files?
karma_mechanic
 
Posts: 2
Joined: 02. March 2009 15:02

Re: I made a mistake uninstalling

Postby Izzy » 03. March 2009 22:39

Run xampp\apache\apache_uninstallservice.bat file.

Run xampp\mysql\mysql\uninstallservice.bat file.

Check in Task Manager>Processes that no apache (2) or mysql processes are running if they are then select each in turn and click on End Process.

Try and delete now - or try again after a reboot but after a reboot and before trying to delete make sure that the apache and mysql services are not running in the Task Manager Processes tab again.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 73 guests