...cgi question...

Problems with the Windows version of XAMPP, questions, comments, and anything related.

...cgi question...

Postby RodneyzPc » 28. February 2009 18:04

I searched for "cgi" but it didn't turn up any results...

...I'm trying to get a script to work...but I guess I'm not doing something right...

....in the OEM script it says...


#!/usr/bin/perl .... do I change it to....
#!"C:\xampp\perl\bin\perl.exe"

...and....

$DATA_PATH= "/usr/local/apache/share/xmylittlenet/cgi-bin/survey";

...do I change this to...
$DATA_PATH= "/cgi-bin/survey";

.and.

# The $DOMAIN must be your site's domain name.
$DOMAIN="www.mylittleserver.net";

...do I change this to...
$DOMAIN="localhost";

.the cgi.cgi...perltest.cgi...printenv.pl... all seem to work....

....Thank You for your time....
....I know it's just a scripting error on my part...
RodneyzPc
 
Posts: 4
Joined: 28. February 2009 17:49

Re: ...cgi question...

Postby newbie2244 » 28. February 2009 21:55

Do you have the PERL addon installed?? If not, download and install.
YOu'll know its installed because you'll see a hyperlink to PERL in the navigation bar of the XAMP explorer window.

PEruse through the PERL or mod_perl subdirs under PERL and you'll find sample .cgi and .pl scripts with the info you need to write your own. YOu may still have probs. I spent some serous time with .cgi the last day and it does have some probs. LIKE you I started by adapting the PERL demo app script to my own ideas and although I finally got the script working, it still has probs.

Hope this helps.
newbie2244
 
Posts: 49
Joined: 20. February 2009 22:39

Re: ...cgi question...

Postby RodneyzPc » 01. March 2009 01:16

...C:\xampp\perl\bin...

...perltest.cgi seems to work..

....I get a ....

....GCI with MiniPerl
CGI with MiniPerl is ready ...
RodneyzPc
 
Posts: 4
Joined: 28. February 2009 17:49

Re: ...cgi question...

Postby newbie2244 » 06. March 2009 20:53

SO how did the cgi scripts work out?? I finally solved my problems - mostly stupid things like thinking that I wrote $f_var and really writing $_ var.

Regards :D :D
newbie2244
 
Posts: 49
Joined: 20. February 2009 22:39


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 69 guests