MyWeb application not run in Xampp

Problems with the Windows version of XAMPP, questions, comments, and anything related.

MyWeb application not run in Xampp

Postby tatang » 26. February 2009 08:15

I had trouble to run my web application.

my web application is running well when I install apache(apache_2.2.11-win32-x86-no_ssl.msi), mysql-5 and php(php-5.2.8-win32-installer.msi) separately.

some times I install xampp v 1.7.0 on another computer.. and copy my web application folder to xamp/htdoc and make alias in httpd-xampp.conf,
php.ini and htt.conf using default ( I'm not change ).My Xampp application is running well I can to load
I also success to create database for my application using php-myadmin, mysql port is (3306 default)
but my web application cannot run,

I really confuse, .. it is something wrong to my configuration file (php.ini, httpd.conf, httpd-xampp.conf)
please guys help me .. my be there are some one had same problem earlier and solve d now . please let me know.
tatang
 
Posts: 8
Joined: 26. February 2009 07:33

Re: MyWeb application not run in Xampp

Postby Izzy » 26. February 2009 08:21

and make alias in httpd-xampp.conf
What Alias did you add and where in the file did you add it?

Did you restart Apache after editing the file?

Did you change the paths in your application to reflect the XAMPP location?

What does the xampp\apache\logs\error.log file say about it?
Last edited by Izzy on 12. March 2009 10:15, edited 1 time in total.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: MyWeb application not run in Xampp

Postby tatang » 26. February 2009 08:58

here from error log:
[Thu Feb 26 14:31:54 2009] [notice] Apache/2.2.11 (Win32) DAV/2 mod_ssl/2.2.11 OpenSSL/0.9.8i mod_autoindex_color PHP/5.2.8 configured -- resuming normal operations
[Thu Feb 26 14:31:54 2009] [notice] Server built: Dec 10 2008 00:10:06
[Thu Feb 26 14:31:54 2009] [notice] Parent: Created child process 1764
[Thu Feb 26 14:31:54 2009] [notice] Digest: generating secret for digest authentication ...
[Thu Feb 26 14:31:54 2009] [notice] Digest: done
[Thu Feb 26 14:31:55 2009] [notice] Child 1764: Child process is running
[Thu Feb 26 14:31:55 2009] [notice] Child 1764: Acquired the start mutex.
[Thu Feb 26 14:31:55 2009] [notice] Child 1764: Starting 250 worker threads.
[Thu Feb 26 14:31:55 2009] [notice] Child 1764: Starting thread to listen on port 443.
[Thu Feb 26 14:31:55 2009] [notice] Child 1764: Starting thread to listen on port 80.
[Thu Feb 26 14:37:44 2009] [error] [client 127.0.0.1] File does not exist: C:/xampp/htdocs/QandA/mycss.css, referer: http://localhost/qanda/
[Thu Feb 26 14:38:25 2009] [error] [client 127.0.0.1] File does not exist: C:/xampp/htdocs/QandA/function.session-start, referer: http://localhost/qanda/Authen.php
[Thu Feb 26 14:38:34 2009] [error] [client 127.0.0.1] File does not exist: C:/xampp/htdocs/QandA/function.session-start, referer: http://localhost/qanda/Authen.php
[Thu Feb 26 14:38:49 2009] [error] [client 127.0.0.1] File does not exist: C:/xampp/htdocs/QandA/login
[Thu Feb 26 14:42:41 2009] [error] [client 127.0.0.1] File does not exist: C:/xampp/htdocs/QandA/mycss.css, referer: http://localhost/qanda/
[Thu Feb 26 14:43:00 2009] [error] [client 127.0.0.1] File does not exist: C:/xampp/htdocs/QandA/mycss.css, referer: http://localhost/qanda/OurForum.php
[Thu Feb 26 14:43:02 2009] [error] [client 127.0.0.1] File does not exist: C:/xampp/htdocs/QandA/mycss.css, referer: http://localhost/qanda/CategoryForum.php?projectID=5
[Thu Feb 26 14:51:05 2009] [error] [client 127.0.0.1] File does not exist: C:/xampp/htdocs/QandA/mycss.css, referer: http://localhost/qanda/
[Thu Feb 26 14:52:18 2009] [error] [client 127.0.0.1] File does not exist: C:/xampp/htdocs/QandA/mycss.css, referer: http://localhost/qanda/
tatang
 
Posts: 8
Joined: 26. February 2009 07:33

Re: MyWeb application not run in Xampp

Postby Izzy » 26. February 2009 09:04

The [error] entries are quite clear.

You have those missing files in the locations mentioned?

If so then the paths to those files in your QandA app are incorrect and need adjusting in the configuration file or where ever they are being requested - refer to the app's documentation.

The Alias entry I can't check because you did not post it as asked - are you sure it is correct?
Last edited by Izzy on 12. March 2009 10:17, edited 1 time in total.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: MyWeb application not run in Xampp

Postby tatang » 26. February 2009 09:13

sorry this is my alias in http-xampp.conf

Alias /qanda "C:/xampp/htdocs/Qanda/"
<Directory "C:/xampp/htdocs/Qanda">
<IfModule php5_module>
<Files "xamppsecurity.php">
php_admin_flag safe_mode off
</Files>
</IfModule>
Order deny,allow
Deny from all
Allow from localhost
</Directory>
tatang
 
Posts: 8
Joined: 26. February 2009 07:33

Re: MyWeb application not run in Xampp

Postby tatang » 26. February 2009 09:16

Thanks Izzi,
actually my web application is running well when i'm install apache, mysql and php separatelly, not using bundled xampp
tatang
 
Posts: 8
Joined: 26. February 2009 07:33

Re: MyWeb application not run in Xampp

Postby Izzy » 26. February 2009 09:21

Well you have some constant naming issues that in XAMPP are all case sensitive and different in your implementation.

C:/xampp/htdocs/Qanda/ = your Alias drive path.

C:/xampp/htdocs/QandA/ = your actual drive path.

You have to have them the same or you will get file not found errors like in the error.log file.
Last edited by Izzy on 12. March 2009 10:19, edited 1 time in total.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: MyWeb application not run in Xampp

Postby tatang » 26. February 2009 10:29

Ok Thank,s I'll try
tatang
 
Posts: 8
Joined: 26. February 2009 07:33

Acess forbidden .. how to solved that??

Postby tatang » 27. February 2009 04:26

I'm using Xampp 1.7.0 and success to run my web application .. using localhost/mywebappl
but when I try to connect from another computer there are message "Acess forbidden"
what should I setting in configuration file? and what file?

thank's for appreciate
tatang
 
Posts: 8
Joined: 26. February 2009 07:33

Re: Acess forbidden .. how to solved that??

Postby Izzy » 27. February 2009 04:31

Read the xampp\apache\logs\error.log file for clues.

BTW you can't access localhost/myappl from another computer you have to use the IP address of the computer that your webappl is located.
example: http://123.123.123.123/webapl

You could also open your xampp\apache\conf\httpd.conf file in your text editor and find this about line 53 or near:
Listen 80

change to:
Listen *:80

Save the file and restart Apache then try your IP address again.
Last edited by Izzy on 12. March 2009 10:20, edited 1 time in total.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: Acess forbidden .. how to solved that??

Postby tatang » 27. February 2009 05:12

I have to change line 53 with your advice (*:80) but it still forbidden
here my address http://192.168.0.239/qanda its not run "access forbidden"

btw if I acess http://192.168.0.239 ... Xampp main page is open

why?
thanks Izzy to help me..
tatang
 
Posts: 8
Joined: 26. February 2009 07:33

Re: Acess forbidden .. how to solved that??

Postby tatang » 27. February 2009 05:34

here the logs error

[Fri Feb 27 11:31:09 2009] [error] [client 192.168.0.2] client denied by server configuration: C:/xampp/htdocs/QandA/
[Fri Feb 27 11:31:45 2009] [error] [client 192.168.0.2] client denied by server configuration: C:/xampp/htdocs/QandA/
tatang
 
Posts: 8
Joined: 26. February 2009 07:33

Re: MyWeb application not run in Xampp

Postby Izzy » 27. February 2009 05:58

client denied by server configuration: C:/xampp/htdocs/QandA/
Your Alias needs editing and I have marked in red the lines that need changing:

Alias /qanda "C:/xampp/htdocs/QandA/"
<Directory "C:/xampp/htdocs/QandA">

<IfModule php5_module>
<Files "xamppsecurity.php">
php_admin_flag safe_mode off
</Files>
</IfModule>
<-- delete these lines, not needed

Order deny,allow <-- change this line to Order allow,deny
Deny from all <-- delete this line
Allow from localhost <--change to Allow from all
</Directory>

Save the file and restart Apache then try your IP address from the other computer again.


Your Alias should now look like this:

Alias /qanda "C:/xampp/htdocs/QandA/"
<Directory "C:/xampp/htdocs/QandA">
Order allow,deny
Allow from all
</Directory>
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 64 guests