Trouble starting Apache under XAMPP

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Trouble starting Apache under XAMPP

Postby SpencerDub » 25. February 2009 21:59

I'm having some troubles, much like many others, starting Apache through XAMPP.

I wanted a test environment where I could practice PHP, so I downloaded XAMPP a few days ago and installed it to my portable flash drive. I ran it for a little while to get the hang of it, and it worked without any problems. I could start Apache, go to localhost, and do all I needed to do. Then, once I got home, I installed it again, on my external hard drive, so that I'd have much more space than my portable thumb drive would offer. When I ran it from the external drive, it also worked-- same deal. I could start Apache and do all I needed to do.

Today, I plugged my thumb drive in and tried to fire up Apache to do some more PHP practice. However, when I click the Apache "Start" button in the XAMPP control panel, the text box below prints the following:

Code: Select all
Busy...
Apache started [Port 80]


However, Apache does not start-- there is no "running" notice in the Control Panel, the "Start" button does not transform into a "Stop" button, and if I try to navigate to http://localhost, I get a 404. What was working just fine a few days ago doesn't work at all now, and the only software change I've made is the secondary installation of XAMPP on my external hard drive.

Other people have suggested an incompatibility with Skype and port 80. While I have Skype installed, I hardly ever use it, and I don't let it run in the system tray-- the application is closed. Nevertheless, I unchecked the relevant option in Skype, and I still have the problem with Apache.

When I run xampp-portcheck.exe, the terminal tells me that both "Apache <HTTP>" in Port 80, and "Apache <HTTPS>" in Port 443 are of status "SYSTEM".

One other thing of note: when I start the XAMPP control panel from my thumb drive, this is posted at the top of the text area:

Code: Select all
XAMPP Control Panel Version 2.5 (9. May, 2007)
Windows 6.0 Build 6001 Platform 2 Service Pack 1
Current Directory: K:\xampp
Install Directory: L:\xampp
*** WARNING: Directory mismatch ***
Status Check OK


What do I need to do to make Apache under XAMPP work again?

I'm running Windows Vista SP1.

Thank you!
SpencerDub
 
Posts: 5
Joined: 25. February 2009 21:43

Re: Trouble starting Apache under XAMPP

Postby Wiedmann » 25. February 2009 22:02

When I run xampp-portcheck.exe, the terminal tells me that both "Apache <HTTP>" in Port 80, and "Apache <HTTPS>" in Port 443 are of status "SYSTEM".

Use e.g. netstat or tcpview to find the program which is using the ports.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Trouble starting Apache under XAMPP

Postby SpencerDub » 25. February 2009 22:05

Wiedmann wrote:Use e.g. netstat or tcpview to find the program which is using the ports.

How would I use that? Incredibly sorry for my ignorance, but when it comes to the command line, I'm largely illiterate.
SpencerDub
 
Posts: 5
Joined: 25. February 2009 21:43

Re: Trouble starting Apache under XAMPP

Postby Izzy » 25. February 2009 23:43

of status "SYSTEM
Usually this means a SYSTEM service is occupying the ports (Apache or IIS in this case) and a reboot to remove the SYSTEM entry may work.

First check that IIS (the Windows web server) is disabled in the Windows Control Panel Add remove programs or something similar in Vista.

So reboot and check again using the xampp-portcheck.exe file.

If all ports are free then you can start Apache and MySQL and go forward.

If the ports still have SYSTEM next to them instead of free post back as there may be a solution to fix it.
Last edited by Izzy on 31. March 2009 22:44, edited 3 times in total.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: Trouble starting Apache under XAMPP

Postby newbie2244 » 25. February 2009 23:57

Greetings-

I received the same message, but in my case it was because I had two copies of xampp installed, one on each hard disk, and there seemed to be some contention. When I disconnected my external hard disk, the problem went away. Check to be sure that you only have one copy of xampp and its componenets running at a time. The fact that there was a directory mismatch was not fatal.
newbie2244
 
Posts: 49
Joined: 20. February 2009 22:39

Re: Trouble starting Apache under XAMPP

Postby SpencerDub » 26. February 2009 04:18

Problem solved, I believe.

This was all my own darn fault-- I had forgotten to properly stop my external hard drive's instance of XAMPP before starting the new one on my thumb drive. I rebooted, and everything was golden; and then, just to check, I plugged in my external, ran XAMPP from there and then closed it correctly, then ran XAMPP from my thumb drive. Everything worked perfectly.

Thanks, everyone, for helping. Figures that the common sense solution-- reboot-- was the one I didn't try.
SpencerDub
 
Posts: 5
Joined: 25. February 2009 21:43

Re: Trouble starting Apache under XAMPP

Postby lotster » 02. March 2009 10:48

Hi! I have the same problem, however, portcheck shows that all my ports are "free". Still, it doesn't want to start Apache. (I'm running XP SP3, had same problem with Vista SP1.) Could anyone help, please? Oh, and I only have one XAMPP installed...
lotster
 
Posts: 4
Joined: 02. March 2009 10:41

Re: Trouble starting Apache under XAMPP

Postby Izzy » 02. March 2009 10:52

Run xampp\apache_start.bat file and see if the error message contains a clue.
Last edited by Izzy on 12. March 2009 09:30, edited 1 time in total.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: Trouble starting Apache under XAMPP

Postby Cybergoose » 03. March 2009 05:33

I've had this problem on every installation of XAMPP (v1.7.0 w/Patch2) I've done so far and run into it when trying to restart Apache after modifying the Document Root in Apache's config file. After saving the config file I click the strart button in the XAMPP control panel and receive the same messages as you.

To get around this I simply click the checkbox next to Apache in the XAMPP control panel to uninstall the service then click again to install. Click the start button again and all is good.
Cybergoose
 
Posts: 3
Joined: 03. March 2009 03:53

Re: Trouble starting Apache under XAMPP

Postby lotster » 03. March 2009 15:09

Thanks, I tried that, but unfortunately it didn't work for me. I checked XAMPP_START.EXE, and the message I get is (apache_start.bat says exactly the same):

Syntax error on line 477 of c:/xampplite/apache/conf/httpd.conf: Syntax error on line 7 of c:/xampplite/apache/conf/extra/httpd-xampp.conf: Cannot load C:/xampplite/apache/bin/php5apache2_2.dll into server: The specified module could not be found.

I checked all the different conf files and I checked for the presence of php5apache2_2.dll, and everything seems okay...

Btw, I also just noticed XAMPP-CONTROL says "Directory Mismatch". I don't know if it's related... I tried re-installing, still have the same problems.
lotster
 
Posts: 4
Joined: 02. March 2009 10:41

Re: Trouble starting Apache under XAMPP

Postby Izzy » 03. March 2009 22:29

Directory Mismatch has been covered many times before and a search would have found this:
viewtopic.php?p=108259#p108259

You can also choose to ignore the message as it will not affect XAMPP in any way.

Syntax error on line 477 of c:/xampplite/apache/conf/httpd.conf: Syntax error on line 7 of c:/xampplite/apache/conf/extra/httpd-xampp.conf: Cannot load C:/xampplite/apache/bin/php5apache2_2.dll into server: The specified module could not be found.
Installing the Microsoft.NET Framework 1.1 has been reported to fix this issue.

This Google Search may help with where to get it.
Last edited by Izzy on 12. March 2009 09:32, edited 1 time in total.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: Trouble starting Apache under XAMPP

Postby derita » 04. March 2009 13:42

Has anyone got a link to "port-check.exe" then I can check the port conflicts.I have seen several references to thsi application but have not been able to find the place to download it from

Thanks

Derrick
derita
 
Posts: 1
Joined: 04. March 2009 13:37

Re: Trouble starting Apache under XAMPP

Postby Izzy » 04. March 2009 21:45

derita wrote:Has anyone got a link to "port-check.exe"...
The reference to a port check in these forums is usually the one that comes with XAMPP and can be found in the folder you installed XAMPP in - usually C:\xampp\xampp-portcheck.exe
Last edited by Izzy on 12. March 2009 09:34, edited 1 time in total.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: Trouble starting Apache under XAMPP

Postby lotster » 05. March 2009 08:20

I have tried .NET 1.1, 2.0, and 3.0, and still it's doing the same thing... What's strange is that it's doing the same thing on both my PC's. They are both running XP Pro SP3. The only other thing that's the same on both is the wireless network... I even tried disabling that, but it's still doing the same. Any other suggestions, or should I just give it up as a lost case?
lotster
 
Posts: 4
Joined: 02. March 2009 10:41

Re: Trouble starting Apache under XAMPP

Postby Izzy » 05. March 2009 08:39

Suggestion:
Delete xampplite and download the full EXE (7zip) version of XAMPP and extract the files to the C:\ drive which will put all the XAMPP files in the C:\xampp folder.

Then run setup-xampp.bat file to set the paths.

Run xampp-control.exe from the xampp folder which is the XAMPP Control Panel (XCP) click on Start Apache and Click on MySQL Start but do not click on any of the Admin... buttons or your installation will chuck a wobbly.

Go to http://localhost and try all the demos.
Last edited by Izzy on 12. March 2009 09:35, edited 1 time in total.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Next

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 22 guests