Syntax error on line 477...

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Syntax error on line 477...

Postby lingorr » 25. February 2009 07:17

Trying an uninstalled xampplite 1.70 at the root of a non-C drive, and attempting to start apache gives me this error:

apache.exe: Syntax error on line 477 of C:/xampplite/apache/conf/httpd.conf: Syn
tax error on line 7 of C:/xampplite/apache/conf/extra/httpd-xampp.conf: Cannot l
oad C:/xampplite/apache/bin/php5apache2_2.dll into server: The specified module
could not be found.

This has been mentioned on the forums before, and the supposed solutions were either to install Microsoft .Net 1.1 or place mcsvr71.dll into the apache/bin or windows/system32 folder.

However, neither solution works for me. Strangely though, this problem occurs on only one of my two XP boxes. The box that works has .NET 2, 3 and 3.5 on it, but not 1.1. The box that gives me the error has all .NETs installed on it.

Help please! What's wrong here?
Thanks!
lingorr
 
Posts: 9
Joined: 22. February 2008 23:46

Re: Syntax error on line 477...

Postby Izzy » 25. February 2009 07:43

Trying an uninstalled xampplite 1.70 at the root of a non-C drive, and attempting to start apache gives me this error:
Not sure that an uninstalled xampplite version in any location would work - is that correct that you have xampplite in a non C:\ drive location like D:\ perhaps?

Did you run setup_xampp.bat file after installing to set the paths, as your syntax error clearly states that xampplite is installed in the C: drive root
apache.exe: Syntax error on line 477 of C:/xampplite/apache/conf/httpd.conf:
Syntax error on line 7 of C:/xampplite/apache/conf/extra/httpd-xampp.conf:
Cannot load C:/xampplite/apache/bin/php5apache2_2.dll into server:
The specified module could not be found.
Last edited by Izzy on 12. March 2009 10:31, edited 1 time in total.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: Syntax error on line 477...

Postby lingorr » 25. February 2009 08:14

Oh, it's C: because I copied that from a previous poster who had the same problem and didn't want to type out the whole thing.
But rest assured, I get that same error from the drive I do run it from.
And by uninstalled, I mean I run it from the unzip version, not the installer one.
As I understand it, the setupbat is only necessary if you put all the xampp files somewhere other than the top level of your drive.
lingorr
 
Posts: 9
Joined: 22. February 2008 23:46

Re: Syntax error on line 477...

Postby Izzy » 25. February 2009 08:21

If you install the zip version then you should run the setup_xampp.bat file to set the paths especially as the default drive is C and you have installed to another drive.

Run the bat file and then try and start Apache again and see if the syntax error returns.

The readme_en.txt file Step 1 may have changed from the good old days as now it is required you run the bat file to set the paths.
Step 1: Unpack the package into a directory of your choice.
Please start the "setup_xampp.bat" and beginning the installation.
Note: XAMPP makes no entries in the windows registry and no settings for the system variables.
The only time you don't run the bat file now is when you install to a USB drive.
Last edited by Izzy on 12. March 2009 10:33, edited 1 time in total.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: Syntax error on line 477...

Postby lingorr » 25. February 2009 08:55

Downloaded a fresh copy of the zip, unzipped to root of another drive, did nothing to any of the files. Ran setupxamppbat, then ran apachestartbat, and same error.

Why would it say the module is missing, when the file is right there in the folder?
lingorr
 
Posts: 9
Joined: 22. February 2008 23:46

Re: Syntax error on line 477...

Postby Izzy » 25. February 2009 09:07

Try this and see if it fixes your syntax issues - change the drive letter to yours and make sure the line does contain your drive letter after running the setup bat file.

Line 7 in the httpd-xampp.conf file reads
LoadModule php5_module "C:/xampp/apache/bin/php5apache2_2.dll"

change it to
LoadModule php5_module "C:/xampp/apache/bin/php5apache2.dll"

Save the file and try and restart Apache again.

In the bin folder the 2 dll files are the same size and date but just have a different name ending number.
Last edited by Izzy on 12. March 2009 10:35, edited 1 time in total.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: Syntax error on line 477...

Postby lingorr » 25. February 2009 11:38

Well Izzy, thank you for trying to help, but I found a solution before I noticed your last post. I deleted xampplite and downloaded the full xampp, and it works just fine.
Thanks again.
lingorr
 
Posts: 9
Joined: 22. February 2008 23:46

Re: Syntax error on line 477...

Postby JohnB » 11. April 2009 14:32

I've just installed XAMPP Lite on a new laptop running Windows XP Pro Sp3, with .NET 1.1 installed, and I'm getting this error. At the moment downloading the full version of XAMPP isn't an option, as I only have dial-up speed mobile internet access. It took 4 attempts to download 17Mb, so I have no hope of downloading a much bigger file!

Has anyone found a solution to the problem in Lite?
JohnB
 
Posts: 2
Joined: 11. April 2009 14:20

Re: Syntax error on line 477...

Postby JohnB » 15. April 2009 15:36

I've just downloaded Lite version 1.7.1 and it worked first time. So it looks like the problem is fixed :D
JohnB
 
Posts: 2
Joined: 11. April 2009 14:20


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 51 guests