loading up swf files, movie not loaded?? why?

Problems with the Windows version of XAMPP, questions, comments, and anything related.

loading up swf files, movie not loaded?? why?

Postby da1 » 23. February 2009 17:50

hi..
i have installed xampp on a windows xp pro. made a test website with flash contents. the script calls a swf file and a JS file to open. its from speedtest.net. (will post at the bottom). when i go on the local server to load this domain, it displays the tester in flash but when use another computer, it doesnt.

i then, installed tomcat, ran the server, tested the 'helloworld' examples to see if it works. then, still the same problem.

is it because i need to put the js file in a certian directory or something?
here is the code:

Code: Select all
<!-- BEGIN SPEED TEST - DO NOT ALTER BELOW-->
<script type="text/javascript" src="speedtest/swfobject.js"></script>
<div id="speedtest">
Speed Test requires at least version 8 of Flash. <a href="http://www.macromedia.com/shockwave/download/download.cgi?P1_Prod_Version=ShockwaveFlash">Please update your client</a>.

</div>
<script type="text/javascript">
   var so = new SWFObject("speedtest.swf?v=2.0.7", "speedtest", "450", "250", "8", "#171715");
   so.addVariable("upload_extension", "php");
   so.write("speedtest");
</script>
<!-- END SPEED TEST - DO NOT ALTER ABOVE -->


thanks!
da1
 
Posts: 2
Joined: 23. February 2009 17:44

Re: loading up swf files, movie not loaded?? why?

Postby Izzy » 23. February 2009 23:27

Your path to src="speedtest/swfobject.js" would look like this according to your code (adjust for your actual XAMPP install location:
C:\xampp\htdocs\speedtest\speedtest\swfobject.js

If you remove the speedtest/ from in front of the swfobject.js in your code so it simply is src="swfobject.js" then the path would be:
C:\xampp\htdocs\speedtest\swfobject.js
which would have the swfobject.js file in with the rest of the speedtest files.

I use a folder called scripts to keep my JS scripts all in one place which in your case would look like this:
C:\xampp\htdocs\speedtest\scripts\swfobject.js
and in the code would look like this src="scripts\swfobject.js"


BTW, a clue to your problem may have been found in the xampp\apache\logs\error.log file.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 66 guests