Access forbidden! Security

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Access forbidden! Security

Postby junior1102 » 21. February 2009 05:09

I just installed Xammp and it has been textbook up until the latest release 1.7.0.
Last week I could get to the security area with the previous release.
1.7.0 was released 2/20/2009

Any Ideas i can not move forward through joomla sequence either I am held up at the Sql database point there which is probbily from this issue.

Here is my screen text info:
http://127.0.0.1/security/lang.php?en
Access forbidden!
You don't have permission to access the requested object. It is either read-protected or not readable by the server.

If you think this is a server error, please contact the webmaster.

Error 403
127.0.0.1
02/20/09 22:00:09
Apache/2.2.11 (Win32) DAV/2 mod_ssl/2.2.11 OpenSSL/0.9.8i mod_autoindex_color PHP/5.2.8
junior1102
 
Posts: 4
Joined: 21. February 2009 04:52

Re: Access forbidden! Security

Postby Izzy » 21. February 2009 05:39

Last edited by Izzy on 12. March 2009 10:43, edited 1 time in total.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: Access forbidden! Security

Postby junior1102 » 21. February 2009 07:57

Still the same story rather it is Localhost or 127.0.0.1
I tried localhoast and 127.0.0.1 before after the change with the same results??????
junior1102
 
Posts: 4
Joined: 21. February 2009 04:52

Re: Access forbidden! Security

Postby Izzy » 21. February 2009 08:02

Clear your browser's cache and try again.
Last edited by Izzy on 12. March 2009 10:45, edited 1 time in total.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: Access forbidden! Security

Postby junior1102 » 21. February 2009 08:07

Del Browsing hist?
Am I understanding you correctly?
junior1102
 
Posts: 4
Joined: 21. February 2009 04:52

Re: Access forbidden! Security

Postby Izzy » 21. February 2009 08:09

junior1102 wrote:Del Browsing hist?
Am I understanding you correctly?
No not the History but the temporary internet files stored in a cache that the browser will serve rather than a fresh one from the server.

What browser are you using?

Is there a clue in the xampp\apache\logs\error.log file?

Can you go to http://localhost and see the XAMPP Welcome Page?

If you can, do all the demos work including the CD Collection demo?

Then, in this same page, when you click on the Security link you get the error you reported?
Last edited by Izzy on 12. March 2009 10:47, edited 1 time in total.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: Access forbidden! Security

Postby voidmind » 21. February 2009 17:19

I have the same issue. I'm using xampp lite In Apache's error log I see:

127.0.0.1 - - [21/Feb/2009:10:50:55 -0500] "GET /xampp/cds.php HTTP/1.1" 200 685
127.0.0.1 - - [21/Feb/2009:10:51:04 -0500] "GET /xampp/status.php HTTP/1.1" 200 477
bartok - - [21/Feb/2009:10:56:16 -0500] "GET /security/lang.php?en HTTP/1.1" 403 1108

Note: "bartok" is my computer name. I have no idea what it's doing there. All other stuff like the htdocs/index.php I can access fine and in the log they appear as 127.0.0.1, not "bartok"

I am accessing the security page through this link:
http://localhost/security/lang.php?en
voidmind
 
Posts: 2
Joined: 21. February 2009 17:03

Re: Access forbidden! Security

Postby voidmind » 21. February 2009 17:34

Nervermind. I added "Allow from 127.0.0.1" and it worked.
voidmind
 
Posts: 2
Joined: 21. February 2009 17:03

Re: Access forbidden! Security

Postby Wildside » 23. February 2009 23:10

Dear VOIDMIND,
What exactly do you mean by: Nervermind. I added "Allow from 127.0.0.1" and it worked.
Can you please explain what exactly you did to solve this access restriction.
Am still coping with this problem and anxious to hear your solution.
Thanks in advance.
Wildside
 
Posts: 1
Joined: 23. February 2009 22:46

Re: Access forbidden! Security

Postby Izzy » 23. February 2009 23:35

Wildside wrote:What exactly do you mean by: Nervermind. I added "Allow from 127.0.0.1" and it worked.
voidmind would have read this topic again after he posted and found the answer already here:
Izzy wrote:Try this fix:
viewtopic.php?p=136165#p136165
Last edited by Izzy on 12. March 2009 10:49, edited 1 time in total.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: Access forbidden! Security

Postby junior1102 » 24. February 2009 00:35

Izzy,
The fix you sugguested did work { viewtopic.php?p=136165#p136165}
My last reply at that time had beer involved and I did not follow your instructions correctly :D
Thanks for your help !
junior1102
 
Posts: 4
Joined: 21. February 2009 04:52

Re: Access forbidden! Security

Postby Izzy » 24. February 2009 00:40

Your welcome and I am also pleased it is now working as it should.

Best wishes and now you can enjoy your XAMPP experience again.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 38 guests

cron