Apache Startup Problems-Advice needed

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Apache Startup Problems-Advice needed

Postby mray » 19. February 2009 16:05

Hi all
I have read your advice to other members regarding this topic but they do not seem to resolve my problem.
The Problem;-
On clicking the start button in xampp control panel I see meaasge Apache Started [Port 80] but start button does not change to stop and the text "running" is flashed once the goes off. When I press the start button again the message "busy" Apache Started [Port 80] is seen.
From your advice I ran the xampp-portcheck and the status for all ports was free.
I have ran the apache_start batch file and the message was:-

apche2 is starting....
<OS 10013>An attempt was made to access a socket in a way forbidden by its access permissions.
: make_sock: unable to listen for connections on address 0.0.0.0:80
no listening sockets available, shutting down
unable to open logs

below is the section from my apache config file that deals with listening ports. should I change this and what to ?

ServerRoot "E:/xampp/apache"
#
# Listen: Allows you to bind Apache to specific IP addresses and/or
# ports, instead of the default. See also the <VirtualHost>
# directive.
#
# Change this to Listen on specific IP addresses as shown below to
# prevent Apache from glomming onto all bound IP addresses (0.0.0.0)
#
#Listen 12.34.56.78:80
Listen 80

Thank you for help
mray
 
Posts: 1
Joined: 19. February 2009 15:36

Re: Apache Startup Problems-Advice needed

Postby Izzy » 19. February 2009 23:03

[quote="mray"]From your advice I ran the xampp-portcheck and the status for all ports was free.
I have ran the apache_start batch file and the message was:-

apche2 is starting....
<OS 10013>An attempt was made to access a socket in a way forbidden by its access permissions.
: make_sock: unable to listen for connections on address 0.0.0.0:80
no listening sockets available, shutting down
unable to open logs/quote]These 2 messages seem to be in conflict.

The port check tells you that port 80 is free and the start bat file tells you it is not free.

Are you running apache as a service?

Try uninstalling the apache service then reboot and try again.
Last edited by Izzy on 12. March 2009 11:30, edited 1 time in total.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: Apache Startup Problems-Advice needed

Postby Wiedmann » 19. February 2009 23:08

and the start bat file tells you it is not free.

"not free" (only one usage...) is another error then he have.

BTW:
I've never seen this message myself and don't know what's the cause.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Apache Startup Problems-Advice needed

Postby Izzy » 20. February 2009 01:15

mray wrote:Apache Startup Problems-Advice needed
"not free" (only one usage...) is another error then he have...
I don't see any advise in that reply.

Translation issue with the word free? - more than one usage of a port means that it is not free for use by Apache, which requires exclusive use of a free port 80.

BTW the error does not say (only one usage...) as would the normal error message returned if a port is in use by another TCP/IP application.

http://httpd.apache.org/docs/2.2/platform/windows.html
The above docs wrote:Because Apache cannot share the same port with another TCP/IP application, you may need to stop, uninstall or reconfigure certain other services before running Apache. These conflicting services include other WWW servers and some firewall implementations.



@mray
Here is a list of Windows System Error Codes (exit codes) that really don't tell you much more than that which is contained in your actual error message from the bat file.
10013 An attempt was made to access a socket in a way forbidden by its access permissions.

This error you have may be related to a firewall or an anti-virus scanner controlling the ports that XAMPP requires perhaps - temporarily disable your firewall and try again and if it starts then configure your firewall to allow port 80 at least.

A list of ports can be found here, ignore the reference to XP SP2 as these FAQs need updating, but still may apply.
http://apachefriends.org/faq-xampp-windows.html#xpsp2

Also make sure if using Vista that UAC is turned off.
http://wiki.apache.org/httpd/WindowsVistaPlatform
Last edited by Izzy on 12. March 2009 11:32, edited 1 time in total.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: Apache Startup Problems-Advice needed

Postby Wiedmann » 20. February 2009 08:40

Translation issue with the word free?

No. (only a strict usage in this context)

to clarify:
The port check tells you that port 80 is free and the start bat file tells you it is not free.

Both, port check and start bat are writing that the port is free (not used by something other). But the start but tells us, that he have no access rights. If the start but tells us the the port is not free, it's writing the message with "only one usage".

I don't see any advise in that reply.

Just a correction of your answer and giving you a hint to search in another direction (well, a blocking firewall seems good).
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Apache Startup Problems-Advice needed

Postby Izzy » 20. February 2009 08:50

My answer was correct as is my interpretation of the word free which was to correct your mistranslation of the word free in any context. I have had problems before with you poor translation skills - btw, what's a start but?
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 52 guests