xampp no longer working

Problems with the Windows version of XAMPP, questions, comments, and anything related.

xampp no longer working

Postby Ladydee » 19. February 2009 14:46

I installed Xamp when I first set up my lap top. It stopped working, so I uninsalled it and re-installed it. I was using port 90 for apache since IIS uses port 80. Also my Mysql is now having problems. Please tell me how to set the ports for both of these, it is stating that there is a conflict and I turned the firewall off to do the install.

If needed I can post a copy of my http.conf file


Thank you
Ladydee
Ladydee
 
Posts: 17
Joined: 19. February 2009 14:38

Re: xampp no longer working

Postby Ladydee » 19. February 2009 17:23

OK, I finally got everything running but I can not get into locahost:90/xampp to set my user id and password for xampp nor phpadmin.

Can someone help.

Thank you
Ladydee
Ladydee
 
Posts: 17
Joined: 19. February 2009 14:38

Re: xampp no longer working

Postby Izzy » 19. February 2009 22:59

Ladydee wrote:it is stating that there is a conflict
No need to paste the httpd.conf file.

Can you post the actual error messages please.

What do you see when you run http://localhost:90/xampp


BTW it is often easier to disable IIS if you will know you are not going to use it which will then allow you to use the default httpd.conf file.

Also if you use Skype then you can configure Skype to use other ports also.

What OS are you using then I may be able to give advises how to do this reconfiguring?
Last edited by Izzy on 12. March 2009 11:13, edited 1 time in total.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: xampp no longer working

Postby Ladydee » 20. February 2009 01:20

I do use IIS as well, because I use SQL as well. I do not use Skype.

Here is the message I get when trying to enter into phpadmin:

Welcome to phpMyAdmin
#1130 - Host 'localhost' is not allowed to connect to this MySQL server
Language

Log in
Username:
Password:
Connection for controluser as defined in your configuration failed.

Thank you
LadyDee
Ladydee
 
Posts: 17
Joined: 19. February 2009 14:38

Re: xampp no longer working

Postby Izzy » 20. February 2009 01:26

Drag this file xampp\phpMyAdmin\config.inc.php in to your text editor and change this line:

$cfg['Servers'][$i]['auth_type'] = 'config';

to this:

$cfg['Servers'][$i]['auth_type'] = 'cookie';


Save the file and try to open phpMyAdmin again but first empty your browser's cache.
Last edited by Izzy on 12. March 2009 11:15, edited 1 time in total.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: xampp no longer working

Postby Ladydee » 20. February 2009 01:34

I could not find that line.

Thank you
Ladydee
Ladydee
 
Posts: 17
Joined: 19. February 2009 14:38

Re: xampp no longer working

Postby Izzy » 20. February 2009 01:44

Can you please paste the config.inc.php file here.

What Windows version are you using?

What version of XAMPP are you using?

What error message when you go to http://localhost:90 ?

What do you see when you go to http://localhost:90/security ?

BTW the alternative (http-alt) port to port 80 is port 8080 as port 90 is already assigned.
http://www.iana.org/assignments/port-numbers
Last edited by Izzy on 12. March 2009 11:17, edited 1 time in total.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: xampp no longer working

Postby Ladydee » 20. February 2009 02:40

I can get to those areas now like http://localhost:90/xampp and http://localhost:90/xamp/security. I am using xampp 1.7.0.

Here in the file:

<?php
/*
* This is needed for cookie based authentication to encrypt password in
* cookie
*/
$cfg['blowfish_secret'] = 'xampp'; /* YOU SHOULD CHANGE THIS FOR A MORE SECURE COOKIE AUTH! */

/*
* Servers configuration
*/
$i = 0;

/*
* First server
*/
$i++;

/* Authentication type and info */
$cfg['Servers'][$i]['auth_type'] = 'cookie'; // Authentication method (config, http or cookie based)
$cfg['Servers'][$i]['user'] = 'root';
$cfg['Servers'][$i]['password'] = '';
$cfg['Servers'][$i]['AllowNoPasswordRoot'] = true;

/* User for advanced features */
$cfg['Servers'][$i]['controluser'] = 'pma';
$cfg['Servers'][$i]['controlpass'] = '';

/* Advanced phpMyAdmin features */
$cfg['Servers'][$i]['pmadb'] = 'phpmyadmin';
$cfg['Servers'][$i]['bookmarktable'] = 'pma_bookmark';
$cfg['Servers'][$i]['relation'] = 'pma_relation';
$cfg['Servers'][$i]['table_info'] = 'pma_table_info';
$cfg['Servers'][$i]['table_coords'] = 'pma_table_coords';
$cfg['Servers'][$i]['pdf_pages'] = 'pma_pdf_pages';
$cfg['Servers'][$i]['column_info'] = 'pma_column_info';
$cfg['Servers'][$i]['history'] = 'pma_history';
$cfg['Servers'][$i]['designer_coords'] = 'pma_designer_coords';

/*
* End of servers configuration
*/

?>
Ladydee
 
Posts: 17
Joined: 19. February 2009 14:38

Re: xampp no longer working

Postby Izzy » 20. February 2009 02:46

The file looks fine.

You still can't access phpMyAdmin and get the error message?

Clear your browser's cache as you may be being served a cached page instead of being served the web server page - you browser cache should be cleared often when developing at localhost level.
Last edited by Izzy on 12. March 2009 11:19, edited 1 time in total.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: xampp no longer working

Postby nimd4 » 20. February 2009 02:49

Control Panel, Add/Remove Windows Components?.. Can you remove IIS, or is it in use actually?

Image

...that should be simpler :)
MSI Z68A-G45 - Intel i5-2400 - DDR3 2x2GB 1600MHz - GeForce GTS450 Palit - WD 1TB 64MB SATA - Win7 Pro/64 SP1 / Raring Xfce AMD64
User avatar
nimd4
 
Posts: 18
Joined: 20. September 2006 20:43

Re: xampp no longer working

Postby Ladydee » 20. February 2009 02:55

I use it, I doing web developing with MySQL and MS SQL. I have always used xampp, this is the first time I had a problem.

Cleared cookies and tried this in two browsers and got the same thing.

Thank you
Ladydee
Ladydee
 
Posts: 17
Joined: 19. February 2009 14:38

Re: xampp no longer working

Postby Izzy » 20. February 2009 03:04

No not cleared cookies, that won't help but cleared browser cache - in Firefox it is under tools>options>advanced>network in IE its under tools>internet options>delete files or similar.

In your httpd.conf file you changed the Listen 80 to Listen 90 correct?

In the httpd.conf file you changed ServerName localhost:80 to ServerName localhost:90 correct?

You also still have your Windows firewall disabled?
Last edited by Izzy on 12. March 2009 11:20, edited 1 time in total.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: xampp no longer working

Postby Ladydee » 20. February 2009 03:14

I believe MySQL is not running even through it says so in services and in the xampp control panel.

I just ran one of my php files which calls the database and it had ran before and I got the following:

Warning: mysql_connect() [function.mysql-connect]: Lost connection to MySQL server at 'reading initial communication packet', system error: 0 in D:\Program Files\xampp\htdocs\Mary\GeorgiaVending\manage.php on line 6

Fatal error: Maximum execution time of 60 seconds exceeded in D:\Program Files\xampp\htdocs\Mary\GeorgiaVending\manage.php on line 6


Ladydee
Ladydee
 
Posts: 17
Joined: 19. February 2009 14:38

Re: xampp no longer working

Postby Izzy » 20. February 2009 03:22

Do you have another php.ini file somewhere like in the Windows folder perhaps, if so rename or delete that php.ini file as only the one in the apache\bin folder is used in XAMPP.

http://localhost:90/xampp/phpinfo.php look for Loaded Configuration File.

Make sure in your firewall port 3306 is open.

Also try http://127.0.0.1:90/phpmyadmin
Last edited by Izzy on 12. March 2009 11:22, edited 1 time in total.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: xampp no longer working

Postby Ladydee » 20. February 2009 03:44

I checked and there is no other php on my laptop, there is another Perl and there is Python on d:/perl and d:/python. I check the phpinfo and got D:\Program Files\xampp\apache\bin\php.ini . The second option did not work http://127.0.0.1:90/phpmyadmin either.

Thanks
Ladydee
Ladydee
 
Posts: 17
Joined: 19. February 2009 14:38

Next

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 94 guests