Having problems with Apache; Can't load localhost

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Having problems with Apache; Can't load localhost

Postby alsage13 » 19. February 2009 06:08

I couldn't get Apache to install properly because it kept saying that port 80 and 443 were in use although they were (Skype and McAfee were turned off, and I'm not using IIS!) I found a fix online that required I changed a few things in the files, (ie: telling Apache to run on ports 8080 and 4499) and then Apache started working fine.

I'm still not able to view Localhost, though. I can view localhost:8080, but that doesn't help me much! I thought I found a way to turn on the (HTTPS) SSL which was deactivated, and I hoped that would solve it, but I can't figure out how to activate it.

I'm trying to install Joomla and I've spent the past 4 hours trying to figure out how to get Xampp to work first!!!

Help! This is so frustrating!
alsage13
 
Posts: 2
Joined: 19. February 2009 06:02

Re: Having problems with Apache; Can't load localhost

Postby Izzy » 19. February 2009 06:16

alsage13 wrote:...telling Apache to run on ports 8080 and 4499) and then Apache started working fine.

I'm still not able to view Localhost, though. I can view localhost:8080, but that doesn't help me much!

http://localhost was lost when you change the ports that Apache listen on.
http://localhost:8080
is now the address to be used or
https://localhost:4499

What is your issue with that as I am having a problem trying to sort out what in the above does not help you?

You may be better off by trying to find out what is using the original Apache ports by running xampp-portcheck.exe in the xampp folder, then disabling the offender and returning the httpd.conf file back to the defaults.

Then you you will be able to use http://localhost

TIP
Make sure you clear your browser's cache often when developing at localhost level or you may be served a cached page instead of the page you requested from the web server.



BTW, No need to disable Skype just change the ports that it uses.

Skype uses ports 80 and 443 by default.

You can alter that behavior by going to:
Tools\Options\Connection

Untick
Use port 80 and 443 as alternative for incoming connections

You will have to decide a different port to use for incoming connections before Skype lets you save your changes.

Use ports between 49152 through 65535.
http://www.iana.org/assignments/port-numbers
Last edited by Izzy on 12. March 2009 11:45, edited 3 times in total.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: Having problems with Apache; Can't load localhost

Postby alsage13 » 19. February 2009 06:31

I figured it out. There was an error that I overlooked. Thank you.
alsage13
 
Posts: 2
Joined: 19. February 2009 06:02

Re: Having problems with Apache; Can't load localhost

Postby Izzy » 19. February 2009 06:40

alsage13 wrote:I figured it out. There was an error that I overlooked. Thank you.
Care to tell the forum what the error was that you overlooked that gave you all these frustrating hassles?
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 33 guests