Problem with Apache and XAMPP

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Problem with Apache and XAMPP

Postby andreicek » 15. February 2009 12:40

Well I cant access my page, I changed IP to 192.168.1.8. All was working fine since now. Now when I try to access my page I get this.
Code: Select all
Network Timeout
The server at 192.168.1.8 is taking too long to respond.   
The requested site did not respond to a connection request and the browser has stopped waiting for a reply.

    * Could the server be experiencing high demand or a temporary outage?  Try again later.
    * Are you unable to browse other sites? Check the computer's network connection.
    * Is your computer or network protected by a firewall or proxy?  Incorrect settings can interfere with Web browsing.
    * Still having trouble? Consult your network administrator or Internet provider for assistance.
But when I try to access it from computer that haves XAMPP (192.168.1.8) it lodes ok. Is a problem in XAMPP or my other computer? I can access all internet pages and there is no firewall.
My name is Andrei, I use XAMPP for building my own LAN NETWORK INTRANET.
andreicek
 
Posts: 16
Joined: 07. January 2009 20:59

Re: Problem with Apache and XAMPP

Postby Wiedmann » 15. February 2009 12:45

I changed IP to 192.168.1.8

Can you explain this more detailed?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Problem with Apache and XAMPP

Postby andreicek » 15. February 2009 13:23

I created static IP in Windows. There is a problem with XAMPP, now I now for shure. I reinstalled Windows on computer from what I tried to access. The problem is still on. I need this urgent. What can I do?
My name is Andrei, I use XAMPP for building my own LAN NETWORK INTRANET.
andreicek
 
Posts: 16
Joined: 07. January 2009 20:59

Re: Problem with Apache and XAMPP

Postby Wiedmann » 15. February 2009 13:29

I created static IP in Windows.

OK. (just assign a statiic ip, no changes in the Apache configuration)

So from your XAMPP pc you can access the server with "http://127.0.0.1/" or "http://192.168.1.8/". But you can't access the server from another pc on the same LAN with "http://192.168.1.8/". Correct?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Problem with Apache and XAMPP

Postby andreicek » 15. February 2009 13:35

Yes, and I need it fast. I think of reinstaling Windows.
My name is Andrei, I use XAMPP for building my own LAN NETWORK INTRANET.
andreicek
 
Posts: 16
Joined: 07. January 2009 20:59

Re: Problem with Apache and XAMPP

Postby Wiedmann » 15. February 2009 14:28

But you can't access the server from another pc on the same LAN with "http://192.168.1.8/"

Yes

- Sure there is no filewall or other antivirus/"security" software on the XAMPP pc?
- Can you telnet to the XAMPP pc from the other pc?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Problem with Apache and XAMPP

Postby andreicek » 15. February 2009 16:46

Now I reinstalled Windows. I hope that will help...
My name is Andrei, I use XAMPP for building my own LAN NETWORK INTRANET.
andreicek
 
Posts: 16
Joined: 07. January 2009 20:59

Re: Problem with Apache and XAMPP

Postby andreicek » 16. February 2009 09:21

This is the story: I reinstalled Windows, installed XAMPP, APACHE runing as service, FileZilla also. Now with another computer in the network I am tring to access 192.168.1.8 (IP adress for another computer). I am always getting a message that page cannot be found. I can access 192.168.1.8 form that computer. The router haves firewall, I can try to shutdown that tool if needed. What can I do? :( :(
My name is Andrei, I use XAMPP for building my own LAN NETWORK INTRANET.
andreicek
 
Posts: 16
Joined: 07. January 2009 20:59

Re: Problem with Apache and XAMPP

Postby andreicek » 16. February 2009 09:32

The problem was right in font of my nose. The Windows Firewall was blocking my Apache, but when I turned off firewall it worked. Sorry for bodhering you with that. :mrgreen: :mrgreen: :mrgreen:
My name is Andrei, I use XAMPP for building my own LAN NETWORK INTRANET.
andreicek
 
Posts: 16
Joined: 07. January 2009 20:59


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 53 guests