Help please - can't get phpmyadmin to work

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Help please - can't get phpmyadmin to work

Postby G101 » 14. February 2009 09:10

Hi there,

I'm trying to set-up xampp as a local server on my machine so that I can build and test websites and evaluate joomla and drupal.

I succesfully installed Joomla but after when I was installing Drupal on my localhost I changed the password (as directed) in http://localhost/phpmyadmin/. When I refreshed the page/ went back to http://localhost/phpmyadmin/ I got the following message:

MySQL said: Cannot connect: invalid settings.

phpMyAdmin tried to connect to the MySQL server, and the server rejected the connection. You should check the host, username and password in your configuration and make sure that they correspond to the information given by the administrator of the MySQL server
.


Since I had only just started with xampp I uninstalled and re-installed and STILL have the same error message, what am I doing wrong? The only other file I changed when setting up xampp was the windows/drivers/etc/hosts file and added my url (i.e. added 127.0.0.1 localhost at the bottom of the file)

The strange thing is that you would think that the problem would have been fixed after uninstalling and re-installing xampp - can any one help? I'm sure it is something quite simple that I've missed but can't see wht.

Thanks in advance from a rapidly-learning new-user.
G101
 
Posts: 2
Joined: 14. February 2009 08:53

Re: Help please - can't get phpmyadmin to work

Postby Izzy » 14. February 2009 09:29

G101 wrote:...I changed the password (as directed) in http://localhost/phpmyadmin/
Which user password did you change.
Tip
Never use the super user root for any databases you create, always create a different user/pass for each database you create.

Have you tried changing the password for root in http://localhost/security

G101 wrote:...I uninstalled and re-installed
How exactly did you do that?

G101 wrote:The only other file I changed when setting up xampp was the windows/drivers/etc/hosts file and added my url (i.e. added 127.0.0.1 localhost at the bottom of the file)
127.0.0.1 localhost should be the first entry after the commented lines not the last.

G101 wrote:The strange thing is that you would think that the problem would have been fixed after uninstalling and re-installing xampp
If you uninstalled correctly then the problem would have been fixed.


Anything in these search results for phpmyadmin that may be of help?
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: Help please - can't get phpmyadmin to work

Postby G101 » 14. February 2009 11:43

Thanks,

I uninstalled and used the xampplite version in the end and now I have both drupal and joomla on my localhost
G101
 
Posts: 2
Joined: 14. February 2009 08:53


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 58 guests