Cannot 'start' Apache

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Cannot 'start' Apache

Postby DPD_Mac » 14. February 2009 00:05

I'm in the process of trying to install a 'local' copy of WordPress. The procedure I'm trying to follow prescribed installing 'XAMPP lite', which I have done. Using XAMPP I have been able to start SQL but I have not been able to start Apache. Here are some of the relevant conditions:
* 'xampp-portcheck' reports that all ports are open
* I have installed XAMPP in the root directory (C:) of my Windows XP
* I have attempted to start Apache with my Windows firewall OFF and with my virus scanning OFF, no success
* I am running Windows XP as a virtual machine, within Parallels, on my iMac
* My browser is Firefox 3.0.6
* Here is the result (command-prompt window) of trying to start Apache with the "Apache_Start' batch file
***********************************************************************************************************************************************
Diese Eingabeforderung nicht waehrend des Running beenden
Bitte erst bei einem gewollten Shutdown schliessen
Please close this command only for Shutdown
Apache 2 is starting ...
apache.exe: Syntax error on line 477 of C:/xampplite/apache/conf/httpd.conf: Syn
tax error on line 7 of C:/xampplite/apache/conf/extra/httpd-xampp.conf: Cannot l
oad C:/xampplite/apache/bin/php5apache2_2.dll into server: The specified module
could not be found.

Apache konnte nicht gestartet werden
Apache could not be started
Press any key to continue . . .
***************************************************************************************************************************************************
If my problem is truly a syntax error on line 477 I have no idea of how to correct it, but can I even be confident that is the root problem?
I have searched this forum and it seems that problems with getting Apache to run are not that unusual but I haven't found any threads that suggest a solid solution to the issue I am experiencing. I'd guess there is a solution obvious to you experienced hands at this game though. Thanks
DPD_Mac
 
Posts: 3
Joined: 13. February 2009 23:16

Re: Cannot 'start' Apache

Postby ghost-busters.de » 14. February 2009 00:28

read this: Cannot load C:/xampplite/apache/bin/php5apache2_2.dll into server: The specified modulecould not be found.
Dunkel die eine Seite ist, sehr dunkel... Halts Maul Yoda und friss deinen Toast!
ghost-busters.de
 
Posts: 14
Joined: 13. February 2009 23:58
Location: Berlin

Re: Cannot 'start' Apache

Postby Izzy » 14. February 2009 01:10

ghost-busters.de wrote:read this: Cannot load C:/xampplite/apache/bin/php5apache2_2.dll into server: The specified modulecould not be found.
If the OP reads that line then what do you propose he does to correct it, that is if you know the solution, which would be of more help than your current reply?
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: Cannot 'start' Apache

Postby ghost-busters.de » 14. February 2009 01:20

Apology, my English is very bad. I assume simply, which is missing the DLL. That states also the error message. Did you examine that times?
Dunkel die eine Seite ist, sehr dunkel... Halts Maul Yoda und friss deinen Toast!
ghost-busters.de
 
Posts: 14
Joined: 13. February 2009 23:58
Location: Berlin

Re: Cannot 'start' Apache

Postby Izzy » 14. February 2009 01:31

ghost-busters.de wrote:Apology, my English is very bad.
My German is like your English and is why I don't post in a German language forum

ghost-busters.de wrote:I assume simply, which is missing the DLL. That states also the error message. Did you examine that times?
A forum search may help you and the OP to understand this issue and find a possible solution.

BTW the error message does not state that the DLL is missing it simply states The specified module could not be found and unlike you I did examine the error message as I have done many times before this topic was raised again.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: Cannot 'start' Apache

Postby ghost-busters.de » 14. February 2009 11:27

Terminate all services ( Filezilla, SQL, Apache etc.) and secure for you there entire xampp Verzeichniss.
Afterwards you start a renewed installation. Perhaps the problem is then repaired.
Dunkel die eine Seite ist, sehr dunkel... Halts Maul Yoda und friss deinen Toast!
ghost-busters.de
 
Posts: 14
Joined: 13. February 2009 23:58
Location: Berlin

Re: Cannot 'start' Apache

Postby DPD_Mac » 14. February 2009 16:27

Viele danke. Ich will unternehmen weider das herunterladen von XAMPP zu (meine deusche ist nicht so gut also bitte meine english erlaube).
Thank you for your responses. I believe I understand that you are suggesting that I remove my current installation of XAMPP and then download and reinstall it again. I expect that attempting to find the php5apache2_2.dll file and to insert it the correct way might prove to be beyond my level of expertise, so I'll try the reinstall procedure first.
DPD_Mac
 
Posts: 3
Joined: 13. February 2009 23:16

Re: Cannot 'start' Apache

Postby DPD_Mac » 14. February 2009 16:43

Update... I did a search on my system for the php5apache2_2.dll file. I found it in the correct location (C:/xampplite/apache/bin/php5apache2_2.dll). With this knowledge does anyone know what I should do to resolve the error condition? Apparently something is preventing this .dll file from loading even though it seems to be found in the right place.
DPD_Mac
 
Posts: 3
Joined: 13. February 2009 23:16

Re: Cannot 'start' Apache

Postby Wiedmann » 14. February 2009 17:21

With this knowledge does anyone know what I should do to resolve the error condition?

Install the .NET Framework 1.1 on your pc.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 45 guests