Apache crashes in new install on XP

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Apache crashes in new install on XP

Postby hughworm » 12. February 2009 18:49

I've just installed XAMPP on an XP machine.

I get an error message in red across the top of the XAMPP home page:
"Warning: Variable passed to each() is not an array or object in D:\XAMPP\htdocs\xampp\head.php on line 27"

PHPInfo() works from the XAMPP home page menu.

BUT if I choose phpMyAdmin from the home page menu (to http://localhost/phpmyadmin/) apache crashes with the following error reported in the windows event log:
Faulting application apache.exe, version 2.2.11.0, faulting module php5ts.dll, version 5.2.8.8, fault address 0x0000abae.

The only changes I've made from the installation are
- to my.ini in mysql and
- having read the forum I modified D:\XAMPP\apache\conf\extra\httpd-xampp.conf, changing localhost to 127.0.0.1 in 2 places, to allow me to load the security page at http://localhost/security/index.php.

Help!
Cheers.
hughworm
 
Posts: 2
Joined: 12. February 2009 18:34

Re: Apache crashes in new install on XP

Postby hughworm » 12. February 2009 22:38

OK I've sorted it. It was caused by an improperly uninstalled previous version of PHP. :roll:

The reason for the initial error was apache not recognising the <? tag because PHP was picking up the old PHP.ini file with "short_open_tag = Off".

I guess the crash was due to clash of incompatible PHP versions. I cleaned up the old install, reinstalled XAMPP and all seems happy...
hughworm
 
Posts: 2
Joined: 12. February 2009 18:34


Return to XAMPP for Windows

Who is online

Users browsing this forum: milaz357 and 54 guests