Can't get mysql to run and getting error 10013

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Can't get mysql to run and getting error 10013

Postby jsibley » 06. February 2009 00:39

I have installed XAMPP in WinXP and can run Apache and Filezilla. When I try to start MySQL I get this:

Diese Eingabeforderung nicht waehrend des Running beenden
Please dont close Window while MySQL is running
MySQL is trying to start
Please wait ...
MySQL is starting with mysql\bin\my.cnf (console)
090205 18:34:27 InnoDB: Started; log sequence number 0 46409
Can't start server: listen() on TCP/IP port: No such file or directory
090205 18:34:27 [ERROR] listen() on TCP/IP failed with error 10013
090205 18:34:27 [ERROR] Aborting

090205 18:34:27 InnoDB: Starting shutdown...
090205 18:34:28 InnoDB: Shutdown completed; log sequence number 0 46409
090205 18:34:28 [Note] mysql\bin\mysqld: Shutdown complete


MySQL konnte nicht gestartet werden
MySQL could not be started
Press any key to continue . . .

----
Port 3306 is free. I have tried the uninstall bat file for MySQL and then tried starting it again.

Any thoughts about what else to try or what other information would be helpful? Thanks!
jsibley
 
Posts: 2
Joined: 06. February 2009 00:34

Re: Can't get mysql to run and getting error 10013

Postby Izzy » 06. February 2009 00:54

Any clues in the Windows Event Viewer?

Any clues in the Apache error.log file?

Did you install XAMPP using the installer version and elect to start services?

Try a reboot, then try and start MySQL again.

If the reboot fails then you could try this:
start>Run...
type cmd> then OK
type sc delete mysql >then OK

Then try again to start MySQL.

It has been know for Firefox and other browsers to use port 3306 and others near to this range of port numbers, in the normal running of the browser which I have been able fix by using X-NetStat Pro ($$$) to end activity on that port - try closing your browser and wait about 5 minutes for the system to close the ports that the browser used, then try and start MySQL again.


Last resort - often a complete uninstall as per the readme_en.txt file including uninstalling all services and closing the XCP and then a reinstall using the EXE (7zip) or the zip archive version can eliminate odd errors.


Please post back if any of the above helped with your problem.
Thanks.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: Can't get mysql to run and getting error 10013

Postby jsibley » 06. February 2009 06:14

Thanks for your help.

After several attempts to uninstall and reinstall, it looks like Mcafee firewall was getting in the way. When I turned off the firewall, MySQL finally started up.
jsibley
 
Posts: 2
Joined: 06. February 2009 00:34

Re: Can't get mysql to run and getting error 10013

Postby Izzy » 06. February 2009 07:58

Thanks for posting back with your solution.

You may be able to configure your firewall to allow port 3306 rather than leave it disabled.

Good luck.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 58 guests