New to XAMP phpmyadmin problem

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Re: New to XAMP phpmyadmin problem

Postby kiltedscotsman5 » 15. February 2009 03:33

Nevermind the login/password question; I just tried "root" with no password, and it worked.
kiltedscotsman5
 
Posts: 11
Joined: 15. February 2009 01:48

Re: New to XAMP phpmyadmin problem

Postby Izzy » 15. February 2009 03:38

kiltedscotsman5 wrote:Nevermind the login/password question; I just tried "root" with no password, and it worked.
To change the root password or rather add a root password go to http://localhost/security

You have to type a command after mysql at the command prompt like mysql --help

XAMPP should work out of the box on a new installation but now at least you are armed for most eventualities that may arise.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: New to XAMP phpmyadmin problem

Postby kiltedscotsman5 » 15. February 2009 03:49

Here's what I get on the command prompt:
C:\Documents and Settings\Administrator> mysql -help
'mysql' is not recognized as an internal or external command,
operable program or hatch file

C:\Documents and Settings\Administrator>
kiltedscotsman5
 
Posts: 11
Joined: 15. February 2009 01:48

Re: New to XAMP phpmyadmin problem

Postby Izzy » 15. February 2009 03:53

kiltedscotsman5 wrote:Here's what I get on the command prompt:
C:\Documents and Settings\Administrator> mysql -help
'mysql' is not recognized as an internal or external command,
operable program or hatch file

C:\Documents and Settings\Administrator>


C:\Documents and Settings\Administrator>cd C:\xampp\mysql\bin <-- or your path here
Click enter
C:\xampp\mysql\bin>mysql --help
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: New to XAMP phpmyadmin problem

Postby kiltedscotsman5 » 15. February 2009 03:57

Tried that, got:

'-help' is not recognized as an internal or external command,
operable program or hatch file.

I realize that i should be content that phpMyAdmin works, but I get nervous when EVERYTHING that is supposed to work, doesn't.
kiltedscotsman5
 
Posts: 11
Joined: 15. February 2009 01:48

Re: New to XAMP phpmyadmin problem

Postby Izzy » 15. February 2009 04:00

kiltedscotsman5 wrote:...'-help' is not recognized as an internal or external command,
operable program or hatch file...
Try mysql --help at the command prompt in the mysql bin folder.

To clarify.
You must be in the bin folder to execute the mysql command.

This command prompt must be showing in the console window then type the above command.
C:\xampp\mysql\bin>mysql --help <-- note the double --
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: New to XAMP phpmyadmin problem

Postby kiltedscotsman5 » 15. February 2009 04:14

The double hyphen did it! Excellent!

Thank you so much... is there a resource I could go to that covers the general theory of what we have been doing - the language(s) that the various configuration files are written, what they do, etc.? I am the kind that is happiest knowing as much as possible about any topic, so that I can be self-sufficient.
kiltedscotsman5
 
Posts: 11
Joined: 15. February 2009 01:48

Re: New to XAMP phpmyadmin problem

Postby Izzy » 15. February 2009 04:21

You could no better than to use Google and search for php manual, apache manual and visit the mysql web site - look through the files and various folders in the main xampp folder and you may find some help files and also read the comments in the various configuration files as they often contain some very useful help.

Good luck and I hope now you can enjoy your XAMPP experience.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: New to XAMP phpmyadmin problem

Postby kiltedscotsman5 » 15. February 2009 06:00

One last question: is there any reason why I should not now go back in and set up again the virtual hosts I mentioned earlier, making the changes that i described to Hosts, httpd.conf, and httpd-vhosts.conf?
kiltedscotsman5
 
Posts: 11
Joined: 15. February 2009 01:48

Re: New to XAMP phpmyadmin problem

Postby Izzy » 15. February 2009 06:07

None what soever and in fact I recommend it - usually though the httpd.conf file should always remain at the defaults when creating vhosts.

If you get stuck there are many post with successful outcomes for vhost configurations on the forum and of course we are here to help where we can at all times.

Best wishes.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: New to XAMP phpmyadmin problem

Postby elias75 » 22. March 2009 11:13

Hello Izzy,
I have the same problem connecting to mysql db and I have been following this thread... your recommendations did got me somewhere but I am stuck again and can't connect. Here is some info:

from the xampp control panel Apache is running fine but when click start on Mysql I get the message: "Mysql service not started [-1]" also in xampp status mysql is "deactivated"

when I click on phpmyadmin I get a welcome message and asking me to enter password & username (btw never set password)

if I try "root" with no password I get "#2003 - The server is not responding" and "Connection for controluser as defined in your configuration failed."

if I go to localhost/security to set a password I get "The MySQL server is not running or is blocked by a firewall! Please check this problem first ..."

Firewall is set to allow xampp cache is also cleared
I have XP SP3 Apache is newly installed (xampp 1.7.0 & MySql 5.1.30)

here is the error log:
[Sun Mar 22 09:49:14 2009] [warn] pid file C:/xampp/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
[Sun Mar 22 09:49:16 2009] [notice] Digest: generating secret for digest authentication ...
[Sun Mar 22 09:49:16 2009] [notice] Digest: done
[Sun Mar 22 09:49:24 2009] [notice] Apache/2.2.11 (Win32) DAV/2 mod_ssl/2.2.11 OpenSSL/0.9.8i mod_autoindex_color PHP/5.2.8 configured -- resuming normal operations
[Sun Mar 22 09:49:24 2009] [notice] Server built: Dec 10 2008 00:10:06
[Sun Mar 22 09:49:24 2009] [notice] Parent: Created child process 3748
[Sun Mar 22 09:49:30 2009] [notice] Digest: generating secret for digest authentication ...
[Sun Mar 22 09:49:30 2009] [notice] Digest: done
[Sun Mar 22 09:49:31 2009] [notice] Child 3748: Child process is running
[Sun Mar 22 09:49:31 2009] [notice] Child 3748: Acquired the start mutex.
[Sun Mar 22 09:49:31 2009] [notice] Child 3748: Starting 250 worker threads.
[Sun Mar 22 09:49:31 2009] [notice] Child 3748: Starting thread to listen on port 443.
[Sun Mar 22 09:49:31 2009] [notice] Child 3748: Starting thread to listen on port 80.
[Sun Mar 22 10:45:58 2009] [notice] Parent: Received shutdown signal -- Shutting down the server.
[Sun Mar 22 10:45:58 2009] [notice] Child 3748: Exit event signaled. Child process is ending.
[Sun Mar 22 10:45:59 2009] [notice] Child 3748: Released the start mutex
[Sun Mar 22 10:46:00 2009] [notice] Child 3748: All worker threads have exited.
[Sun Mar 22 10:46:00 2009] [notice] Child 3748: Child process is exiting
[Sun Mar 22 10:46:00 2009] [notice] Parent: Child process exited successfully.
[Sun Mar 22 10:46:04 2009] [notice] Digest: generating secret for digest authentication ...
[Sun Mar 22 10:46:04 2009] [notice] Digest: done
[Sun Mar 22 10:46:05 2009] [notice] Apache/2.2.11 (Win32) DAV/2 mod_ssl/2.2.11 OpenSSL/0.9.8i mod_autoindex_color PHP/5.2.8 configured -- resuming normal operations
[Sun Mar 22 10:46:05 2009] [notice] Server built: Dec 10 2008 00:10:06
[Sun Mar 22 10:46:05 2009] [notice] Parent: Created child process 2648
[Sun Mar 22 10:46:06 2009] [notice] Digest: generating secret for digest authentication ...
[Sun Mar 22 10:46:06 2009] [notice] Digest: done
[Sun Mar 22 10:46:06 2009] [notice] Child 2648: Child process is running
[Sun Mar 22 10:46:06 2009] [notice] Child 2648: Acquired the start mutex.
[Sun Mar 22 10:46:06 2009] [notice] Child 2648: Starting 250 worker threads.
[Sun Mar 22 10:46:06 2009] [notice] Child 2648: Starting thread to listen on port 443.
[Sun Mar 22 10:46:06 2009] [notice] Child 2648: Starting thread to listen on port 80.
[Sun Mar 22 10:56:51 2009] [warn] pid file C:/xampp/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
[Sun Mar 22 10:56:51 2009] [notice] Digest: generating secret for digest authentication ...
[Sun Mar 22 10:56:51 2009] [notice] Digest: done
[Sun Mar 22 10:56:52 2009] [notice] Apache/2.2.11 (Win32) DAV/2 mod_ssl/2.2.11 OpenSSL/0.9.8i mod_autoindex_color PHP/5.2.8 configured -- resuming normal operations
[Sun Mar 22 10:56:52 2009] [notice] Server built: Dec 10 2008 00:10:06
[Sun Mar 22 10:56:52 2009] [notice] Parent: Created child process 3048
[Sun Mar 22 10:56:53 2009] [notice] Digest: generating secret for digest authentication ...
[Sun Mar 22 10:56:53 2009] [notice] Digest: done
[Sun Mar 22 10:56:56 2009] [notice] Child 3048: Child process is running
[Sun Mar 22 10:56:56 2009] [notice] Child 3048: Acquired the start mutex.
[Sun Mar 22 10:56:56 2009] [notice] Child 3048: Starting 250 worker threads.
[Sun Mar 22 10:56:56 2009] [notice] Child 3048: Starting thread to listen on port 80.
[Sun Mar 22 10:56:56 2009] [notice] Child 3048: Starting thread to listen on port 443.

here is also the HOSTS file:

# Copyright © 1993-1999 Microsoft Corp.
#
# This is a sample HOSTS file used by Microsoft TCP/IP for Windows.
#
# This file contains the mappings of IP addresses to host names. Each
# entry should be kept on an individual line. The IP address should
# be placed in the first column followed by the corresponding host name.
# The IP address and the host name should be separated by at least one
# space.
#
# Additionally, comments (such as these) may be inserted on individual
# lines or following the machine name denoted by a "#" symbol.
#
# For example:
#
# 102.54.94.97 rhino.acme.com # source server
# 38.25.63.10 x.acme.com # x client host
#
127.0.0.1 localhost

here is the config.inc.php

<?php
/*
* This is needed for cookie based authentication to encrypt password in
* cookie
*/
$cfg['blowfish_secret'] = 'xampp'; /* YOU SHOULD CHANGE THIS FOR A MORE SECURE COOKIE AUTH! */

/*
* Servers configuration
*/
$i = 0;

/*
* First server
*/
$i++;

/* Authentication type and info */
$cfg['Servers'][$i]['auth_type'] = 'cookie';
$cfg['Servers'][$i]['user'] = 'root';
$cfg['Servers'][$i]['password'] = '';
$cfg['Servers'][$i]['AllowNoPasswordRoot'] = true;

/* User for advanced features */
$cfg['Servers'][$i]['controluser'] = 'root';
$cfg['Servers'][$i]['controlpass'] = '';

/* Advanced phpMyAdmin features */
$cfg['Servers'][$i]['pmadb'] = 'phpmyadmin';
$cfg['Servers'][$i]['bookmarktable'] = 'pma_bookmark';
$cfg['Servers'][$i]['relation'] = 'pma_relation';
$cfg['Servers'][$i]['table_info'] = 'pma_table_info';
$cfg['Servers'][$i]['table_coords'] = 'pma_table_coords';
$cfg['Servers'][$i]['pdf_pages'] = 'pma_pdf_pages';
$cfg['Servers'][$i]['column_info'] = 'pma_column_info';
$cfg['Servers'][$i]['history'] = 'pma_history';
$cfg['Servers'][$i]['designer_coords'] = 'pma_designer_coords';

/*
* End of servers configuration
*/

?>

also the Loaded Configuration File is C:\xampp\apache\bin\php.ini

sorry if this is too much..... please let me know if you need any other info

thanks
elias
elias75
 
Posts: 15
Joined: 12. March 2009 12:24

Re: New to XAMP phpmyadmin problem

Postby Izzy » 22. March 2009 11:24

Is there a tick in the MySQL Svc box in the XAMPP Control Panel (XCP)?

You won't be able to access phpMyAdmin until we get MySQL started as it uses a MySQL database and needs to connect just like a script would.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: New to XAMP phpmyadmin problem

Postby elias75 » 22. March 2009 11:28

yes there is tick in the MySQL Svc box in the XAMPP Control Panel
elias75
 
Posts: 15
Joined: 12. March 2009 12:24

Re: New to XAMP phpmyadmin problem

Postby Izzy » 22. March 2009 11:38

If you remove the tick in the MySQL Svc box then answer the questions, can you then start MySQL?
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: New to XAMP phpmyadmin problem

Postby elias75 » 22. March 2009 11:42

if I remove the tick in the box, a new window opens with "click OK to uninstall the MySql Service"
shall I proceed to uninstall MySql Service ??
elias75
 
Posts: 15
Joined: 12. March 2009 12:24

PreviousNext

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 50 guests