New to XAMP phpmyadmin problem

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Re: New to XAMP phpmyadmin problem

Postby Izzy » 10. February 2009 21:43

Username = root
If you have not set a password then don't type anything in the Password box.
Click Go.


To set a user root password for phpMyAdmin/MySQL follow the instructions in the readme_en.txt file found in the xampp folder.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: New to XAMP phpmyadmin problem

Postby Danilux » 11. February 2009 06:32

Nope, root doesn't work, i tried my nick and password but nothing, when i put root in the portal i get the error from the my first post:

Image


I checked the readme and i went to the security link to set up a password but it doesn't allow me to enter a pass for the mysql section it gives me this error:

Code: Select all
MYSQL SECTION: "ROOT" PASSWORD
 
MySQL SuperUser:    root
     
The MySQL server is not running or is blocked by a firewall! Please check this problem first ...


And here is a screenshot of the security check that says the firewall problem too, i have outpost firewall and since i only want to use xampp locally i didn't let mysql to go out to internet when i first ran xampp, do you think that may be problem? Thanks.

Image
Danilux
 
Posts: 10
Joined: 03. February 2009 00:10

Re: New to XAMP phpmyadmin problem

Postby Izzy » 11. February 2009 06:50

The messages are hard coded and can't tell if a firewall is blocking or the server is simply not running but if as you say you blocked them then that is your problem.

You must at least allow the following ports to pass through your firewall:
80 http
443 https
3306 MySQL


All the ports XAMPP uses can be found when you go to:
http://localhost/security and scroll down.

If you are working on localhost then it will not go out to the Internet anyway but still your firewall must allow those ports to pass through it or the firewall will block all access to those ports.

You can block requests coming into your PC on those ports if your server is running, usually by responding to a pop up message, or at least I can on my old Sygate Pro firewall.

Firewall rules are very flexible and can control ports in many ways, so perhaps you need to read the manual and see if you can set your firewall to do what you want without interfering with your server on local use but block for remote use, this is also possible on my old Sygate.

Code: Select all
 The XAMPP default ports:

ftp          21/tcp         # File Transfer [Control] (XAMPP: FTP Default Port)
smtp         25/tcp         # Simple Mail Transfer (XAMPP: SMTP Default Port)
http         80/tcp         # World Wide Web HTTP (XAMPP: Apache Default Port)
pop3         110/tcp         # Post Office Protocol - Version 3 (XAMPP: POP3 Default Port)
imap         143/tcp         # Internet Message Access Protocol (XAMPP: IMAP Default Port)
https         443/tcp         # http protocol over TLS/SSL (XAMPP: Apache SSL Port)
mysql         3306/tcp         # MySQL (XAMPP: MySQL Default Port)
AJP/1.3         8009         # AJP/1.3 (XAMPP: Tomcat AJP/1.3 Port)
http-alt         8080/tcp         # HTTP Alternate (see port 80) (XAMPP: Tomcat Default Port)

 
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: New to XAMP phpmyadmin problem

Postby Danilux » 13. February 2009 08:43

That's it, i wanna thank you for helping me to get it working, i think most of the problems came from blocking the port with the firewall, now everything is working as it should, Thank you one more time Izzi :mrgreen:
Danilux
 
Posts: 10
Joined: 03. February 2009 00:10

Re: New to XAMP phpmyadmin problem

Postby Izzy » 13. February 2009 09:05

Your most welcome and I am also pleased that you finally have it working.

Good luck and now you can enjoy XAMPP. :)
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: New to XAMP phpmyadmin problem

Postby kiltedscotsman5 » 15. February 2009 01:53

Izzy, I am having the same problem. I have followed along step by step, and up til the change in the file config.inc.php, I had been getting identical results. When I changed the variable assignement to the value "cookie", however, I did not get any different results, even after a reboot. phpmyadmin stubbornly refuses to run, I get the same error #2003, and typing "mysql" in the command line gets me nothing either.

Can you help?
kiltedscotsman5
 
Posts: 11
Joined: 15. February 2009 01:48

Re: New to XAMP phpmyadmin problem

Postby Izzy » 15. February 2009 02:00

To help I will need actual error messages as I can't see your PC from here.

Look in the apache\logs\error.log file at the time and date you attempt to start PMA.

What message when you type:
http://localhost/phpmyadmin in your browser?
or
http://127.0.0.1/phpmyadmin

Try and be as detailed as possible please, then there may be a chance of spotting your issue and also make sure that a firewall or anti-virus scanner is not blocking access.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: New to XAMP phpmyadmin problem

Postby kiltedscotsman5 » 15. February 2009 02:30

1. Here's what I found in the error log file:

[Sat Feb 14 18:16:44 2009] [notice] Digest: generating secret for digest authentication ...
[Sat Feb 14 18:16:44 2009] [notice] Digest: done
[Sat Feb 14 18:16:54 2009] [notice] Apache/2.2.11 (Win32) DAV/2 mod_ssl/2.2.11 OpenSSL/0.9.8i mod_autoindex_color PHP/5.2.8 configured -- resuming normal operations
[Sat Feb 14 18:16:54 2009] [notice] Server built: Dec 10 2008 00:10:06
[Sat Feb 14 18:16:55 2009] [notice] Parent: Created child process 4296
[Sat Feb 14 18:16:58 2009] [notice] Digest: generating secret for digest authentication ...
[Sat Feb 14 18:16:58 2009] [notice] Digest: done
[Sat Feb 14 18:16:58 2009] [notice] Child 4296: Child process is running
[Sat Feb 14 18:16:58 2009] [notice] Child 4296: Acquired the start mutex.
[Sat Feb 14 18:16:58 2009] [notice] Child 4296: Starting 250 worker threads.
[Sat Feb 14 18:16:59 2009] [notice] Child 4296: Starting thread to listen on port 443.
[Sat Feb 14 18:16:59 2009] [notice] Child 4296: Starting thread to listen on port 80.

2. When I go to http://localhost, I get the standard XAMPP welcome screen, with the options to try the demos (they all work, I tried every one), launch phpmyadmin, etc.

3. When I click on phpmyadmin from that welcome screen, I get the same error that the previous user described:
Welcome to phpMyAdmin
Error
MySQL said:

#2003 - The server is not responding

Connection for controluser as defined in your configuration failed.

HOWEVER:

4. When I try http://127.0.01/phpmyadmin in the URL box, I get a log in screen, asking for a login and password... I had never tried that method of getting to phpMyAdmin before, so I am pleased... and yet, I would like the other method to work as well.

Do you need more info from me?

- Nathan
kiltedscotsman5
 
Posts: 11
Joined: 15. February 2009 01:48

Re: New to XAMP phpmyadmin problem

Postby Izzy » 15. February 2009 02:42

OK, I think we have narrowed it down now.

Drag this file into your text editor
C:\Windows\system32\drivers\etc\HOSTS

Look for this line:
::1 localhost

Either delete it or comment it out like so
# ::1 localhost

Save the file and then try http://localhost/phpmyadmin again.

Make sure you are using a text editor and that you are saving these configuration files in XAMPP as text not utf-8 or any other encoding.

BTW your error.log file looks fine.

If the above doesn't work we are not finished yet.
Last edited by Izzy on 15. February 2009 03:01, edited 2 times in total.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: New to XAMP phpmyadmin problem

Postby kiltedscotsman5 » 15. February 2009 02:48

In the etc folder, there is no "HOST" file, there is only "Hosts", which I had modified in a previous iteration of XAMPP (3 or 4 uninstall/reinstalls ago), to include some virtual hosts for 127.0.0.1

In any case, there is no HOST file, and there is no line in "Hosts" remotely like what you described. Here is the full text of the "Hosts" file:

# Copyright (c) 1993-1999 Microsoft Corp.
#
# This is a sample HOSTS file used by Microsoft TCP/IP for Windows.
#
# This file contains the mappings of IP addresses to host names. Each
# entry should be kept on an individual line. The IP address should
# be placed in the first column followed by the corresponding host name.
# The IP address and the host name should be separated by at least one
# space.
#
# Additionally, comments (such as these) may be inserted on individual
# lines or following the machine name denoted by a '#' symbol.
#
# For example:
#
# 102.54.94.97 rhino.acme.com # source server
# 38.25.63.10 x.acme.com # x client host

127.0.0.1 localhost
127.0.0.1 hfphp
127.0.0.1 phppractice
kiltedscotsman5
 
Posts: 11
Joined: 15. February 2009 01:48

Re: New to XAMP phpmyadmin problem

Postby Izzy » 15. February 2009 02:52

Typo, Hosts it is.

Ok now paste here the contents of xampp\phpmyadmin\config.inc.php <--no typo here I hope.

Also go to http://localhost/xampp/phpinfo.php and see what the line
Loaded Configuration File is.

Have you made any other configuration file changes at all in XAMPP apart from the httpd-vhosts.conf file perhaps?
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: New to XAMP phpmyadmin problem

Postby kiltedscotsman5 » 15. February 2009 03:08

<?php
/*
* This is needed for cookie based authentication to encrypt password in
* cookie
*/
$cfg['blowfish_secret'] = 'xampp'; /* YOU SHOULD CHANGE THIS FOR A MORE SECURE COOKIE AUTH! */

/*
* Servers configuration
*/
$i = 0;

/*
* First server
*/
$i++;

/* Authentication type and info */
$cfg['Servers'][$i]['auth_type'] = 'cookie';
$cfg['Servers'][$i]['user'] = 'root';
$cfg['Servers'][$i]['password'] = '';
$cfg['Servers'][$i]['AllowNoPasswordRoot'] = true;

/* User for advanced features */
$cfg['Servers'][$i]['controluser'] = 'pma';
$cfg['Servers'][$i]['controlpass'] = '';

/* Advanced phpMyAdmin features */
$cfg['Servers'][$i]['pmadb'] = 'phpmyadmin';
$cfg['Servers'][$i]['bookmarktable'] = 'pma_bookmark';
$cfg['Servers'][$i]['relation'] = 'pma_relation';
$cfg['Servers'][$i]['table_info'] = 'pma_table_info';
$cfg['Servers'][$i]['table_coords'] = 'pma_table_coords';
$cfg['Servers'][$i]['pdf_pages'] = 'pma_pdf_pages';
$cfg['Servers'][$i]['column_info'] = 'pma_column_info';
$cfg['Servers'][$i]['history'] = 'pma_history';
$cfg['Servers'][$i]['designer_coords'] = 'pma_designer_coords';

/*
* End of servers configuration
*/

?>
kiltedscotsman5
 
Posts: 11
Joined: 15. February 2009 01:48

Re: New to XAMP phpmyadmin problem

Postby kiltedscotsman5 » 15. February 2009 03:16

Loaded Configuration File C:\xampp\apache\bin\php.ini

Any other configuration changes I made previously were made to files that would have been lost when I uninstalled XAMPP. That said, I did open xampp\apache\conf\httpd.conf to make sure the line including httpd-vhosts.conf was not commented out (it wasn't). I also opened xampp\apache\conf\extra\httpd-vhosts.conf, and added blocks of code for each of the virtual hosts I wanted to add. I just confirmed, however, that those blocks of code are not there anymore.
kiltedscotsman5
 
Posts: 11
Joined: 15. February 2009 01:48

Re: New to XAMP phpmyadmin problem

Postby Izzy » 15. February 2009 03:24

The config.inc.php file looks correct as does the loaded php.ini file.

This question needs asking, have you cleared your browser's cache or tried another browser that you have not tried accessing PMA before?

The browser cache can be your worst enemy when developing at localhost level and needs to be cleared often especially if you are getting strange inexplicable errors.

The strange thing now is that PMA loads with the local loopback IP address but not the localhost address and we have tried to eliminate the reason for this.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: New to XAMP phpmyadmin problem

Postby kiltedscotsman5 » 15. February 2009 03:30

*sigh* Yes, clearing the cache seemed to do it.

Thank you so much. Now, where do I go to set a login and password for mySQL? Or should I revisit one of the other threads to find the answer?

Also, typing "mysql" at the command prompt doesn't seem to do anything, and I was led to believe that it would. Can you shed any light there?

Finally, if I were to download and install xampp on a machine with a fresh install of XP, which had never had IIS or any other server installed, would I still have to deal with these same problems, do you know? Or is everything that we have been doing, simply a set of corrections for problems created by previous installs of either xampp or IIS?

Thanks,
Nathan
kiltedscotsman5
 
Posts: 11
Joined: 15. February 2009 01:48

PreviousNext

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 61 guests