New to XAMP phpmyadmin problem

Problems with the Windows version of XAMPP, questions, comments, and anything related.

New to XAMP phpmyadmin problem

Postby Danilux » 03. February 2009 00:33

Hi i just downloaded xamp lite the zip version 1.7, and i'm following this http://www.tamba2.org.uk/wordpress/xampp/ tutorial in order to run wordpress locally, i did everything the guide says but when i get to the point where xamp welcomes me and then i click phpmyadmin for the first time i get an error:

Code: Select all
Welcome to phpMyAdmin

Error

MySQL has said: Documentation
#2003 - The server is not responding
The connection for controluser, as defined in the configuration, Failed.



Also after that when i try to close xamp the mysql service freezes and i have to shut the proccess down in order to close xamp everytime, and in the xamp control center it says this:
Code: Select all
Current Directory:  C:\xampplite
Install Directory:
***Warning Directory Missmatch***
Status check OK
Busy
Apache Started  [Port 80]
Busy
Mysql Started  [Port 3306]
Busy






I'm running windows xp pro sp3 and outpost firewall, if you need any more information let me know, Hope someone can help me, thanks.
Danilux
 
Posts: 10
Joined: 03. February 2009 00:10

Re: New to XAMP phpmyadmin problem

Postby Izzy » 03. February 2009 01:16

Up to the point where the tut tells you to load http://localhost/xampp/splash.php looks to be in order.

I would prefer you to go to http://localhost only and then follow the instructions, even though you will eventually end up at The Welcome Page with all the menus - then test all the demos to see if your XAMPP installation has been successful before proceeding to do anything else.

I suggest you uninstall your current XAMPP installation by stopping all XAMPP components and uninstalling any services including the XCP (remove any ticks in the Svc boxes) and then delete the xampp folder.

Now install again but use the Full XAMPP version (I also recommended the EXE (7zip) version) to the C:\ drive and then run the setup_xampp.bat file to set the correct paths.

Now go to http://localhost and select your language then test your installation by clicking on all the demos - I don't have the lite version as it is what it says in the description (useless for any serious use).

Then when all is working as it should, try phpMyAdmin again.

If you have had another instance of PHP or phpMyAdmin installed then this could also affect the XAMPP installation - check that there is no php.ini file in the Windows folder and if there is then rename it to php.ini.old for example.

BTW a forum search for wordpress in the XAMPP for Windows forum may also find some helpful WP install advices and even a tutorial or 2.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: New to XAMP phpmyadmin problem

Postby Danilux » 03. February 2009 03:53

OK i unninstalled the lite version closing all services following your guide, i installed the full version i tested all the demos and all the other options too such as webalizer, PHP Switch, Mercury Mail, Filezilla etc. Everything work but phpmyadmin gives me again the same errors, i don't know what could be wrong really, When i close Apache from the xamp control panel it closes but Mysql freezes again and i have to shut the process down.
Danilux
 
Posts: 10
Joined: 03. February 2009 00:10

Re: New to XAMP phpmyadmin problem

Postby Izzy » 03. February 2009 04:05

Go to xampp folder and click on mysql_stop.bat file.

Then go to xampp\mysql and double click on mysql_uninstallservice.bat file then try again.

If that doesn't help:
Go to start>Run... Type sc delete mysql >OK

Then try again.

You may have a sticking service that will not allow you to proceed.
Izzy wrote:If you have had another instance of PHP or phpMyAdmin installed then this could also affect the XAMPP installation - check that there is no php.ini file in the Windows folder and if there is then rename it to php.ini.old for example.
or MySQL ???
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: New to XAMP phpmyadmin problem

Postby Danilux » 03. February 2009 05:55

Hi izzi thanks for helping in the first place, well i did all that but it's the same so i reinstall it again and now at least i can stop the Mysql process from the xamp control panel without freezing, i have no php.ini in the windows folder i did had a my.ini that had information of the lite xampp so i deleted the file and reinstall it again but nothing changed, when i click phpmyadmin the same error appears. :?
Danilux
 
Posts: 10
Joined: 03. February 2009 00:10

Re: New to XAMP phpmyadmin problem

Postby Izzy » 03. February 2009 06:11

Did you clear your browser's cache before trying to access phpMyAdmin as it is your worst enemy when at localhost level?

Any clues in the xampp\apache\logs\error.log file after you try and access phpMyAdmin?
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: New to XAMP phpmyadmin problem

Postby Danilux » 07. February 2009 06:23

Yes i did cleand the cache, i tried 3 different browsers too, about the error.log here it is:
Code: Select all
[Sat Feb 07 02:17:31 2009] [notice] Digest: generating secret for digest authentication ...
[Sat Feb 07 02:17:31 2009] [notice] Digest: done
PHP Warning:  PHP Startup: Unable to load dynamic library 'C:\\xampplite\\php\\ext\\php_pdf.dll' - Can't find the m\xf3dulo especified.\r\n in Unknown on line 0
[Sat Feb 07 02:17:37 2009] [notice] Apache/2.2.11 (Win32) DAV/2 mod_ssl/2.2.11 OpenSSL/0.9.8i mod_autoindex_color PHP/5.2.8 configured -- resuming normal operations
[Sat Feb 07 02:17:37 2009] [notice] Server built: Dec 10 2008 00:10:06
[Sat Feb 07 02:17:37 2009] [notice] Parent: Created child process 884
[Sat Feb 07 02:17:41 2009] [notice] Digest: generating secret for digest authentication ...
[Sat Feb 07 02:17:41 2009] [notice] Digest: done
PHP Warning:  PHP Startup: Unable to load dynamic library 'C:\\xampplite\\php\\ext\\php_pdf.dll' - Can't find the m\xf3dulo especified.\r\n in Unknown on line 0
[Sat Feb 07 02:17:41 2009] [notice] Child 884: Child process is running
[Sat Feb 07 02:17:41 2009] [notice] Child 884: Acquired the start mutex.
[Sat Feb 07 02:17:41 2009] [notice] Child 884: Starting 250 worker threads.
[Sat Feb 07 02:17:41 2009] [notice] Child 884: Starting thread to listen on port 443.
[Sat Feb 07 02:17:41 2009] [notice] Child 884: Starting thread to listen on port 80.


Weird thing, i was able to install xamp on windows 7 without a problem, i don't know why i can't get phpmyadmin to run on the xp partition.
Danilux
 
Posts: 10
Joined: 03. February 2009 00:10

Re: New to XAMP phpmyadmin problem

Postby Izzy » 07. February 2009 07:14

error log wrote:PHP Warning: PHP Startup: Unable to load dynamic library 'C:\\xampplite\\php\\ext\\php_pdf.dll' - Can't find the m\xf3dulo especified.\r\n in Unknown on line 0
You still have a php.ini file floating around somewhere that is not in the xampp\apache\bin folder - delete the C:\xampplite folder or rename it to Copy of xampplite and this may get rid of this error that is not helping you go forward.

Start Apache then go to http://localhost/xampp/phpinfo.php in your browser and look for the line:
Loaded Configuration File and tell me what it says please.

Also do a search of your PC for any php.ini files and see where they all are and delete or rename any you find except the one in the xampp\apache\bin folder.

See how that goes.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: New to XAMP phpmyadmin problem

Postby Danilux » 09. February 2009 00:28

Ok i did a search in my pc and found some php.ini files and i erased them all also i erased the my.ini file on c:\windows and reinstall xampp but this time i installed the full version and i added Apache and mysql as services, here's what phpinfo.php says:

Code: Select all
Configuration File (php.ini) Path    C:\WINDOWS
Loaded Configuration File    C:\xampp\apache\bin\php.ini



The same error ocurrs with phpmyadmin :( , also before unninstaling the lite version it started to get a different error when i clicked on xamp-setup it said Something like can't find phpcli i don't know if that is relevant but now with the full version i don't have this error though, Thanx for keep on helping me izzy and sorry for my bad english.
Danilux
 
Posts: 10
Joined: 03. February 2009 00:10

Re: New to XAMP phpmyadmin problem

Postby Izzy » 09. February 2009 02:22

Can you recap and paste the error messages you now receive when trying to access http://localhost/phpmyadmin please?

Do you know how to read and edit the Environment Variable paths?
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: New to XAMP phpmyadmin problem

Postby Danilux » 10. February 2009 04:59

The error is the same from the first post:

Code: Select all
    Welcome to phpMyAdmin

    Error

    MySQL has said: Documentation
    #2003 - The server is not responding
    The connection for controluser, as defined in the configuration, Failed.



I search the forum for the error phpcli and i found this link where you posted help to another guy http://community.apachefriends.org/f/viewtopic.php?f=16&t=27956 and followed the intructions from your post:

Code: Select all
Open the Windows Control Panel
Click on System->Advanced->Environment Variables

There are 2 path locations
User variables->PATH
System variables->Path

Click on Edit on both of these and add at the beginning
C:\xampp;C:\xampp\php;

Click OK Click OK Click OK


But nothing, my computer just don't like xampp, i think i'm gonna give up, i tried a lot but there seems to be no way i can run it in xp, thanks for all the help mate.
Danilux
 
Posts: 10
Joined: 03. February 2009 00:10

Re: New to XAMP phpmyadmin problem

Postby Izzy » 10. February 2009 05:13

Don't give up so soon, we are not finished this troubleshoot yet. :)

BTW I did not want you to add anything to the path variables, I wanted you to find any other php paths that might be in the path variables also if you found this entry:
SetEnv PHPRC "path"
it should be deleted.

Can you open C:\xampp\phpMyAdmin folder and drag this file config-inc.php into your text editor then copy and paste back here the contents, please.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: New to XAMP phpmyadmin problem

Postby Danilux » 10. February 2009 06:51

Thanks for keep on giving me a hand with this, well erased the path i made, and there is no SetEnv PHPRC path in the variables, I found a "config.inc.php" file, i don't know if it's the one you are asking cause this one doesn't have a - after the config "config-inc.php" instead it's "config.inc.php" here it is:

Code: Select all
<?php
/*
 * This is needed for cookie based authentication to encrypt password in
 * cookie
 */
$cfg['blowfish_secret'] = 'xampp'; /* YOU SHOULD CHANGE THIS FOR A MORE SECURE COOKIE AUTH! */

/*
 * Servers configuration
 */
$i = 0;

/*
 * First server
 */
$i++;

/* Authentication type and info */
$cfg['Servers'][$i]['auth_type'] = 'config';
$cfg['Servers'][$i]['user'] = 'root';
$cfg['Servers'][$i]['password'] = '';
$cfg['Servers'][$i]['AllowNoPasswordRoot'] = true;

/* User for advanced features */
$cfg['Servers'][$i]['controluser'] = 'pma';
$cfg['Servers'][$i]['controlpass'] = '';

/* Advanced phpMyAdmin features */
$cfg['Servers'][$i]['pmadb'] = 'phpmyadmin';
$cfg['Servers'][$i]['bookmarktable'] = 'pma_bookmark';
$cfg['Servers'][$i]['relation'] = 'pma_relation';
$cfg['Servers'][$i]['table_info'] = 'pma_table_info';
$cfg['Servers'][$i]['table_coords'] = 'pma_table_coords';
$cfg['Servers'][$i]['pdf_pages'] = 'pma_pdf_pages';
$cfg['Servers'][$i]['column_info'] = 'pma_column_info';
$cfg['Servers'][$i]['history'] = 'pma_history';
$cfg['Servers'][$i]['designer_coords'] = 'pma_designer_coords';

/*
 * End of servers configuration
 */

?>
Danilux
 
Posts: 10
Joined: 03. February 2009 00:10

Re: New to XAMP phpmyadmin problem

Postby Izzy » 10. February 2009 07:38

Yes that was the file config.inc.php - sorry, typo. ;)

Change this line:
$cfg['Servers'][$i]['auth_type'] = 'config';

to this:
$cfg['Servers'][$i]['auth_type'] = 'cookie';

Save the file and try and load http://localhost/phpmyadmin

Fingers crossed. :)
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: New to XAMP phpmyadmin problem

Postby Danilux » 10. February 2009 18:55

I think this may have worked, now when i click on phpmyadmin it opens a portal that says:

phpMyadmin

Welcome to phpMyadmin


Lenguage:
Here i choose the lenguage in a drop down menu.


Log in:
Nick:
User:

The weird thing is i don't remember setting up a password, i tried with the one i always use in case i had set it up before but it doesn't work, is there a file i can edit to change de pass, thanks i think we are in the right track now :D
Danilux
 
Posts: 10
Joined: 03. February 2009 00:10

Next

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 55 guests