[H]Socket Error (Apache)

Problems with the Windows version of XAMPP, questions, comments, and anything related.

[H]Socket Error (Apache)

Postby RockyNguyen » 30. January 2009 20:45

I just installed XAMPP and I tried to start Apache and MySQL. MySQL ran fine but Apache did not start each time I pressed the button. I went and ran apache_start.bat and it gave me this message:

Image

Any fix?

Thanks. :D
RockyNguyen
 
Posts: 3
Joined: 30. January 2009 20:42
Location: Hawthorne, California

Re: [H]Socket Error (Apache)

Postby Wiedmann » 30. January 2009 21:36

Any fix?

Sure, stop the program which is already using port 80 (like you can read in any other thread with this error message).
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: [H]Socket Error (Apache)

Postby RockyNguyen » 30. January 2009 22:23

Ooh, sorry I didn't do a search. Yeah, it's like the first rule of forums. >_<

I also have another question. How do I make it so that Apache/MySQL runs on startup? :oops:
RockyNguyen
 
Posts: 3
Joined: 30. January 2009 20:42
Location: Hawthorne, California

Re: [H]Socket Error (Apache)

Postby Wiedmann » 30. January 2009 22:44

How do I make it so that Apache/MySQL runs on startup?

Install both as Windows service.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: [H]Socket Error (Apache)

Postby RockyNguyen » 31. January 2009 01:35

Uhh, one last question. <_<

Is there anyway I can change the port that Apache runs on? You never know when there might be a time where I need to have Skype and my server on at the same time. XD

Thank you for all your help so far. You've been really helpful. :D
RockyNguyen
 
Posts: 3
Joined: 30. January 2009 20:42
Location: Hawthorne, California

Re: [H]Socket Error (Apache)

Postby Izzy » 31. January 2009 02:08

You are best changing the port Skype runs on then you will always be able to run them both together without having to add a port number to your URI to access your Apache server - can be a pain.

Skype>Tools>Options...>Connections> change Use port to say 55555 remove the tick for Use port 80 and 443 click on Save

Now enjoy both at once.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 51 guests