localhost security Access forbidden Error 403 *Win 2000Pro

Problems with the Windows version of XAMPP, questions, comments, and anything related.

localhost security Access forbidden Error 403 *Win 2000Pro

Postby sprinteroz » 27. January 2009 12:06

Hi everyone I'm new to this kind of thing .

My problem is whenever i go to (security). https://localhost/security/lang.php?en I get this error?

Access forbidden!
You don't have permission to access the requested object. It is either read-protected or not readable by the server.

If you think this is a server error, please contact the webmaster.

Error 403
localhost
01/27/09 20:59:20
Apache/2.2.11 (Win32) DAV/2 mod_ssl/2.2.11 OpenSSL/0.9.8i mod_autoindex_color PHP/5.2.8


Also so extra info to help you help me:

MySQL database ACTIVATED
PHP ACTIVATED
HTTPS (SSL) ACTIVATED
Common Gateway Interface (CGI) ACTIVATED
Server Side Includes (SSI) ACTIVATED
SMTP Service DEACTIVATED
FTP Service DEACTIVATED

For OpenSSL support please use the test certificate with https://127.0.0.1 or https://localhost
*done both and seems OK *

If anyone can help me i would be ever so great full

Also this is a fresh install of windows server 2000 w/sp4 and a few basic updates.
Last edited by sprinteroz on 27. January 2009 13:24, edited 3 times in total.
sprinteroz
 
Posts: 6
Joined: 27. January 2009 11:43

Re: localhost security Access forbidden! Error 403

Postby Izzy » 27. January 2009 12:14

Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: localhost security Access forbidden! Error 403

Postby sprinteroz » 27. January 2009 13:10

Hi thanks for the reply, i went to the pagers and read them they were for vista viewtopic.php?f=16&t=32503 But i still give Tut/Post ago all the same and changed all the localhosts to 127.0.0.1 but this still did not work for some reason?

The site works fine so far as 127.0.0.1 its just the (security) that will not work and the comments about IPv6 in Tut's/Post must not be the problem as by the sounds of it to me as Xp and earlier versions like windows 2000 which I'm using are getting the same problem and i believe we do not have IPv6. (Correct me if I'm wrong as I'm still learning this stuff)

Error after change. address: http://127.0.0.1/security/lang.php?en

Access forbidden!

You don't have permission to access the requested object. It is either read-protected or not readable by the server.

If you think this is a server error, please contact the webmaster.
Error 403
127.0.0.1
01/27/09 22:14:30
Apache/2.2.11 (Win32) DAV/2 mod_ssl/2.2.11 OpenSSL/0.9.8i mod_autoindex_color PHP/5.2.8

---------------------------------------------------------------------------------------------------------
Inside the \xampp\apache\conf\extra\httpd-xampp.conf file
----------------------------------------------------------------------------------------------------------
# XAMPP settings
#
<IfModule alias_module>
<IfModule mime_module>
#ScriptAlias /php/ "C:/xampp/php/"
#Action application/x-httpd-php "/php/php-cgi.exe"
LoadModule php5_module "C:/xampp/apache/bin/php5apache2_2.dll"
AddType application/x-httpd-php-source .phps
AddType application/x-httpd-php .php .php5 .php4 .php3 .phtml .phpt

<Directory "C:/xampp/htdocs/xampp">
<IfModule php5_module>
<Files "status.php">
php_admin_flag safe_mode off
</Files>
</IfModule>
</Directory>

Alias /security "C:/xampp/security/htdocs/"
<Directory "C:/xampp/security/htdocs">
<IfModule php5_module>
<Files "xamppsecurity.php">
php_admin_flag safe_mode off
</Files>
</IfModule>
Order deny,allow
Deny from all
Allow from 127.0.0.1
</Directory>

Alias /phpmyadmin "C:/xampp/phpMyAdmin/"
<Directory "C:/xampp/phpMyAdmin">
AllowOverride AuthConfig
Order allow,deny
Allow from all
</Directory>

Alias /webalizer "C:/xampp/webalizer/"
<Directory "C:/xampp/webalizer">
<IfModule php5_module>
<Files "webalizer.php">
php_admin_flag safe_mode off
</Files>
</IfModule>
AllowOverride AuthConfig
Order allow,deny
Allow from all
</Directory>

Alias /contrib "C:/xampp/contrib/"
<Directory "C:/xampp/contrib">
<IfModule php5_module>
<Files "webalizer.php">
php_admin_flag safe_mode off
</Files>
</IfModule>

Order deny,allow
Deny from all
Allow from 127.0.0.1
</Directory>
</IfModule>
</IfModule>


# Access restriction via Remote
<IfModule auth_remote_module>
<Directory "C:/xampp/htdocs/fonts">
AllowOverride All
AuthType Basic
AuthName "AUTH REMOTE TEST"
AuthRemoteServer 127.0.0.1
AuthRemotePort 80
AuthRemoteURL /forbidden/
Require valid-user
#User: user / Password: pass
</Directory>
</IfModule>

# Access restriction via MySQL
<IfModule mysql_auth_module>
<Location /restricted>
AuthMySQLEnable On
AuthName "MySQL Secured Place"
AuthType Basic
require valid-user
AuthMySQLHost 127.0.0.1
AuthMySQLUser root
# AuthMySQLPassword
AuthMySQLDB webauth
AuthMySQLUserTable user_pwd
AuthMySQLNameField name
AuthMySQLPasswordField pass
AuthMySQLPwEncryption none
</Location>
</IfModule>

----------------------------------------------------------------------------------------------
Can anyone see if i missed something?

This is out of the file that people were talking about changing the ipv6 i can not see it in there


below is whats Inside host file in C:\WINNT\system32\drivers\etc\hosts
--------------------------------------------------------------------------------------------------
# Copyright (c) 1993-1999 Microsoft Corp.
#
# This is a sample HOSTS file used by Microsoft TCP/IP for Windows.
#
# This file contains the mappings of IP addresses to host names. Each
# entry should be kept on an individual line. The IP address should
# be placed in the first column followed by the corresponding host name.
# The IP address and the host name should be separated by at least one
# space.
#
# Additionally, comments (such as these) may be inserted on individual
# lines or following the machine name denoted by a '#' symbol.
#
# For example:
#
# 102.54.94.97 rhino.acme.com # source server
# 38.25.63.10 x.acme.com # x client host

127.0.0.1 localhost
----------------------------------------------------------------------------------------------------------------
This is my Error log file

[Tue Jan 27 19:14:19 2009] [notice] Digest: generating secret for digest authentication ...
[Tue Jan 27 19:14:19 2009] [notice] Digest: done
[Tue Jan 27 19:14:21 2009] [notice] Apache/2.2.11 (Win32) DAV/2 mod_ssl/2.2.11 OpenSSL/0.9.8i mod_autoindex_color PHP/5.2.8 configured -- resuming normal operations
[Tue Jan 27 19:14:21 2009] [notice] Server built: Dec 10 2008 00:10:06
[Tue Jan 27 19:14:21 2009] [notice] Parent: Created child process 704
[Tue Jan 27 19:14:22 2009] [notice] Digest: generating secret for digest authentication ...
[Tue Jan 27 19:14:22 2009] [notice] Digest: done
[Tue Jan 27 19:14:22 2009] [notice] Child 704: Child process is running
[Tue Jan 27 19:14:22 2009] [notice] Child 704: Acquired the start mutex.
[Tue Jan 27 19:14:22 2009] [notice] Child 704: Starting 250 worker threads.
[Tue Jan 27 19:14:22 2009] [notice] Child 704: Starting thread to listen on port 443.
[Tue Jan 27 19:14:22 2009] [notice] Child 704: Starting thread to listen on port 80.
[Tue Jan 27 19:17:05 2009] [warn] pid file C:/xampp/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
[Tue Jan 27 19:17:05 2009] [notice] Digest: generating secret for digest authentication ...
[Tue Jan 27 19:17:05 2009] [notice] Digest: done
[Tue Jan 27 19:17:17 2009] [notice] Apache/2.2.11 (Win32) DAV/2 mod_ssl/2.2.11 OpenSSL/0.9.8i mod_autoindex_color PHP/5.2.8 configured -- resuming normal operations
[Tue Jan 27 19:17:17 2009] [notice] Server built: Dec 10 2008 00:10:06
[Tue Jan 27 19:17:17 2009] [notice] Parent: Created child process 1056
[Tue Jan 27 19:17:18 2009] [notice] Digest: generating secret for digest authentication ...
[Tue Jan 27 19:17:18 2009] [notice] Digest: done
[Tue Jan 27 19:17:18 2009] [notice] Child 1056: Child process is running
[Tue Jan 27 19:17:18 2009] [notice] Child 1056: Acquired the start mutex.
[Tue Jan 27 19:17:18 2009] [notice] Child 1056: Starting 250 worker threads.
[Tue Jan 27 19:17:18 2009] [notice] Child 1056: Starting thread to listen on port 443.
[Tue Jan 27 19:17:18 2009] [notice] Child 1056: Starting thread to listen on port 80.
[Tue Jan 27 20:18:59 2009] [notice] Parent: Received shutdown signal -- Shutting down the server.
[Tue Jan 27 20:18:59 2009] [notice] Child 1056: Exit event signaled. Child process is ending.
[Tue Jan 27 20:19:00 2009] [notice] Child 1056: Released the start mutex
[Tue Jan 27 20:19:01 2009] [notice] Child 1056: All worker threads have exited.
[Tue Jan 27 20:19:01 2009] [notice] Child 1056: Child process is exiting
[Tue Jan 27 20:19:05 2009] [notice] Parent: Child process exited successfully.
[Tue Jan 27 20:25:44 2009] [notice] Digest: generating secret for digest authentication ...
[Tue Jan 27 20:25:44 2009] [notice] Digest: done
[Tue Jan 27 20:25:44 2009] [notice] Apache/2.2.11 (Win32) DAV/2 mod_ssl/2.2.11 OpenSSL/0.9.8i mod_autoindex_color PHP/5.2.8 configured -- resuming normal operations
[Tue Jan 27 20:25:44 2009] [notice] Server built: Dec 10 2008 00:10:06
[Tue Jan 27 20:25:44 2009] [notice] Parent: Created child process 1056
[Tue Jan 27 20:25:45 2009] [notice] Digest: generating secret for digest authentication ...
[Tue Jan 27 20:25:45 2009] [notice] Digest: done
[Tue Jan 27 20:25:46 2009] [notice] Child 1056: Child process is running
[Tue Jan 27 20:25:46 2009] [notice] Child 1056: Acquired the start mutex.
[Tue Jan 27 20:25:46 2009] [notice] Child 1056: Starting 250 worker threads.
[Tue Jan 27 20:25:46 2009] [notice] Child 1056: Starting thread to listen on port 443.
[Tue Jan 27 20:25:46 2009] [notice] Child 1056: Starting thread to listen on port 80.
[Tue Jan 27 20:26:47 2009] [notice] Parent: Received shutdown signal -- Shutting down the server.
[Tue Jan 27 20:26:47 2009] [notice] Child 1056: Exit event signaled. Child process is ending.
[Tue Jan 27 20:26:48 2009] [notice] Child 1056: Released the start mutex
[Tue Jan 27 20:26:49 2009] [notice] Child 1056: All worker threads have exited.
[Tue Jan 27 20:26:49 2009] [notice] Child 1056: Child process is exiting
[Tue Jan 27 20:26:51 2009] [notice] Parent: Child process exited successfully.
[Tue Jan 27 20:27:34 2009] [notice] Digest: generating secret for digest authentication ...
[Tue Jan 27 20:27:34 2009] [notice] Digest: done
[Tue Jan 27 20:27:34 2009] [notice] Apache/2.2.11 (Win32) DAV/2 mod_ssl/2.2.11 OpenSSL/0.9.8i mod_autoindex_color PHP/5.2.8 configured -- resuming normal operations
[Tue Jan 27 20:27:34 2009] [notice] Server built: Dec 10 2008 00:10:06
[Tue Jan 27 20:27:34 2009] [notice] Parent: Created child process 1112
[Tue Jan 27 20:27:35 2009] [notice] Digest: generating secret for digest authentication ...
[Tue Jan 27 20:27:35 2009] [notice] Digest: done
[Tue Jan 27 20:27:36 2009] [notice] Child 1112: Child process is running
[Tue Jan 27 20:27:36 2009] [notice] Child 1112: Acquired the start mutex.
[Tue Jan 27 20:27:36 2009] [notice] Child 1112: Starting 250 worker threads.
[Tue Jan 27 20:27:36 2009] [notice] Child 1112: Starting thread to listen on port 443.
[Tue Jan 27 20:27:36 2009] [notice] Child 1112: Starting thread to listen on port 80.
[Tue Jan 27 20:29:25 2009] [error] [client 127.0.0.1] client denied by server configuration: C:/xampp/security/htdocs/lang.php, referer: http://localhost/xampp/navi.php
[Tue Jan 27 20:29:38 2009] [error] [client 127.0.0.1] client denied by server configuration: C:/xampp/security/htdocs/lang.php, referer: http://localhost/xampp/navi.php
[Tue Jan 27 20:30:13 2009] [error] [client 127.0.0.1] client denied by server configuration: C:/xampp/security/htdocs/lang.php, referer: http://localhost/xampp/navi.php
[Tue Jan 27 20:39:03 2009] [error] [client 127.0.0.1] client denied by server configuration: C:/xampp/security/htdocs/lang.php, referer: http://localhost/xampp/navi.php
[Tue Jan 27 20:46:08 2009] [error] [client 127.0.0.1] client denied by server configuration: C:/xampp/security/htdocs/lang.php, referer: http://localhost/xampp/navi.php
[Tue Jan 27 20:46:12 2009] [error] [client 127.0.0.1] client denied by server configuration: C:/xampp/security/htdocs/lang.php, referer: http://localhost/xampp/navi.php
[Tue Jan 27 20:46:26 2009] [error] [client 127.0.0.1] client denied by server configuration: C:/xampp/security/htdocs/lang.php, referer: http://localhost/xampp/navi.php
[Tue Jan 27 20:46:33 2009] [error] [client 127.0.0.1] client denied by server configuration: C:/xampp/security/htdocs/
[Tue Jan 27 20:46:34 2009] [error] [client 127.0.0.1] client denied by server configuration: C:/xampp/security/htdocs/
[Tue Jan 27 20:46:56 2009] [error] [client 127.0.0.1] File does not exist: C:/xampp/htdocs/xampp/admin
[Tue Jan 27 20:47:41 2009] [notice] Digest: generating secret for digest authentication ...
[Tue Jan 27 20:47:41 2009] [notice] Digest: done
[Tue Jan 27 20:47:42 2009] [notice] Apache/2.2.11 (Win32) DAV/2 mod_ssl/2.2.11 OpenSSL/0.9.8i mod_autoindex_color PHP/5.2.8 configured -- resuming normal operations
[Tue Jan 27 20:47:42 2009] [notice] Server built: Dec 10 2008 00:10:06
[Tue Jan 27 20:47:42 2009] [notice] Parent: Created child process 568
Apache server shutdown initiated...
Digest: generating secret for digest authentication ...
[Tue Jan 27 20:47:43 2009] [notice] Digest: done
[Tue Jan 27 20:47:43 2009] [notice] Child 568: Child process is running
[Tue Jan 27 20:47:43 2009] [notice] Child 568: Acquired the start mutex.
[Tue Jan 27 20:47:43 2009] [notice] Child 568: Starting 250 worker threads.
[Tue Jan 27 20:47:44 2009] [notice] Child 568: Starting thread to listen on port 443.
[Tue Jan 27 20:47:44 2009] [notice] Child 568: Starting thread to listen on port 80.
[Tue Jan 27 20:49:13 2009] [notice] Parent: Received shutdown signal -- Shutting down the server.
[Tue Jan 27 20:49:13 2009] [notice] Child 568: Exit event signaled. Child process is ending.
[Tue Jan 27 20:49:14 2009] [notice] Child 568: Released the start mutex
[Tue Jan 27 20:49:15 2009] [notice] Child 568: All worker threads have exited.
[Tue Jan 27 20:49:15 2009] [notice] Child 568: Child process is exiting
[Tue Jan 27 20:49:19 2009] [notice] Parent: Child process exited successfully.
[Tue Jan 27 20:50:41 2009] [notice] Digest: generating secret for digest authentication ...
[Tue Jan 27 20:50:41 2009] [notice] Digest: done
[Tue Jan 27 20:50:58 2009] [notice] Apache/2.2.11 (Win32) DAV/2 mod_ssl/2.2.11 OpenSSL/0.9.8i mod_autoindex_color PHP/5.2.8 configured -- resuming normal operations
[Tue Jan 27 20:50:58 2009] [notice] Server built: Dec 10 2008 00:10:06
[Tue Jan 27 20:50:58 2009] [notice] Parent: Created child process 1056
[Tue Jan 27 20:50:58 2009] [notice] Digest: generating secret for digest authentication ...
[Tue Jan 27 20:50:58 2009] [notice] Digest: done
[Tue Jan 27 20:50:59 2009] [notice] Child 1056: Child process is running
[Tue Jan 27 20:50:59 2009] [notice] Child 1056: Acquired the start mutex.
[Tue Jan 27 20:50:59 2009] [notice] Child 1056: Starting 250 worker threads.
[Tue Jan 27 20:50:59 2009] [notice] Child 1056: Starting thread to listen on port 443.
[Tue Jan 27 20:50:59 2009] [notice] Child 1056: Starting thread to listen on port 80.
[Tue Jan 27 20:53:27 2009] [error] [client 127.0.0.1] client denied by server configuration: C:/xampp/security/htdocs/lang.php, referer: http://localhost/xampp/navi.php
[Tue Jan 27 20:58:50 2009] [error] [client 127.0.0.1] client denied by server configuration: C:/xampp/security/htdocs/lang.php, referer: http://localhost/xampp/navi.php
[Tue Jan 27 20:59:04 2009] [error] [client 127.0.0.1] client denied by server configuration: C:/xampp/security/htdocs/lang.php, referer: http://localhost/xampp/navi.php
[Tue Jan 27 20:59:06 2009] [error] [client 127.0.0.1] client denied by server configuration: C:/xampp/security/htdocs/lang.php, referer: http://localhost/xampp/navi.php
[Tue Jan 27 20:59:06 2009] [error] [client 127.0.0.1] client denied by server configuration: C:/xampp/security/htdocs/lang.php, referer: http://localhost/xampp/navi.php
[Tue Jan 27 20:59:07 2009] [error] [client 127.0.0.1] client denied by server configuration: C:/xampp/security/htdocs/lang.php, referer: http://localhost/xampp/navi.php
[Tue Jan 27 20:59:14 2009] [error] [client 127.0.0.1] client denied by server configuration: C:/xampp/security/htdocs/lang.php, referer: http://localhost/xampp/navi.php
[Tue Jan 27 20:59:20 2009] [error] [client 127.0.0.1] client denied by server configuration: C:/xampp/security/htdocs/lang.php, referer: http://localhost/xampp/navi.php
[Tue Jan 27 21:10:47 2009] [error] [client 127.0.0.1] client denied by server configuration: C:/xampp/security/htdocs/lang.php, referer: http://localhost/xampp/navi.php
[Tue Jan 27 21:10:49 2009] [error] [client 127.0.0.1] client denied by server configuration: C:/xampp/security/htdocs/lang.php, referer: http://localhost/xampp/navi.php
[Tue Jan 27 21:11:01 2009] [error] [client 127.0.0.1] client denied by server configuration: C:/xampp/security/htdocs/lang.php, referer: http://localhost/xampp/navi.php
[Tue Jan 27 21:13:21 2009] [error] [client 127.0.0.1] client denied by server configuration: C:/xampp/security/htdocs/lang.php, referer: https://localhost/xampp/navi.php
[Tue Jan 27 21:13:26 2009] [error] [client 127.0.0.1] client denied by server configuration: C:/xampp/security/htdocs/lang.php, referer: https://localhost/xampp/navi.php
[Tue Jan 27 21:17:25 2009] [warn] pid file C:/xampp/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
[Tue Jan 27 21:17:25 2009] [notice] Digest: generating secret for digest authentication ...
[Tue Jan 27 21:17:25 2009] [notice] Digest: done
[Tue Jan 27 21:17:38 2009] [notice] Apache/2.2.11 (Win32) DAV/2 mod_ssl/2.2.11 OpenSSL/0.9.8i mod_autoindex_color PHP/5.2.8 configured -- resuming normal operations
[Tue Jan 27 21:17:38 2009] [notice] Server built: Dec 10 2008 00:10:06
[Tue Jan 27 21:17:38 2009] [notice] Parent: Created child process 1060
[Tue Jan 27 21:17:39 2009] [notice] Digest: generating secret for digest authentication ...
[Tue Jan 27 21:17:39 2009] [notice] Digest: done
[Tue Jan 27 21:17:39 2009] [notice] Child 1060: Child process is running
[Tue Jan 27 21:17:39 2009] [notice] Child 1060: Acquired the start mutex.
[Tue Jan 27 21:17:39 2009] [notice] Child 1060: Starting 250 worker threads.
[Tue Jan 27 21:17:39 2009] [notice] Child 1060: Starting thread to listen on port 443.
[Tue Jan 27 21:17:39 2009] [notice] Child 1060: Starting thread to listen on port 80.
[Tue Jan 27 22:02:19 2009] [error] [client 127.0.0.1] client denied by server configuration: C:/xampp/security/htdocs/lang.php, referer: http://127.0.0.1/xampp/navi.php
[Tue Jan 27 22:02:42 2009] [error] [client 127.0.0.1] client denied by server configuration: C:/xampp/security/htdocs/lang.php, referer: http://127.0.0.1/xampp/navi.php
[Tue Jan 27 22:14:30 2009] [error] [client 127.0.0.1] client denied by server configuration: C:/xampp/security/htdocs/lang.php, referer: http://127.0.0.1/xampp/navi.php
---------------------------------------------------------------------------------------------
Also i turned on Filezilla and Mercury and tried to log into security again made no difference

MySQL database ACTIVATED
PHP ACTIVATED
HTTPS (SSL) ACTIVATED
Common Gateway Interface (CGI) ACTIVATED
Server Side Includes (SSI) ACTIVATED
SMTP Service ACTIVATED
FTP Service ACTIVATED
-------------------------------------------------------------------------------------------------------
Problem still open.
sprinteroz
 
Posts: 6
Joined: 27. January 2009 11:43

Re: localhost security Access forbidden! Error 403

Postby Izzy » 27. January 2009 13:36

When you changed the conf file did you restart Apache?

Is there a lang.tmp file in the xampp\htdocs\xampp folder?
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: localhost security Access forbidden! Error 403

Postby sprinteroz » 27. January 2009 13:53

Izzy wrote:When you changed the conf file did you restart Apache?

Is there a lang.tmp file in the xampp\htdocs\xampp folder?


Thanks for your help Izzy your a champ, after i read your post i thought to myself did i restart Apache :?: and i was thinking yes I did. Then I thought to be sure I better shutdown my system and restart my whole system. After restarting I then started Apache and it went into security right away.

Thank you so much for your time, just doing that i feel i understand how this works a bit better now. 8)
Last edited by sprinteroz on 27. January 2009 14:07, edited 1 time in total.
sprinteroz
 
Posts: 6
Joined: 27. January 2009 11:43

Re: localhost security Access forbidden Error 403 *Win 2000Pro

Postby Izzy » 27. January 2009 13:59

Your very welcome and thanks for posting in such great detail - I wish more would do it as it saves so much time.

Good luck and please enjoy your XAMPP experience.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 44 guests