No php-switch.bat file

Problems with the Windows version of XAMPP, questions, comments, and anything related.

No php-switch.bat file

Postby bvoltz » 24. January 2009 08:12

I just finished installing using xampp 1.7.0 and applyed the patch, and as I'm going to test with oscommerce, it requires php4, and I do have a php-switch.bat file, I have done a search on the computer and the only file found was php-switch.php. What am I doing wrong?
bvoltz
 
Posts: 7
Joined: 24. January 2009 08:00

Re: No php-switch.bat file

Postby Izzy » 24. January 2009 08:27

bvoltz wrote:I just finished installing using xampp 1.7.0 and applyed the patch, and as I'm going to test with oscommerce, it requires php4, and I do have a php-switch.bat file, I have done a search on the computer and the only file found was php-switch.php. What am I doing wrong?
You are doing nothing wrong, it's just that there is nothing to switch to. :)

php4 is not included in 1.7.0 because it is no longer supported by PHP - php6 will be stable soon so it is time for osCommerce to upgrade their scripts to work with php5, but I thought they had already.

You would need to install an older XAMPP version, 1.6.8 for example, that has the switch bat file and php4 to switch to from php5.

Check out the XAMPP For Windows home page for a link to older versions at the SourceForge repository
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: No php-switch.bat file

Postby bvoltz » 24. January 2009 09:11

Many thanks...
bvoltz
 
Posts: 7
Joined: 24. January 2009 08:00


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 50 guests