apache error on xampp 1.7.0

Problems with the Windows version of XAMPP, questions, comments, and anything related.

apache error on xampp 1.7.0

Postby xpinx2pin » 21. January 2009 10:29

hi, i just want to tell that apache on xampp 1.7.0 error when i going to install magentocommerce script. I think It's caused by "php_pdo_mysql.dll" in xampp 1.7.0 had a little bug.

When i try install my magento using xampp 1.6.8 there is no problem.
xpinx2pin
 
Posts: 1
Joined: 21. January 2009 10:22

Re: apache error on xampp 1.7.0

Postby Izzy » 21. January 2009 10:41

See this topic for the fix:
viewtopic.php?f=16&t=32617
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: apache error on xampp 1.7.0

Postby tokyobaka » 21. January 2009 13:49

I am not sure that it is the right solution because after copying libmysql.dll I have a message in phpMyAdmin stating:
Your PHP MySQL library version 5.0.51a differs from your MySQL server version 5.1.30. This may cause unpredictable behavior.

I decided to keep using Magentocommerce with Xampp 1.6.8 with after seeing this message in phpMyAdmin
tokyobaka
 
Posts: 12
Joined: 10. May 2007 05:08
Location: Tokyo - Japan

Re: apache error on xampp 1.7.0

Postby Izzy » 22. January 2009 04:55

tokyobaka wrote:I am not sure that it is the right solution because after copying libmysql.dll I have a message in phpMyAdmin stating:
Your PHP MySQL library version 5.0.51a differs from your MySQL server version 5.1.30. This may cause unpredictable behavior.
It may not be the right solution for you because you have not revealed here any error message you received so it could be looked at and an advise offered - you obviously have some conflict with wamp or at least some residue left over in the registry or system folders if you uninstalled wamp.

The above link to the fix has worked for all that tried, except you, which obviously leads me to believe you have had other issues when installing XAMPP 1.7.0 that you failed to mention here.

It is always a good idea to post here the exact error messages and to look in the apache error logs for further clues - hoping that we here have a crystal ball is wishful thinking indeed. :)

For new forum members the forum search facility is a must to use before posting, as is reading the forum Announcements before proceeding into the forum topics.

Many guest that visit here use the forum search facility and quite often have no need to sign up to become members as they may have already found a solution to their problems from the search results.

BTW, most members who post here with XAMPP 1.7.0 issues have them resolved and can then proceed to use the latest and greatest XAMPP compilation - very few and can be counted on one finger, give up and revert to using an older version of XAMPP or indeed another inferior web server compilation.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: apache error on xampp 1.7.0

Postby tokyobaka » 22. January 2009 05:48

Hi
Well I uninstalled Xampp 1.7 completely. I have been using Xampp for years but it was the first time I have an issue with a script.
I installed Xampp 1.7 again and followed the instructions showed in the link
I downloaded : http://windows.php.net/downloads/snaps/ ... latest.zip

unziped it, then copied libmysql.dll into xampp\apache\bin and xampp\php. Restarted apache.

Here is my phpMyadmin display before doing the trick above:
MySQL
Server: localhost via TCP/IP
Server version: 5.1.30-community
Protocol version: 10
User: root@localhost
MySQL charset: UTF-8 Unicode (utf8)
Web server
Apache/2.2.11 (Win32) DAV/2 mod_ssl/2.2.11 OpenSSL/0.9.8j mod_autoindex_color PHP/5.2.8
MySQL client version: 5.1.30
PHP extension: mysql
phpMyAdmin
Version information: 3.1.1
Documentation
Wiki
Official Homepage
[ChangeLog] [Subversion] [Lists]

and after the trick:

MySQL
Server: localhost via TCP/IP
Server version: 5.1.30-community
Protocol version: 10
User: root@localhost
MySQL charset: UTF-8 Unicode (utf8)
Web server
Apache/2.2.11 (Win32) DAV/2 mod_ssl/2.2.11 OpenSSL/0.9.8j mod_autoindex_color PHP/5.2.8
MySQL client version: 5.0.51a
PHP extension: mysql
phpMyAdmin
Version information: 3.1.1
Documentation
Wiki
Official Homepage
[ChangeLog] [Subversion] [Lists]

As you can see before we have: MySQL client version: 5.1.30 and after we have MySQL client version: 5.0.51a . I did this on 2 different computers and had the same results. By the way I also noticed that the libmysql.dll that we are supposed to download is much lighter than the one that was inluded in Xampp so I suppose it is not the good solution nor the good file for the problem with PDO and Magentocommerce. And of course I still have the message in phpMyadmin:
Your PHP MySQL library version 5.0.51a differs from your MySQL server version 5.1.30. This may cause unpredictable behavior.


PS: all my other scripts using Xampp 1.7 work great: joomla, modx, wordpress, expression engine and PHPmyFAQ.
tokyobaka
 
Posts: 12
Joined: 10. May 2007 05:08
Location: Tokyo - Japan

Re: apache error on xampp 1.7.0

Postby Izzy » 22. January 2009 06:30

When you had 1.7.0 installed which php.ini file was being loaded?

Run http://localhost/xampp/phpinfo and look for the line Loaded Configuration File.

Paste back which file it mentions please.

Are there any more php.ini files on your PC and if so where are they?

I did a Google search for your phpMyAdmin error message.

BTW if all your other scripts work fine except for Magentocommerce then surely you would have better results by contacting the scripts web site or the scripts authors direct to have them sort out their script.

I have not had time to read these search results from the Magento home page for any relevant fixes, perhaps they could be read and a report posted back here.

BTW there is a patch available on the SourceForge repository and this post has the details:
viewtopic.php?f=16&t=32697&p=133185

It was in response to points raised in this topic:
viewtopic.php?f=12&t=32511
Last edited by Izzy on 22. January 2009 08:01, edited 5 times in total.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: apache error on xampp 1.7.0

Postby sunw » 22. January 2009 06:34

When I run upgrade script for MySQL for webERP, and having problems with the foreign key creation:

CONSTRAINT `audittrail_ibfk_1` FOREIGN KEY (`userid`) REFERENCES
`www_users` (`userid`);

But, it is OK if the script run in XAMPP 1.64.

any clue?
sunw
 
Posts: 1
Joined: 22. January 2009 04:31

Re: apache error on xampp 1.7.0

Postby Izzy » 22. January 2009 06:53

sunw wrote:When I run upgrade script for MySQL for webERP, and having problems with the foreign key creation:

CONSTRAINT `audittrail_ibfk_1` FOREIGN KEY (`userid`) REFERENCES
`www_users` (`userid`);

But, it is OK if the script run in XAMPP 1.64.

any clue?
Off topic in here, start a new thread please.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: apache error on xampp 1.7.0

Postby tokyobaka » 23. January 2009 06:34

Izzy wrote:When you had 1.7.0 installed which php.ini file was being loaded?

Loaded Configuration File C:\xampp\apache\bin\php.ini

BTW if all your other scripts work fine except for Magentocommerce then surely you would have better results by contacting the scripts web site or the scripts authors direct to have them sort out their script.

I did. I posted on Magento forum. I was not the only one. Another user with Xampp 1.7 and the same problem suggested to stay on Xampp 1.6.8. I am fine with Xampp 1.6.8 and I do not complain, I am just saying that changing libmysql.dll leaded to a warning in phpMyAdmin and I am wondering it other users got this message.
tokyobaka
 
Posts: 12
Joined: 10. May 2007 05:08
Location: Tokyo - Japan

Re: apache error on xampp 1.7.0

Postby Wiedmann » 23. January 2009 08:36

and the same problem

Which problem?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: apache error on xampp 1.7.0

Postby tokyobaka » 23. January 2009 10:16

Wiedmann wrote:Which problem?

As I said on another thread when Xampp 1.7 was released, there was a problem with Magentocommerce not working anymore. It was not Xampp fault because according to most users there was an issue with the PDO bug. It was posted also on PHP bug report here:
http://bugs.php.net/bug.php?id=39858
And on Magento board:
http://www.magentocommerce.com/boards/viewthread/26935/
http://www.magentocommerce.com/boards/v ... ad/26644/m
http://www.magentocommerce.com/boards/viewthread/26860/

According to Izzy I am the only one having a problem when coping libmysql.dll from http://windows.php.net/downloads/snaps/...latest.zip
I am just saying that on my 2 computers I have a message on phpMyadmin stating:
Your PHP MySQL library version 5.0.51a differs from your MySQL server version 5.1.30. This may cause unpredictable behavior.
It is not a problem for me, I am really fine working with Xampp 1.6.8. It works really good.
tokyobaka
 
Posts: 12
Joined: 10. May 2007 05:08
Location: Tokyo - Japan

Re: apache error on xampp 1.7.0

Postby Wiedmann » 24. January 2009 00:00

It was not Xampp fault

Well, the "libmysql.dll" from XAMPP 1.7.0 is also not working correct.

According to Izzy I am the only one having a problem when coping libmysql.dll from "http://windows.php.net/downloads/snaps/...latest.zip"

So it's allways a good idea to use the original "libmysql.dll" from PHP. You must not download this file. Just rename the file "libmysql_5.0.51a.dll" in XAMPP to "libmysql.dll".
(BTW: I prefer version 5.0.27 or 5.0.24a of this library.)

Your PHP MySQL library version 5.0.51a differs from your MySQL server version 5.1.30. This may cause unpredictable behavior.

Yeah, an ugly message in phpMyAdmin if you use an older library, and you can't disable it in the configuration. Well, forget this message ;-) (or patch phpMyAdmin to not show this)

there was a problem with Magentocommerce not working anymore.

With the copied "libmysql.dll" I was able to install Magentocommerce in XAMPP 1.7.0. And it seams to work with the test data. (sorry, no knowledge about this software)

there was an issue with the PDO bug. It was posted also on PHP bug report here:
"http://bugs.php.net/bug.php?id=39858"

Right, this is a bug in the "php_pdo_mysql" extension from PHP itself and still exists. I don't know if Magentocommerce is affected by this bug. (remember: installation works for me with a copied "libmysql.dll".)

BTW: From the documentation Magentocommerce can also use mysqli instead of PDO. Maybe that helps?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: apache error on xampp 1.7.0

Postby dmphotography » 24. January 2009 12:51

I just recently decided to go back and re-try installing each component individually as I did before finding XAMPP and giving up because I couldn't get phpMyAdmin to work. Since I've been using XAMPP, I've learned a substantial amount from this forum and I managed to work my way through the manual install method.

The newest PHP 5.2.8 has several library files that are misconfigured upon installation and after digging deep enough, I solved the riddle for most of them. And the same goes for the nice little message you are complaining about, which is nothing more than an eye sore as far as I can tell. The XAMPP developers put the fix in the XAMPP install by using an older version of the libmysql.dll instead of the newest version that comes with the latest PHP install.

I've written my findings in this post with a detailed explanation of how I best understand it and how to make it all look nice a pretty again.

http://forums.myownserver.info/viewtopic.php?f=13&t=13&sid=63c64988e4097489915fb2365ca238bf

I don't know why PHP produces installs with damaged libraries, and perhaps someone else can explain that one, but I've seen several more common errors with WAMP that were not corrected like they have been in XAMPP, so switching to that one is your choice.
For great video and written tutorials and guides on creating your own web server and installing things such as forums, blogs, etc., visit http://myownhomeserver.com
dmphotography
 
Posts: 191
Joined: 15. December 2008 14:25
Location: Columbus, MS
Operating System: Windows 7


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 65 guests