can't access new site folders in htdocs

Problems with the Windows version of XAMPP, questions, comments, and anything related.

can't access new site folders in htdocs

Postby dotman » 21. January 2009 02:48

I've put a couple of folders in the htdocs folder to test some sites locally, but I always get a 403 forbidden error. I've set permissions, and don't seem to have another installation of php as one member mentioned. Do I have to edit a config file? I can reach local host, and the xampp dir fine, but no others. Anything else I can try to get this working?
dotman
 
Posts: 11
Joined: 05. October 2008 02:38

Re: can't access new site folders in htdocs

Postby Izzy » 21. January 2009 03:00

What operating system (OS) is installed on your PC?

What version of XAMPP?

What error message is in the xampp\apache\logs\error.log file relating to the 403 error?

What are you typing in your browser to load these folders.

Do you have a .htaccess file in these folders perhaps?

All the above details should have been included in your first post or we will waste time finding out the answers to help with troubleshoot your issue.

You asked the same question back in November but did not respond to the reply you received:
viewtopic.php?f=16&t=31910

Usually a response will help others reading a topic to help with their own similar issue.

So kindly keep responding or help may not be offered in future.
Last edited by Izzy on 21. January 2009 03:09, edited 1 time in total.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: can't access new site folders in htdocs

Postby dotman » 21. January 2009 03:08

my apologies. i should have provided details:

XP Pro
XAMPP for Windows Version 1.5.4a
url: http://localhost/saxson/
url: http://localhost/saxson/index.html
no .htaccess file in that dir

here are the errors from today. I have tried editing the vhost file, but that didn't help.

[Tue Jan 20 19:38:15 2009] [error] [client 127.0.0.1] File does not exist: C:/Program Files/xampp/htdocs/saxon
[Tue Jan 20 19:38:33 2009] [error] [client 127.0.0.1] (OS 5)Access is denied. : file permissions deny server access: C:/Program Files/xampp/htdocs/saxson/index.html
[Tue Jan 20 19:39:08 2009] [error] [client 127.0.0.1] (OS 5)Access is denied. : file permissions deny server access: C:/Program Files/xampp/htdocs/saxson/index.html
[Tue Jan 20 19:45:04 2009] [error] [client 127.0.0.1] (OS 5)Access is denied. : file permissions deny server access: C:/Program Files/xampp/htdocs/saxson/index.html
[Tue Jan 20 19:45:06 2009] [error] [client 127.0.0.1] (OS 5)Access is denied. : file permissions deny server access: C:/Program Files/xampp/htdocs/saxson/index.html
[Tue Jan 20 19:45:31 2009] [error] [client 127.0.0.1] (OS 5)Access is denied. : file permissions deny server access: C:/Program Files/xampp/htdocs/saxson/index.html
[Tue Jan 20 19:47:04 2009] [error] [client 127.0.0.1] (OS 5)Access is denied. : file permissions deny server access: C:/Program Files/xampp/htdocs/saxson/index.html
[Tue Jan 20 20:02:02 2009] [error] [client 127.0.0.1] (OS 5)Access is denied. : file permissions deny server access: C:/Program Files/xampp/htdocs/saxson/index.html
[Tue Jan 20 20:02:35 2009] [notice] Parent: Received shutdown signal -- Shutting down the server.
[Tue Jan 20 20:02:35 2009] [notice] Child 1964: Exit event signaled. Child process is ending.
[Tue Jan 20 20:02:36 2009] [notice] Child 1964: Released the start mutex
[Tue Jan 20 20:02:38 2009] [notice] Child 1964: Waiting for 250 worker threads to exit.
[Tue Jan 20 20:02:38 2009] [notice] Child 1964: All worker threads have exited.
[Tue Jan 20 20:02:38 2009] [notice] Child 1964: Child process is exiting
[Tue Jan 20 20:02:41 2009] [notice] Parent: Child process exited successfully.
[Tue Jan 20 20:02:52 2009] [notice] Apache/2.2.3 (Win32) DAV/2 mod_ssl/2.2.3 OpenSSL/0.9.8d mod_autoindex_color PHP/5.1.6 configured -- resuming normal operations
[Tue Jan 20 20:02:52 2009] [notice] Server built: Sep 30 2006 21:24:06
[Tue Jan 20 20:02:52 2009] [notice] Parent: Created child process 3148
Warning: DocumentRoot [C:/xampp/htdocs/saxson] does not exist
[Tue Jan 20 20:02:53 2009] [notice] Child 3148: Child process is running
[Tue Jan 20 20:02:53 2009] [notice] Child 3148: Acquired the start mutex.
[Tue Jan 20 20:02:53 2009] [notice] Child 3148: Starting 250 worker threads.
[Tue Jan 20 20:02:53 2009] [notice] Child 3148: Starting thread to listen on port 443.
[Tue Jan 20 20:02:53 2009] [notice] Child 3148: Starting thread to listen on port 80.
[Tue Jan 20 20:02:58 2009] [error] [client 127.0.0.1] (OS 5)Access is denied. : file permissions deny server access: C:/Program Files/xampp/htdocs/saxson/index.html
[Tue Jan 20 20:03:05 2009] [error] [client 127.0.0.1] client denied by server configuration: C:/xampp
[Tue Jan 20 20:08:04 2009] [error] [client 127.0.0.1] client denied by server configuration: C:/xampp
[Tue Jan 20 20:08:06 2009] [error] [client 127.0.0.1] client denied by server configuration: C:/xampp
[Tue Jan 20 20:08:06 2009] [error] [client 127.0.0.1] client denied by server configuration: C:/xampp
[Tue Jan 20 20:09:51 2009] [error] [client 127.0.0.1] client denied by server configuration: C:/xampp
[Tue Jan 20 20:09:52 2009] [error] [client 127.0.0.1] client denied by server configuration: C:/xampp
[Tue Jan 20 20:09:53 2009] [error] [client 127.0.0.1] client denied by server configuration: C:/xampp
[Tue Jan 20 20:09:54 2009] [error] [client 127.0.0.1] client denied by server configuration: C:/xampp
[Tue Jan 20 20:09:55 2009] [error] [client 127.0.0.1] client denied by server configuration: C:/xampp
[Tue Jan 20 20:10:53 2009] [error] [client 127.0.0.1] client denied by server configuration: C:/xampp
[Tue Jan 20 20:11:33 2009] [error] [client 127.0.0.1] client denied by server configuration: C:/xampp
[Tue Jan 20 20:11:33 2009] [error] [client 127.0.0.1] client denied by server configuration: C:/xampp
[Tue Jan 20 20:11:41 2009] [error] [client 127.0.0.1] client denied by server configuration: C:/xampp
[Tue Jan 20 20:11:46 2009] [error] [client 127.0.0.1] client denied by server configuration: C:/xampp, referer: http://localhost/saxson
[Tue Jan 20 20:11:50 2009] [error] [client 127.0.0.1] client denied by server configuration: C:/xampp, referer: http://localhost/
[Tue Jan 20 20:11:52 2009] [error] [client 127.0.0.1] client denied by server configuration: C:/xampp, referer: http://localhost/
[Tue Jan 20 20:11:53 2009] [error] [client 127.0.0.1] client denied by server configuration: C:/xampp, referer: http://localhost/
[Tue Jan 20 20:11:54 2009] [error] [client 127.0.0.1] client denied by server configuration: C:/xampp, referer: http://localhost/
[Tue Jan 20 20:12:04 2009] [error] [client 127.0.0.1] client denied by server configuration: C:/xampp, referer: http://localhost/
[Tue Jan 20 20:12:05 2009] [error] [client 127.0.0.1] client denied by server configuration: C:/xampp, referer: http://localhost/
[Tue Jan 20 20:12:07 2009] [error] [client 127.0.0.1] client denied by server configuration: C:/xampp, referer: http://localhost/
[Tue Jan 20 20:12:08 2009] [error] [client 127.0.0.1] client denied by server configuration: C:/xampp, referer: http://localhost/
[Tue Jan 20 20:12:13 2009] [notice] Parent: Received shutdown signal -- Shutting down the server.
[Tue Jan 20 20:12:13 2009] [notice] Child 3148: Exit event signaled. Child process is ending.
[Tue Jan 20 20:12:14 2009] [notice] Child 3148: Released the start mutex
[Tue Jan 20 20:12:15 2009] [notice] Child 3148: Waiting for 250 worker threads to exit.
[Tue Jan 20 20:12:17 2009] [notice] Child 3148: All worker threads have exited.
[Tue Jan 20 20:12:17 2009] [notice] Child 3148: Child process is exiting
[Tue Jan 20 20:12:17 2009] [notice] Parent: Child process exited successfully.
[Tue Jan 20 20:12:19 2009] [notice] Apache/2.2.3 (Win32) DAV/2 mod_ssl/2.2.3 OpenSSL/0.9.8d mod_autoindex_color PHP/5.1.6 configured -- resuming normal operations
[Tue Jan 20 20:12:19 2009] [notice] Server built: Sep 30 2006 21:24:06
[Tue Jan 20 20:12:19 2009] [notice] Parent: Created child process 1868
[Tue Jan 20 20:12:21 2009] [notice] Child 1868: Child process is running
[Tue Jan 20 20:12:21 2009] [notice] Child 1868: Acquired the start mutex.
[Tue Jan 20 20:12:21 2009] [notice] Child 1868: Starting 250 worker threads.
[Tue Jan 20 20:12:21 2009] [notice] Child 1868: Starting thread to listen on port 443.
[Tue Jan 20 20:12:21 2009] [notice] Child 1868: Starting thread to listen on port 80.
[Tue Jan 20 20:13:47 2009] [error] [client 127.0.0.1] (OS 5)Access is denied. : file permissions deny server access: C:/Program Files/xampp/htdocs/saxson/index.html
[Tue Jan 20 20:15:22 2009] [error] [client 127.0.0.1] (OS 5)Access is denied. : file permissions deny server access: C:/Program Files/xampp/htdocs/saxson/index.html
[Tue Jan 20 20:41:55 2009] [error] [client 127.0.0.1] (OS 5)Access is denied. : file permissions deny server access: C:/Program Files/xampp/htdocs/saxson/index.html
[Tue Jan 20 20:49:14 2009] [error] [client 127.0.0.1] (OS 5)Access is denied. : file permissions deny server access: C:/Program Files/xampp/htdocs/saxson/tso.html
[Tue Jan 20 20:51:30 2009] [error] [client 127.0.0.1] (OS 5)Access is denied. : file permissions deny server access: C:/Program Files/xampp/htdocs/saxson/tso.html
[Tue Jan 20 20:51:39 2009] [error] [client 127.0.0.1] File does not exist: C:/Program Files/xampp/htdocs/saxson/html.html
[Tue Jan 20 20:51:48 2009] [error] [client 127.0.0.1] (OS 5)Access is denied. : file permissions deny server access: C:/Program Files/xampp/htdocs/saxson/index.html
[Tue Jan 20 20:52:34 2009] [error] [client 127.0.0.1] (OS 5)Access is denied. : file permissions deny server access: C:/Program Files/xampp/htdocs/saxson/index.html
[Tue Jan 20 20:53:28 2009] [error] [client 127.0.0.1] (OS 5)Access is denied. : file permissions deny server access: C:/Program Files/xampp/htdocs/saxson/index.html
[Tue Jan 20 20:53:29 2009] [error] [client 127.0.0.1] (OS 5)Access is denied. : file permissions deny server access: C:/Program Files/xampp/htdocs/saxson/index.html
[Tue Jan 20 20:53:30 2009] [error] [client 127.0.0.1] (OS 5)Access is denied. : file permissions deny server access: C:/Program Files/xampp/htdocs/saxson/index.html
[Tue Jan 20 20:53:31 2009] [error] [client 127.0.0.1] (OS 5)Access is denied. : file permissions deny server access: C:/Program Files/xampp/htdocs/saxson/index.html
dotman
 
Posts: 11
Joined: 05. October 2008 02:38

Re: can't access new site folders in htdocs

Postby Izzy » 21. January 2009 03:38

dotman wrote:...I've set permissions...
Please tell me exactly how you did that - very important?

Can you paste back here the corresponding parts that I have pasted below from your own httpd.conf file in the xampp\apache\conf folder please?

Your paths will be different as the pastes and paths are from my 1.6.8 version httpd.conf file.

BTW you are using a very old version of XAMPP 1.5.4a - never thought of installing a newer version - the latest is 1.7.0 ?

Code: Select all
#
# DocumentRoot: The directory out of which you will serve your
# documents. By default, all requests are taken from this directory, but
# symbolic links and aliases may be used to point to other locations.
#
DocumentRoot "C:/xampp/htdocs"

Code: Select all
#
# Each directory to which Apache has access can be configured with respect
# to which services and features are allowed and/or disabled in that
# directory (and its subdirectories).
#
# First, we configure the "default" to be a very restrictive set of
# features. 
#
<Directory />
    Options FollowSymLinks
    AllowOverride None
    Order deny,allow
    Deny from all
</Directory>

Code: Select all
#
# This should be changed to whatever you set DocumentRoot to.
#
<Directory "C:/xampp/htdocs">
    #
    # Possible values for the Options directive are "None", "All",
    # or any combination of:
    #   Indexes Includes FollowSymLinks SymLinksifOwnerMatch ExecCGI MultiViews
    #
    # Note that "MultiViews" must be named *explicitly* --- "Options All"
    # doesn't give it to you.
    #
    # The Options directive is both complicated and important.  Please see
    # http://httpd.apache.org/docs/2.2/mod/core.html#options
    # for more information.
    #
    Options MultiViews Indexes FollowSymLinks Includes ExecCGI
   
    #
    # AllowOverride controls what directives may be placed in .htaccess files.
    # It can be "All", "None", or any combination of the keywords:
    #   Options FileInfo AuthConfig Limit
    #
    AllowOverride All

    #
    # Controls who can get stuff from this server.
    #
    Order allow,deny
    Allow from all

</Directory>
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: can't access new site folders in htdocs

Postby dotman » 21. January 2009 03:59

You bet. I used filezilla to set permission on the folder to 755 using the newuser as the login.

I can absolutely upgrade. I see the uninstaller. I'll do that and install the latest version if you suggest. I missed I was so out of date.

Here's the code you requested from the httpd.conf:

#
# DocumentRoot: The directory out of which you will serve your
# documents. By default, all requests are taken from this directory, but
# symbolic links and aliases may be used to point to other locations.
#
DocumentRoot "C:/Program Files/xampp/htdocs"


#
# DocumentRoot: The directory out of which you will serve your
# documents. By default, all requests are taken from this directory, but
# symbolic links and aliases may be used to point to other locations.
#
DocumentRoot "C:/Program Files/xampp/htdocs"

#
# This should be changed to whatever you set DocumentRoot to.
#
<Directory "C:/Program Files/xampp/htdocs">
#
# Possible values for the Options directive are "None", "All",
# or any combination of:
# Indexes Includes FollowSymLinks SymLinksifOwnerMatch ExecCGI MultiViews
#
# Note that "MultiViews" must be named *explicitly* --- "Options All"
# doesn't give it to you.
#
# The Options directive is both complicated and important. Please see
# http://httpd.apache.org/docs/2.2/mod/core.html#options
# for more information.
#
Options Indexes FollowSymLinks Includes ExecCGI

#
# AllowOverride controls what directives may be placed in .htaccess files.
# It can be "All", "None", or any combination of the keywords:
# Options FileInfo AuthConfig Limit
#
AllowOverride All

#
# Controls who can get stuff from this server.
#
Order allow,deny
Allow from all

</Directory>
dotman
 
Posts: 11
Joined: 05. October 2008 02:38

Re: can't access new site folders in htdocs

Postby Izzy » 21. January 2009 04:08

You can't set file permissions in Windows using an FTP client you may do some damage which you may have done already according to your error messages.

Perhaps it is time to install a fresh version but read the instructions on the website and a tip is to make sure you save your relevant files from the htdocs folder of your existing version then delete the xampp folder before installing again - or simply drag the xampp folder while holding the Ctrl key to make a Copy of xampp which will keep intact all your files ready to copy over to the new install but don't copy over any xampp files only your own.

Use the EXE (7zip) version and extract to the C:\ drive which will create C:\xampp then double click on the setup_xampp.bat file in the xampp folder - don't install to a folder like Program Files as it has a space in the name and can cause issues.

Then test the new installation by exercising the demos found on the http://localhost pages.

Then if all is working as intended then you can copy over your files and folders and try out your web sites again - but remember don't try and change any file or folder permissions as on Windows this is not required but is is required on a Linux (*nix) based Apache web server.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: can't access new site folders in htdocs

Postby dotman » 21. January 2009 04:32

well I installed the new version on the C drive, (it was in programs before), can access all the demo apps, so I copied my site folder back into the htdocs folder, didn't touch any permissions and I still get a 403. Here's my error log:

[Tue Jan 20 22:22:51 2009] [notice] Apache/2.2.9 (Win32) DAV/2 mod_ssl/2.2.11 OpenSSL/0.9.8h mod_autoindex_color PHP/5.2.8 configured -- resuming normal operations
[Tue Jan 20 22:22:51 2009] [notice] Server built: Jun 14 2008 19:02:12
[Tue Jan 20 22:22:51 2009] [notice] Parent: Created child process 1464
[Tue Jan 20 22:22:52 2009] [notice] Child 1464: Child process is running
[Tue Jan 20 22:22:52 2009] [notice] Child 1464: Acquired the start mutex.
[Tue Jan 20 22:22:52 2009] [notice] Child 1464: Starting 250 worker threads.
[Tue Jan 20 22:22:52 2009] [notice] Child 1464: Starting thread to listen on port 443.
[Tue Jan 20 22:22:52 2009] [notice] Child 1464: Starting thread to listen on port 80.
[Tue Jan 20 22:25:25 2009] [error] [client 127.0.0.1] (OS 5)Access is denied. : file permissions deny server access: C:/xampp/htdocs/saxson/index.html
dotman
 
Posts: 11
Joined: 05. October 2008 02:38

Re: can't access new site folders in htdocs

Postby dotman » 21. January 2009 04:39

ok, that's interesting. i just copied another site folder and that loads fine. Not sure what it is about the saxson folder. Just odd.
dotman
 
Posts: 11
Joined: 05. October 2008 02:38

Re: can't access new site folders in htdocs

Postby Izzy » 21. January 2009 04:40

You still have the original folders in your previous xampp folder so delete the saxson site folder you just copied over.

Then create a new folder in the htdocs folder with the same name saxson but don't copy any files yet.

In the htdocs folder is an index.html file, copy that into your new saxson folder and then try and access in the same way as gave you the 403 error - http://localhost/saxson/index.html or http://localhost/saxson/

See if you get an error.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: can't access new site folders in htdocs

Postby dotman » 21. January 2009 04:46

yep, that worked. I can see the html file copied from the root in the newly created folder. should I copy the original files there now?

well I just copied over the original files, and got the 403, so there is something about those files that apache does not like.
dotman
 
Posts: 11
Joined: 05. October 2008 02:38

Re: can't access new site folders in htdocs

Postby Izzy » 21. January 2009 04:55

You jumped the gun.

Delete all the files you copied over except the index.html file from your original saxson folder.

Now test again and see if you get the 403 error with only your old index.html file in the saxson folder.

Then let me know and don't jump again till I have finished this little troubleshoot with you or your PC may explode into shrapnel bits. :)
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: can't access new site folders in htdocs

Postby dotman » 21. January 2009 05:02

yeah, that was stupid. Ok I deleted all the files from the saxon folder, and copied only the index.html file and I get the 403. I promise I won't touch a thing :)
dotman
 
Posts: 11
Joined: 05. October 2008 02:38

Re: can't access new site folders in htdocs

Postby Izzy » 21. January 2009 05:13

Ok thats fine.

Now right click on the index file and select Properties

Then select Security

Then look for any boxes that have a tick in the Deny column under any of the Group or user names.

If you are logged in as an Administrator then they should all be set to Allow - on my PC they are all set to Allow as I don't have any user that is not an Administrator.

You can then click on Advanced and make sure again Allow is the Type and Full Control is the Permissions also make sure the Inherit box is ticked.

Then if the Permissions are all Allow and you had to change things then try again to access the index file.

Fingers crossed. ;)
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: can't access new site folders in htdocs

Postby dotman » 21. January 2009 05:27

odd. still no go. Not sure if this is important, but the index.html file in the folder that works appears in type that is black (as you would expect), but the index.html file that is in the saxon folder is of the color green. Does that mean anything? the permissions are the same for the one that works and the one that doesn't.
dotman
 
Posts: 11
Joined: 05. October 2008 02:38

Re: can't access new site folders in htdocs

Postby dotman » 21. January 2009 05:31

that was it. when I click on advanced next to fileattributes), the box "encrypt contents to secure data" was checked. I sure didn't do that, but the file loads now. and no flying shrapnel :)
dotman
 
Posts: 11
Joined: 05. October 2008 02:38

Next

Return to XAMPP for Windows

Who is online

Users browsing this forum: Gharas and 61 guests