Unable to change passwords in http://localhost/security

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Unable to change passwords in http://localhost/security

Postby delirium » 20. January 2009 09:30

Hi to all.

I'm using xampp 1.7 on windows XP. The problem is that there's no fields below the table in http://localhost/security that lists my configuration as unsecure. At first I thought it was a browser problem, but it is not (I tried different browsers). I had already used xampp on Linux and I remember well that passwords could be changed that way (there was also a script, which I don't find for Windows).

I've tried reinstalling XAMPP, but the problem persists.

I couldn't find this topic in the forum: It seems that one can always set the security in http://localhost/security !

Thanks to all.
delirium
 
Posts: 6
Joined: 20. January 2009 09:13

Re: Unable to change passwords in http://localhost/security

Postby Izzy » 20. January 2009 09:34

Try clicking on the your language under the Languages menu item on the security page - sometimes there can be a few seconds delay before the page loads.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: Unable to change passwords in http://localhost/security

Postby delirium » 20. January 2009 09:45

Izzy wrote:Try clicking on the your language under the Languages menu item on the security page - sometimes there can be a few seconds delay before the page loads.


Well, I have seen the table in four different languages, but no form below. PHP seems to be correct, because I can execute the CD collection example in the main page. Any other idea?

Thanks for your help.
delirium
 
Posts: 6
Joined: 20. January 2009 09:13

Re: Unable to change passwords in http://localhost/security

Postby Izzy » 20. January 2009 10:00

What do you see below the Security Status Table when you scroll down?

Do you see this plus a list of ports?
To fix the problems for mysql, phpmyadmin and the xampp directory simply use

=> http://localhost/security/xamppsecurity.php <= [allowed only for localhost]
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: Unable to change passwords in http://localhost/security

Postby delirium » 20. January 2009 10:08

Izzy wrote:What do you see below the Security Status Table when you scroll down?
Do you see a this plus a list of ports?


No, and I don't know why, because inspecting the php file these list should be. There's nothing under the table.

The link you provided works. But I am curious: why I can't see those ports?
delirium
 
Posts: 6
Joined: 20. January 2009 09:13

Re: Unable to change passwords in http://localhost/security

Postby Izzy » 20. January 2009 10:14

All the files are in xampp\security\htdocs and there should be a xampp.js file.

If that file is there then do you have JavaScript disabled in your browser perhaps?

Is there a lang.tmp file in the above folder?
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: Unable to change passwords in http://localhost/security

Postby delirium » 20. January 2009 10:28

Izzy wrote:If that file is there then do you have JavaScript disabled in your browser perhaps?


That was my first thought. But now No-Script is off, Adblock plus is off and I have the same problem using other browsers, like IE. The page also spends a lot of time to load.

Izzy wrote:Is there a lang.tmp file in the above folder?


Yes, there is: en

Is that good?
delirium
 
Posts: 6
Joined: 20. January 2009 09:13

Re: Unable to change passwords in http://localhost/security

Postby Izzy » 20. January 2009 10:35

Yes the lang.tmp is fine and yes the page does take forever to load.

Here is what a default security.php file looks like in 1.0.7

Edited - removed the security.php paste to make the topic smaller and easier to read.

Copy and paste into a file and name it security.php then rename your security.php then try again and clear your browser's cache.

Please let me know if that fixes it.


BTW and just out of curiosity did you use the installer version to install 1.7.0 on your XP and does your XP have the SP3 installed?
Last edited by Izzy on 20. January 2009 12:29, edited 1 time in total.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: Unable to change passwords in http://localhost/security

Postby delirium » 20. January 2009 11:06

Izzy wrote:Please let me know if that fixes it.
BTW and just out of curiosity did you use the installer version to install 1.7.0 on your XP and does your XP have the SP3 installed?


Of course I let you know... you are helping a lot. But the files are identical and I have the same problem. Cache is cleared, NoScript uninstalled, XAMPP restarted....

I used the installer version first and I had the problem. Later I uninstalled XAMPP and installed the zip version. I also ran setup_xampp.bat
And yes, SP3 is installed. Should I complain to the microsofts guys? :)

Thanks.
delirium
 
Posts: 6
Joined: 20. January 2009 09:13

Re: Unable to change passwords in http://localhost/security

Postby Izzy » 20. January 2009 11:29

Complaining to MS would be like talking to a brick wall. :)

Make sure that 127.0.0.1 localhost is the first available line in C:\Windows\system32\drivers\etc\HOSTS file - drag into a text editor.

If you find this line in the HOSTS file:
::1 localhost
then comment it out to
# ::1 localhost


Now go to xampp\apache\conf\extra\httpd-xampp.conf file and change localhost to 127.0.0.1 in 2 places:

Alias /security
and
Alias /contrib

Save the file and restart Apache.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: Unable to change passwords in http://localhost/security

Postby delirium » 20. January 2009 12:07

Ok, now this is my: xampp\apache\conf\extra\httpd-xampp.conf file

(hosts file has only
127.0.0.1 localhost
)

Code: Select all
# XAMPP settings
#
<IfModule alias_module>
<IfModule mime_module>
    #ScriptAlias /php/ "C:/xampp/php/"
    #Action application/x-httpd-php "/php/php-cgi.exe"
    LoadModule php5_module "C:/xampp/apache/bin/php5apache2_2.dll"
    AddType application/x-httpd-php-source .phps
    AddType application/x-httpd-php .php .php5 .php4 .php3 .phtml .phpt

   <Directory "C:/xampp/htdocs/xampp">
      <IfModule php5_module>
         <Files "status.php">
            php_admin_flag safe_mode off
         </Files>
      </IfModule>
   </Directory>

    Alias /security "C:/xampp/security/htdocs/"
    <Directory "C:/xampp/security/htdocs">
      <IfModule php5_module>
         <Files "xamppsecurity.php">
            php_admin_flag safe_mode off
         </Files>
      </IfModule>
        Order deny,allow
        Deny from all
        Allow from 127.0.0.1
    </Directory>

    Alias /phpmyadmin "C:/xampp/phpMyAdmin/"
    <Directory "C:/xampp/phpMyAdmin">
        AllowOverride AuthConfig
        Order allow,deny
        Allow from all
    </Directory>

    Alias /webalizer "C:/xampp/webalizer/"
    <Directory "C:/xampp/webalizer">
      <IfModule php5_module>
         <Files "webalizer.php">
            php_admin_flag safe_mode off
         </Files>
      </IfModule>
        AllowOverride AuthConfig
        Order allow,deny
        Allow from all
    </Directory>

      Alias /contrib "C:/xampp/contrib/"
    <Directory "C:/xampp/contrib">
      <IfModule php5_module>
         <Files "webalizer.php">
            php_admin_flag safe_mode off
         </Files>
      </IfModule>

        Order deny,allow
        Deny from all
        Allow from 127.0.0.1
    </Directory>
</IfModule>
</IfModule>


# Access restriction via Remote
<IfModule auth_remote_module>
    <Directory "C:/xampp/htdocs/fonts">
    AllowOverride All
    AuthType           Basic
    AuthName           "AUTH REMOTE TEST"
    AuthRemoteServer   127.0.0.1
    AuthRemotePort     80
    AuthRemoteURL      /forbidden/
    Require            valid-user
    #User: user / Password: pass
</Directory>
</IfModule>

# Access restriction via MySQL
<IfModule mysql_auth_module>
<Location /restricted>
     AuthMySQLEnable On
    AuthName "MySQL Secured Place"
    AuthType Basic
    require valid-user
    AuthMySQLHost localhost
    AuthMySQLUser root
#    AuthMySQLPassword
    AuthMySQLDB webauth
    AuthMySQLUserTable user_pwd
    AuthMySQLNameField name
    AuthMySQLPasswordField pass
    AuthMySQLPwEncryption none
</Location>
</IfModule>


Re-started Apache and still don't see anything.

At first I was curious, but now I'm not. Now my configuration is not unsecure (as far I know) and I give up searching myself. If you had more ideas, I will prove: I would like to leave solved this thread!

Thanks for your help.
delirium
 
Posts: 6
Joined: 20. January 2009 09:13

Re: Unable to change passwords in http://localhost/security

Postby Izzy » 20. January 2009 12:15

That's fine.

Please post back to this topic if eventually you find what caused this as I am also curious after trying all the above and it still did not load.

Good luck.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06


Return to XAMPP for Windows

Who is online

Users browsing this forum: suze5544 and 63 guests