XAMPP Apache issue with Vista

Problems with the Windows version of XAMPP, questions, comments, and anything related.

XAMPP Apache issue with Vista

Postby oxygene13 » 18. January 2009 22:06

Hi ,

I'm going a bit spare atm trying to get XAMPP [or any packaged php/apache environment] to run properly on Windows Vista Home Premium.

the problem is that Apache just will not start in the services console. If I try to manually start apache in services I get a windows pop up telline me that an Error code 3 System cannot find specified path has occured. (can't find a deeper definition anywhere for this.)

On my initial install of XMAPP I did have a message saying that port 80 was already in use.

Can someone help me with this - I've tried a few suggetsions but nothing has fixed this and its sort of driving me mad and preventing me to progress with any work.

Some system details:
- Windows Vista Home Premium
- Norton internet Security running firewall
- UAC is disabled
- MySQL and FileZilla services seem to be running.

Id appreciate any pointers. Thanks,

NK
oxygene13
 
Posts: 2
Joined: 18. January 2009 21:56

Re: XAMPP Apache issue with Vista

Postby Goofy2k » 18. January 2009 22:11

I had a similar problem a few days ago.

Then I changed a setting in Skype. I prevented the program to use port 80 or 443. Problem solved. I got the advice elsewhere in the forum.
Goofy2k
 
Posts: 19
Joined: 09. December 2007 21:53

Re: XAMPP Apache issue with Vista

Postby oxygene13 » 18. January 2009 22:38

thanks.. ive tried the skype thing but this hasnt fixed it.

Any other pointers?
oxygene13
 
Posts: 2
Joined: 18. January 2009 21:56

Re: XAMPP Apache issue with Vista

Postby Goofy2k » 18. January 2009 22:53

I have understood from other threads in the forum that the problem can be caused by ANY program that uses port 80.

Does anyone have advice on how to find programs that use port 80 on a specific system?
Goofy2k
 
Posts: 19
Joined: 09. December 2007 21:53

Re: XAMPP Apache issue with Vista

Postby Izzy » 19. January 2009 03:47

The 2 culprits are usually Skype and IIS (Windows Internet Information Server).

To find the ports in use double click on xampp-portcheck.exe in the xampp folder, in Vista you need to run as Administrator by right clicking on the exe file.

Perhaps configure Vista so you are a Super Administrator:
http://www.winvistaclub.com/t12.html

Turn off UAC to use XAMPP features:
See Goofy2k's other post:
viewtopic.php?f=16&t=32915&start=0
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 72 guests