Mercury accepts only local clients

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Mercury accepts only local clients

Postby Joddi » 16. January 2009 13:39

I've got the error in Mercury SMTP server:
Code: Select all
553 We do not relay non-local mail, sorry


How to fix it? Thanks for assistance
Joddi
 
Posts: 9
Joined: 16. January 2009 13:38

Re: Mercury accepts only local clients

Postby glitzi85 » 16. January 2009 13:50

Joddi wrote:How to fix it? Thanks for assistance

Either you set Mercury up as an open relay, so everybody can send mail to everywhere or you use SMTP Authentification.

glitzi
User avatar
glitzi85
 
Posts: 1920
Joined: 05. March 2004 23:26
Location: Dahoim

Re: Mercury accepts only local clients

Postby Joddi » 16. January 2009 13:58

i'll wait for answer of professionals -_-

or i'll try to setup this mercury by myself =\
Joddi
 
Posts: 9
Joined: 16. January 2009 13:38

Re: Mercury accepts only local clients

Postby glitzi85 » 16. January 2009 14:06

You should now what you need. Do you want to use the Mailserver inside a LAN, or is it connected to the internet. Inside a LAN an open relay wouldn't matter unless you forward Port 25 from your Router, on the Internet this would mean you set up an Spamserver.

glitzi
User avatar
glitzi85
 
Posts: 1920
Joined: 05. March 2004 23:26
Location: Dahoim

Re: Mercury accepts only local clients

Postby Joddi » 16. January 2009 14:10

glitzi85 wrote:Do you want to use the Mailserver inside a LAN

No
glitzi85 wrote:is it connected to the internet

It's connected to the internet -_-
glitzi85 wrote:on the Internet this would mean you set up an Spamserver.

What should I do to avoid it?

Also, you're strange man =\\

PS: Can you just say how to fix this problem?
Joddi
 
Posts: 9
Joined: 16. January 2009 13:38

Re: Mercury accepts only local clients

Postby glitzi85 » 16. January 2009 14:31

It's not that easy. The behaviour of an Mailserver should be that he accepts mails for the domain he is responsible for. This mails will be saved on the hard disk. Mails for other domains he should only accept, when a valid username / passwor is provided, otherwise everybody on the world will be able to send possibly illegal mail over your Server. I think you don't want that.

OK, here a basic set up:

Configuration -> Mercury Core Modules then we configure the Tabs:

General: Change the field Internet Name to the Servername. Can be the domain, mostly used is something like mail.example.com

Local Domains: Add a new Domain. In the popping up window you must add localhost in the upperfield and your domain in the lower field.

Now close this window with OK. Next Module :

Configuration -> MercuryS SMTP Server

General: Set Announce myself as to the same value as the Name in the other window (mail.example.com), also enabel the option "Disable the SMTP VRFY command".

Connection Control: Enable "Do not permit SMTP relaying of non-local mail" and "Authenticated SMTP connections may relay mail". Then push the button "Add restriction" above and enter this values:

IP Address Range from 127.0.0.1
Select "Allow Connections"
Enable "Connections from this range may relay mail through this server"

Then close the window with OK.

Now you should be able to recieve mail for your Domain. Mails to other servers can be send by using SMTP Authentification in your E-Mail Program. Mails from 127.0.0.1 will be delivered without Authentification. That are Webserver scripts for example.

Important Information: I will not guarantee that this is a safe configuration. I think it will prevent from getting a spamserver, but i will not guarantee for it. It is in your responsibility to control the work of your settings and to check the mailserver logs regular to detect security holes. I point out explicit that a Mailserver should only be operated by someone who knows what he is doing!

glitzi
User avatar
glitzi85
 
Posts: 1920
Joined: 05. March 2004 23:26
Location: Dahoim

Re: Mercury accepts only local clients

Postby Joddi » 16. January 2009 14:57

Thanks for this.
Joddi
 
Posts: 9
Joined: 16. January 2009 13:38

Re: Mercury accepts only local clients

Postby Izzy » 16. January 2009 14:59

Hello Joddi

There is a forum over at Pegasus the home of Mercury that may be worth checking out:
http://community.pmail.com/forums/default.aspx

Also worth a read is this topic in the XAMPP For Windows English forum that covered a few aspects of getting Mercury up and running on the Internet:
viewtopic.php?f=16&t=32766

It may also contain some helpful clues, as the OP and I eventually ironed out some major issues with the blocking techniques used today by the receiving e-mail exchange servers and some ISPs, especially cable providers, to help prevent spam emanating from their clients which may have some of their IP blocks black listed.

Good luck with your project.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: Mercury accepts only local clients

Postby Joddi » 16. January 2009 17:17

Uuh... it's not working -_-

I gonna search on Pegasus
Joddi
 
Posts: 9
Joined: 16. January 2009 13:38

Re: Mercury accepts only local clients

Postby glitzi85 » 16. January 2009 18:42

If you would explain where you get this error message, then we would be able to help you. Like i said you must use SMTP Authentification if accessing the mailserver remote, on the box itself this message should not appear.

glitzi
User avatar
glitzi85
 
Posts: 1920
Joined: 05. March 2004 23:26
Location: Dahoim

Re: Mercury accepts only local clients

Postby Izzy » 17. January 2009 06:10

Joddi wrote:Uuh... it's not working
mercury mail server setup tutorial
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: Mercury accepts only local clients

Postby Joddi » 17. January 2009 08:56

When i'm sending mails from mail client to mail client, all is ok, but i cant send mails through my phpBB forum =\
Mercury says that my IP blocked

On my phpBB forum i'm using the same smtp like in my mail client (i was configured the users in mercury)
Joddi
 
Posts: 9
Joined: 16. January 2009 13:38

Re: Mercury accepts only local clients

Postby glitzi85 » 19. January 2009 14:17

It would be much easier to help if you would post the complete error message.

To use your local mailserver, please use this settings:

Open file xampp\apache\bin\php.ini search for the mail settings and set this values:

Code: Select all
[mail function]
SMTP = localhost
smtp_port = 25

sendmail_from = your@mail

; For Unix only.  You may supply arguments as well (default: "sendmail -t -i").
;sendmail_path = "C:\xampp\sendmail\sendmail.exe -t"

; Force the addition of the specified parameters to be passed as extra parameters
; to the sendmail binary. These parameters will always replace the value of
; the 5th parameter to mail(), even in safe mode.
;mail.force_extra_parameters =

Restart your Apache after that.

Log in to your phpBB and go to E-Mail Settings and set "Use SMTP Server for E-Mail" to No. Now your Mail should work.

glitzi
User avatar
glitzi85
 
Posts: 1920
Joined: 05. March 2004 23:26
Location: Dahoim


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 28 guests