Why is this getting in the way now...?

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Why is this getting in the way now...?

Postby mezloh » 16. January 2009 07:54

I have been using Xampp for about a year with no problems really. Well the other day i decided I wanted a mirror of one of my live wordpress sites on localhost so I could redesign the template.

Everything has worked out great. I can pull up my blog and see the home page, once I try to login is when I have problems. I am getting the error.

localhost:443 uses an invalid security certificate.

The certificate is not trusted because it is self signed.
The certificate expired on 12/4/2006 9:11 AM.

(Error code: sec_error_expired_issuer_certificate)

How do I get rid of this pain in the a**. and why is it all of a sudden showing up now and getting in the way? I never installed this certificate nor do I want it.

Can someone tell me how to bypass this certificate or to get rid of it all together. I am just testing out sites on my system locally and have no need for it. I can't seem to find and answer in this forum or by Googling the problem so hopefully someone can chime in with a fix.

This error shows up when I try to log in to wordpress by going to http://localhost/mysitesfolder/wp-admin or wp-login

This is the only time this has happened to me all other sites have worked perfectly without problems.

I am using the latest version of Xampp on Vista. Any help will be much appreciated.

Thanks
mezloh
 
Posts: 4
Joined: 16. January 2009 07:31

Re: Why is this getting in the way now...?

Postby glitzi85 » 16. January 2009 13:28

Just accept the certificate. The default localhost certificate from XAMPP is self signed, because it is just for testing. But on localhost this doesn't matter, as it would not be necessary to encrypt the data.

glitzi
User avatar
glitzi85
 
Posts: 1920
Joined: 05. March 2004 23:26
Location: Dahoim

Re: Why is this getting in the way now...?

Postby mezloh » 16. January 2009 15:18

I do not get an option to accept the certificate or not...?

There is an OK button on the box and clicking on either gets me nowhere. No results.

Can I go into the Xampp files and change the certificate? delete it? Change the expiration date, etc?

Or can I disable SSL period so it doesn't get in the way in the future.

Thanks

Travis
mezloh
 
Posts: 4
Joined: 16. January 2009 07:31

Re: Why is this getting in the way now...?

Postby Izzy » 16. January 2009 15:29

mezloh wrote:Or can I disable SSL period so it doesn't get in the way in the future.

You could try commenting out these lines in the xampp\apache\conf\httpd-conf file:
(drag into a text editor and make a copy of the file first in case of typos)

Near line 517-518
# Secure (SSL/TLS) connections
Include conf/extra/httpd-ssl.conf


So they look like this:
# Secure (SSL/TLS) connections
#Include conf/extra/httpd-ssl.conf

Save the file and restart Apache.

Please post back tell us if it works for you.

BTW IE has no accept certificate button but I believe Firefox and some other major browsers do.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: Why is this getting in the way now...?

Postby mezloh » 16. January 2009 15:52

Ok, It looks like progress is being made. So we are getting somewhere!


BTW I am using FF3

The popup is gone but not my browser is redirecting to https now so I am getting a "Failed To Connect "

Do I now have to add something to the .htaccess file or something so my browser is not trying to redirect to https?

Thanks you for your quick replies.

Travis
mezloh
 
Posts: 4
Joined: 16. January 2009 07:31

Re: Why is this getting in the way now...?

Postby Izzy » 16. January 2009 16:26

Travis,
You need really to find what is causing the redirect, perhaps in the WordPress script configuration as this may be the easiest and less complicated - you know the url that eventually turns to https try tracing back to the configuration where that url originates or does it do it to all URIs?

You may already have a .htaccess file in the WordPress folder that is performing the redirect from http to https.
Look for something like this if you find a .htaccess file.
RewriteEngine On
RewriteCond %{HTTPS} off
RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI}

Or paste the code here so it can be checked out as it may be possible to simply move the .htaccess out of the folder temporarily just to test if you lose the redirect to the https URI.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

RESOLVED: Why is this getting in the way now...?

Postby mezloh » 16. January 2009 16:58

I would like to thank you for your help. I finally got to the source of my problem. It finally clicked when i was browsing around the wordpress forums.

I have a plugin installed called Admin-ssl - so needless to say I deleted the plugin from my localhost install and guess what...?

Everything is working perfectly. I can log in and I am not getting redirected to https anymore.

I had forgotten that I installed that plugin, so I guess I made things harder than need be.

Your help is much appreciated. If you ever need any help with IM don't hesitate to email me for expert advice.

Take Care

Travis
mezloh
 
Posts: 4
Joined: 16. January 2009 07:31

Re: Why is this getting in the way now...?

Postby Izzy » 16. January 2009 17:09

Travis,
Great outcome and thanks for posting back with your solution - closing a topic like this helps the forum search results which, in turn, helps readers of this topic with similar issues find a resolution.
Stay lucky. :)
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 39 guests