Page 1 of 1

Cannot access Security

PostPosted: 13. January 2009 19:26
by Jaymie1989
Hi,

I just setup XAMPP again a when i go to http://localhost/security im getting a Error 403 Forbidden Access.

I have changed the security/htdocs to this and still nothing.

Code: Select all
Alias /security "C:/xampp/security/htdocs/"
    <Directory "C:/xampp/security/htdocs">
      <IfModule php5_module>
         <Files "xamppsecurity.php">
            php_admin_flag safe_mode off
         </Files>
      </IfModule>
        Allow Override AuthConfig
      Order allow,deny
      Allow from all
    </Directory>


Any ideas please?

Im using Windows Vista and UAC Is turned on BTW

Re: Cannot access Security

PostPosted: 14. January 2009 00:18
by dmphotography
Well first off, turn UAC off. I dunno why anyone would leave that annoying crap on. There's a program called WinPatrol that's free and will alert you of attempts to add stuff to window's startup if that's what you're worried about. It's no where near as annoying as UAC.

Secondly, you edited the wrong file. You should've edited httpd-xampp.conf located in /xampp/apache/conf/extra directory. There's two instances of Allow from localhost that you change to Allow from 127.0.0.1 . Be sure to restart Apache after making this change and saving it.

Whatever changes you made you should probably change back to avoid any further problems.

Re: Cannot access Security

PostPosted: 14. January 2009 00:39
by Izzy
Allowing all to access the security folders is a bad idea indeed and you need to change that back ASAP.

The fix for your issues are detailed in other posts and can easily be found from a forum search.

The fix from dmphotography is the correct one but there are 2 localhost entries to change.

Re: Cannot access Security

PostPosted: 14. January 2009 16:52
by Jaymie1989
Thanks I fixed it by re-reading this
In other words, the correct steps are:
1) open the file "\xampp\apache\conf\extra\httpd-xampp.conf" in a texteditor
2) replace "Allow from localhost" with "Allow from 127.0.0.1" (2 times)
3) save the file
4) restart Apache

Re: Cannot access Security

PostPosted: 14. January 2009 20:57
by dmphotography
Good! That was the same thing I had said to do. :D

Re: Cannot access Security

PostPosted: 16. January 2009 20:45
by X@MPP
yup id did the same and it worked :D :D :D :D :D :D :D :D :D :D