couldn't start apache with dbg-php at xampp 1.7

Problems with the Windows version of XAMPP, questions, comments, and anything related.

couldn't start apache with dbg-php at xampp 1.7

Postby hanpedro » 13. January 2009 08:45

I couldn't start apache with dbg-php at xampp 1.7.

My box is windows 7 x64 beta, and xampp 1.7

Without dbg-php-5.2.dll, apache can be started.
But, With dbg-php, it can't.

My dbg setting at php.ini is the under-mentioned;

Code: Select all
[debugger]
extension="K:\xampp\php\ext\dbg-php-5.2.dll"
debugger.enable_session_cookie=on
debugger.enabled=on
debugger.session_nocache=On
debugger.JIT_enabled=On
debugger.JIT_level=3
debugger.profiler_enabled=on
debugger.hosts_allow= 127.0.0.1 192.168.0.1 localhost btest.dyndns.org:8080
debugger.hosts_deny=ALL
debugger.ports=7869, 10000/16


What am I wrong?
hanpedro
 
Posts: 133
Joined: 09. February 2005 06:03
Operating System: SCientific Linux 6.1 x86

Re: couldn't start apache with dbg-php at xampp 1.7

Postby Izzy » 13. January 2009 08:59

With dbg-php enabled in your php.ini file run xampp\apache_start.bat file and read the error message why it Apache can't start.

Paste it here if you have difficulty understanding the error message.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: couldn't start apache with dbg-php at xampp 1.7

Postby hanpedro » 13. January 2009 09:10

Izzy wrote:With dbg-php enabled in your php.ini file run xampp\apache_start.bat file and read the error message why it Apache can't start.

Paste it here if you have difficulty understanding the error message.



Thank Izzy!

xampp\apache_start.bat works.

However I could not find any chages at xampp control pannel even pressing refresh.

K:\xampp>apache_start
Diese Eingabeforderung nicht waehrend des Running be
Bitte erst bei einem gewollten Shutdown schliessen
Please close this command only for Shutdown
Apache 2 is starting ...
hanpedro
 
Posts: 133
Joined: 09. February 2005 06:03
Operating System: SCientific Linux 6.1 x86

Re: couldn't start apache with dbg-php at xampp 1.7

Postby Izzy » 13. January 2009 09:13

Try commenting this section in xampp\apache\bin\php.ini file:
Code: Select all
[Zend]
zend_extension_ts = "C:\xampp\php\zendOptimizer\lib\ZendExtensionManager.dll"
zend_extension_manager.optimizer_ts = "C:\xampp2\php\zendOptimizer\lib\Optimizer"
zend_optimizer.enable_loader = 0
zend_optimizer.optimization_level=15
;zend_optimizer.license_path =
; Local Variables:
; tab-width: 4
; End:

so it looks like this - your paths may look different:
Code: Select all
[Zend]
zend_extension_ts = "C:\xampp\php\zendOptimizer\lib\ZendExtensionManager.dll"
;zend_extension_manager.optimizer_ts = "C:\xampp2\php\zendOptimizer\lib\Optimizer"
;zend_optimizer.enable_loader = 0
;zend_optimizer.optimization_level=15
;zend_optimizer.license_path =
; Local Variables:
; tab-width: 4
; End:

Save the file and then restart Apache if you can.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: couldn't start apache with dbg-php at xampp 1.7

Postby hanpedro » 13. January 2009 15:16

Commenting ZendExtensionManager was already done before inserting dbg-php lines..

Izzy wrote:Try commenting this section in xampp\apache\bin\php.ini file:
Code: Select all
[Zend]
zend_extension_ts = "C:\xampp\php\zendOptimizer\lib\ZendExtensionManager.dll"
zend_extension_manager.optimizer_ts = "C:\xampp2\php\zendOptimizer\lib\Optimizer"
zend_optimizer.enable_loader = 0
zend_optimizer.optimization_level=15
;zend_optimizer.license_path =
; Local Variables:
; tab-width: 4
; End:

so it looks like this - your paths may look different:
Code: Select all
[Zend]
zend_extension_ts = "C:\xampp\php\zendOptimizer\lib\ZendExtensionManager.dll"
;zend_extension_manager.optimizer_ts = "C:\xampp2\php\zendOptimizer\lib\Optimizer"
;zend_optimizer.enable_loader = 0
;zend_optimizer.optimization_level=15
;zend_optimizer.license_path =
; Local Variables:
; tab-width: 4
; End:

Save the file and then restart Apache if you can.
hanpedro
 
Posts: 133
Joined: 09. February 2005 06:03
Operating System: SCientific Linux 6.1 x86

Re: couldn't start apache with dbg-php at xampp 1.7

Postby Izzy » 14. January 2009 00:50

To save wasting any more time, what else have you tried to fix your problems?
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: couldn't start apache with dbg-php at xampp 1.7

Postby hanpedro » 14. January 2009 11:22

Izzy wrote:To save wasting any more time, what else have you tried to fix your problems?


Izzy,

Than you for your continuos replies.

I have reinstalled, and it's working now.
hanpedro
 
Posts: 133
Joined: 09. February 2005 06:03
Operating System: SCientific Linux 6.1 x86

Re: couldn't start apache with dbg-php at xampp 1.7

Postby Izzy » 14. January 2009 11:30

hanpedro wrote:Izzy,

Than you for your continuos replies.

I have reinstalled, and it's working now.
Your welcome and I am pleased that you now have your XAMPP working.

Often a reinstall fixes some of these seeming unsolvable issues.

Good luck.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 31 guests