changing permissions

Problems with the Windows version of XAMPP, questions, comments, and anything related.

changing permissions

Postby docweathers » 13. January 2009 07:48

I am running joomla 1.58 on Xampp 1.68 on windows xp sp3. I need to change permissions on parms.ini . From utilities in Joomla it says I have permissions 777 . However, I am also getting the message that this file is unwriteable. In fact windows shows it as read only. If I uncheck the read only from windows, something immediately changes it back to read only. Thus I cannot make configuration changes in Joomla running on windows xampp.

How do I change file permissions?

Thanks

Larry
docweathers
 
Posts: 13
Joined: 26. December 2007 00:20

Re: changing permissions

Postby Izzy » 13. January 2009 08:03

Go to the Joomla main folder and right click, select properties and un-tick the read only which usually has 3 positions ticked, un-ticked and a green square which is the default.

After removing the tick on the main Joomla folder click Apply then select to Apply changes to this folder, sub folders and files then click OK.

Now when you right click on the Joomla folder again and select properties, it should show the box filled in with the green square.

Now try and write to your script again.

BTW how are you trying to write to the script?

Also make sure you are logged in as administrator not a just as a user.

If you are logged as an administrator when you right click on the Joomla folder and select properties, select the Security tab and make sure that the allow column is grayed out and all the boxes are ticked - as admin you should have full permissions for your XP.

Fingers crossed. :)
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: changing permissions

Postby docweathers » 13. January 2009 19:56

I think I only partially understand your suggestion.
From Windows Explorer I right click on the joomla root folder and click permissions. It shows "read only" with a gray check. If I click on that to clear it and select Apply the check apply changes to this folder , subfolders and files. It runs a couple of minutes as if it is changing but really nothing changes.

There is no green square anywhere.

I am using Joomla 1.58 to try to write changes to a Joomla template parms.ini file.

I do not find a Security tab when I select properties.

I have tried having the folder set up to share on the network or not. Makes no difference.

I am logged in as the administrator

Thanks for your efforts.

Larry
docweathers
 
Posts: 13
Joined: 26. December 2007 00:20

Re: changing permissions

Postby Izzy » 14. January 2009 00:23

This is not an XAMPP issue but an OS issue so put this read only problem to the Windows forums or the Joomla forums for possibly a more authoritative response.

There is nothing you can do within XAMPP that relates to your read only problems.

Good luck with it and if it is any consolation I don't have this problem on my XP Windows box.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: changing permissions

Postby docweathers » 14. January 2009 00:32

thanks for giving it a try.
docweathers
 
Posts: 13
Joined: 26. December 2007 00:20

Re: changing permissions

Postby Izzy » 14. January 2009 02:02

docweathers wrote:thanks for giving it a try.
Larry, you're most welcome.

Please, if you do find a solution would you mind posting it back here so it may help others with a similar issue.
Thanks. :)
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: changing permissions

Postby glitzi85 » 15. January 2009 16:35

The read-only checkbox does not have any sense in NT-Systems, as they are using ACLs.

Is parms.ini a config file from an extension in joomla? In a normal Joomla Installation this file is not included!

glitzi
User avatar
glitzi85
 
Posts: 1920
Joined: 05. March 2004 23:26
Location: Dahoim


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 59 guests