Run Video on Apache 2.2.4 for Windows video wont run

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Run Video on Apache 2.2.4 for Windows video wont run

Postby jwor » 12. January 2009 05:18

I am on a Windows 2003 server O/S. Trying to get video to play with code:

<h3>Sharon Zukin Seminar</h3>

<td width="50%" class="txt_center">
<tr>
<OBJECT ID="MediaPlayer" WIDTH="420" HEIGHT="340" CLASSID="CLSID:22D6F312-B0F6-11D0-94AB-0080C74C7E95"
STANDBY="Loading Windows Media Player components..." TYPE="application/x-oleobject">
<PARAM NAME="FileName" VALUE="Zukin_seminar.avi">
<PARAM name="ShowControls" VALUE="true">
<param name="ShowStatusBar" value="false">
<PARAM name="ShowDisplay" VALUE="false">
<PARAM name="autostart" VALUE="false">
<EMBED TYPE="application/x-mplayer2" SRC="Zukin_seminar.avi" NAME="MediaPlayer"
WIDTH="4200" HEIGHT="340" ShowControls="1" ShowStatusBar="0" ShowDisplay="0" autostart="1"> </EMBED>
</OBJECT>

</td>
<br />
<br>
<br>
<h3>Description:</h3>
<p>Sharon Zukin speaking on 'Authentic Public Spaces Between Consumption and Democracy<br /><br />
<b>Approx. Running Time:</b> 27secs.</p>
But all I get is sound but no video - just a black screen

ANY IDEAS APPRECIATED. THANKS
jwor
 
Posts: 1
Joined: 12. January 2009 04:59

Re: Run Video on Apache 2.2.4 for Windows video wont run

Postby Izzy » 12. January 2009 05:53

TYPE="application/x-oleobject"
This may be the issue as it is not in the server's mime.type file.

Drag the xampp\apache\conf\mime.types file into a text editor and add this application/x-oleobject avi in with the other application/x- entries, in order if possible so that it look like this perhaps.
Code: Select all
application/x-netcdf            nc cdf
application/x-oleobject         avi
application/x-pkcs12            p12 pfx

Save the file and restart Apache - make a backup/copy of the file first.

See if that helps.

Also any error messages in the xampp\apache\logs\error.log file?

The only other avi mime type is this which you could try changing to in your script:
video/x-msvideo avi
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 41 guests