2 probs, 1st with apache, 2nd with cms

Problems with the Windows version of XAMPP, questions, comments, and anything related.

2 probs, 1st with apache, 2nd with cms

Postby saif3r » 11. January 2009 11:37

Hello,
i have 2 probs with the newest xammp ;/
1: after shutting down mysql and apache, when i try to run it again i got this msg:
Code: Select all
Diese Eingabeforderung nicht waehrend des Running beenden
Bitte erst bei einem gewollten Shutdown schliessen
Please close this command only for Shutdown
Apache 2 is starting ...
apache.exe: Syntax error on line 42 of D:/xampp/apache/conf/httpd.conf: ServerRoot
 must be a valid directory

Apache konnte nicht gestartet werden
Apache could not be started
Press any key. . .


2. Where should i put my folder with whole site ? i would like to be in folder like C:/xampp/MySite
and to be avaliable at http://localhost/index.php which is in MySite folder.
saif3r
 
Posts: 3
Joined: 11. January 2009 11:31

Re: 2 probs, 1st with apache, 2nd with cms

Postby Izzy » 11. January 2009 11:47

What does line 42 in the httpd.conf file look like?
Paste it here.

Did you use the installer version of XAMPP?

What OS?

The other issue may be resolved by creating an Alias for mysite in
.\xampp\apache\conf\extra\httpd-xampp.conf
Try and keep the folder all lower case as Apache and most things XAMPP are case sensitive, unlike Windows.

A forum search for Alias will have some more details perhaps.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: 2 probs, 1st with apache, 2nd with cms

Postby saif3r » 11. January 2009 11:51

Windows, yes i installed it according to readme file steps.

42line:
Code: Select all
ServerRoot "D:/xampp/apache"
saif3r
 
Posts: 3
Joined: 11. January 2009 11:31

Re: 2 probs, 1st with apache, 2nd with cms

Postby Izzy » 11. January 2009 11:59

saif3r wrote:Windows, yes i installed it according to readme file steps.
Windows what?

ServerRoot Syntax looks to be in order.

What is drive D, a network drive, a USB drive, a CD drive, or a regular partition?

Before starting Apache did you run xampp-portcheck.exe to make sure all ports that XAMPP requires are free?
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: 2 probs, 1st with apache, 2nd with cms

Postby saif3r » 11. January 2009 12:30

Windows XP SP3.
D is regular partition.
Yes, all ports are free.
saif3r
 
Posts: 3
Joined: 11. January 2009 11:31

Re: 2 probs, 1st with apache, 2nd with cms

Postby Izzy » 11. January 2009 12:40

saif3r wrote:ServerRoot "D:/xampp/apache"
Windows XP SP3.
D is regular partition.
Yes, all ports are free.
Everything looks fine from here.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 64 guests